LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 08-07-2005, 02:37 AM   #1
LaLinea
LQ Newbie
 
Registered: Aug 2005
Distribution: Suse 9.2
Posts: 9

Rep: Reputation: 0
SuSE 9.3 + wacom intuos 3 problem


Hi guys/gals,

This is my first ever post here, but I am regular visitor on this forum and I found many solutions to my Linux related problems here before.
I am not exactly a noob in using Linux (SuSE distro), and I know quite a lot about programming but I never dug into the Linux kernel/techy stuff before

So here's my problem. I finally managed to get my gf to switch OS from Windows to SuSE 9.3 and guess what, she likes it a lot ... but, she is an artist and so, obviously, she needs a support for her Wacom Intuos 3 tablet.
I searched these forums and Internet and I guess I got quite far with installing the darn thing, but now I'm totally stuck and I would appreciate any help from you Linux wizards.

I managed to get RPM package from Novell site(Linuxwacom RPM), installed it and it seems that the drivers installation went OK, as I can access the tablet's configuration panel from YAST. BUT, whatever I do there(settings, etc...) the tablet still reacts like a second mouse or something. I mean, I did switch the setting to "absolute" (from relative), and nothing. I looked through various answers and tutorials, tried to uninstall all mice from sax2(I think I followed the procedure I found here), then installed mouse again and added tablet. Still no change in behaviour. I tried to look into Linuxwacom source(to recompile the driver), but it seems, the documentation is not "detailed enough" for guys like me who are just barely starting to tinker with "Linux internals" - heck even the XF86Config doesn't exist in 9.3 (replaced by xorg.conf if I recall correctly) and small stuff like this. I am willing to try recompiling again(if really needed), but would really appreciate any pointers to the directions of a good step-by-step tutorial or maybe direct help in this thread.

So, anyone got any ideas of what I should do to make the tablet behave like, well, the tablet and not a mouse?

Cyber beer for anyone who can help me out here as I would really love to see my gf stay with Linux and not run away back to the "evil OS"

P.S. English is not my native language so I apologize for any mistakes in spelling, gramar, etc...
P.S. 2 : I hope Hardware is appropriate section for this thread. If not, then please move it to Linux-newbie or somewhere.
 
Old 08-14-2005, 04:05 PM   #2
jaei
LQ Newbie
 
Registered: Aug 2005
Posts: 2

Rep: Reputation: 0
Hi there,

if you have suse 9.3 then there is a linux driver included.

under

system - configuration sax2, there is an option to use your wacom graphire or intuos..

My graphire is working fine..

hope this helps

J
 
Old 08-21-2005, 04:54 AM   #3
LaLinea
LQ Newbie
 
Registered: Aug 2005
Distribution: Suse 9.2
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by jaei
Hi there,

if you have suse 9.3 then there is a linux driver included.

under

system - configuration sax2, there is an option to use your wacom graphire or intuos..

My graphire is working fine..

hope this helps

J
Tnx for reply mate but I already knew that. The problem is that it seems that mouse driver is hijacking the tablet or something(it looks that way). Tablet IS working but is behaving like a mouse on steroids. It only works in relative mode(no absolute mode even if you switch the absolute setting on in SAX2) and if you "fiddle" with tablet settings in SAX2, it seems like those settings are simply ignored by the system.

Thanks for reply anyways

Anyone else who might have an idea as to what the heck is going on? (still wasn't able to solve the problem)
 
Old 08-30-2005, 08:27 AM   #4
LaLinea
LQ Newbie
 
Registered: Aug 2005
Distribution: Suse 9.2
Posts: 9

Original Poster
Rep: Reputation: 0
OK guys let me try the different approach. I will again try to recompile/install the drivers from linuxwacom project and will ask about the specific errors/warnings/strange things I encounter.

So for the first one, I already noticed strange thing if following the documentation.
All is OK until the time when I have to execute xxd commands.



Code:
-- LINUXWACOM PROJECT DOCS : ----
We are interested in two devices, mouse0 and event0.

[root@ayukawa root]# cd /dev/input
[root@ayukawa input]# ls -la mouse0 event0
crw-------    1 root     root      13,  64 Aug 30 16:31 event0
crw-------    1 root     root      13,  32 Aug 30 16:31 mouse0
[root@ayukawa input]# xxd mouse0
xxd: mouse0: No such device
[root@ayukawa input]# xxd event0
xxd: event0: No such device
------------------
As soon as I execute xxd mouse0 ... the konsole stops responding and just waits(I need to use Ctrl-C to get back to prompt). So ...how do I approach this?
It says in the docs that you shold try rmmod evdev a few more times if that happens but if I do that I get "Module evdev does not exist........" message which kindda indicates that rmmod command worked. or am I just looking at these thing from the wrong angle?
Linux SuSE 9.3 with Kernel 2.6.11 is the system by the way.

Come on guys it must be some Linux guru here lurking about I'm desperate
 
Old 09-12-2005, 12:15 PM   #5
Unmindfulawe
Member
 
Registered: Aug 2005
Location: WI
Distribution: openSUSE 11.1/ TinyMe
Posts: 51

Rep: Reputation: 16
Ok, as you very well know the wacom drivers are going to a pain to configure correctly. I also obtained the rpm from Suse and it didn't do me much good in getting it configured properly. Leave it installed though. You said that you weren't getting any response from the command "xxd event0" Go ahead and try running these two commands.

rmmod wacom
modprobe wacom
tail /var/log/messages

The output for me was this

Sep 12 12:01:11 Linux kernel: input: Wacom Intuos2 4x5 on usb-0000:00:0b.1-1
Sep 12 12:01:11 Linux kernel: usbcore: registered new driver wacom
Sep 12 12:01:11 Linux kernel: drivers/usb/input/wacom.c: v1.40:USB Wacom Graphire and Wacom Intuos tablet driver

It effectively reloaded the wacom driver.
Now run this command

xxd /dev/input/event0

If you see a whole lot of activity you are now good. If not try the following commands
xxd /dev/input/event2
xxd /dev/input/event3
xxd /dev/input/event4
xxd /dev/input/event5
At first I got activity on event5 and there is a long process that you have to go through in order to resolve that problem. If you get activity on event0 then you will have to modify your /etc/X11/xorg.conf . SaX didn't configure it properly for me. (I didn't have any of the pressure sensitive features activated). But first,let me know how this initial part goes. I will do my best to help you through this install. It took me a good portion of a day to finally get it running correctly and I know how frustrating it can be.

Michael
 
Old 09-14-2005, 10:23 PM   #6
LaLinea
LQ Newbie
 
Registered: Aug 2005
Distribution: Suse 9.2
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Unmindfulawe
Ok, as you very well know the wacom drivers are going to a pain to configure correctly. I also obtained the rpm from Suse and it didn't do me much good in getting it configured properly. Leave it installed though. You said that you weren't getting any response from the command "xxd event0" Go ahead and try running these two commands.
Wow, I almost gave up on this. Let me first thank you here for your reply ...
OK then, I re-installed the RPM driver package and tried to do what you wrote.

Quote:
Originally posted by Unmindfulawe
rmmod wacom
modprobe wacom
tail /var/log/messages

The output for me was this

Sep 12 12:01:11 Linux kernel: input: Wacom Intuos2 4x5 on usb-0000:00:0b.1-1
Sep 12 12:01:11 Linux kernel: usbcore: registered new driver wacom
Sep 12 12:01:11 Linux kernel: drivers/usb/input/wacom.c: v1.40:USB Wacom Graphire and Wacom Intuos tablet driver

It effectively reloaded the wacom driver.
The first one(rmmod wacom) told me : Module wacom does not exist in /proc/modules.
Second (modprobe wacom) executed but no output.
Third (tail /var/log/messages) told me :
Code:
Sep 15 04:55:29 linux hal-subfs-mount[6812]: 
Sep 15 04:56:40 linux kernel: usbcore: registered new driver wacom
Sep 15 04:56:40 linux kernel: drivers/usb/input/wacom.c: v1.40:USB Wacom Graphir
e and Wacom Intuos tablet driver
So...I got kindda encouraged by the fact that something to do with the tablet was happening ...


Quote:
Originally posted by Unmindfulawe
Now run this command

xxd /dev/input/event0

If you see a whole lot of activity you are now good. If not try the following commands
xxd /dev/input/event2
xxd /dev/input/event3
xxd /dev/input/event4
xxd /dev/input/event5
At first I got activity on event5 and there is a long process that you have to go through in order to resolve that problem. If you get activity on event0 then you will have to modify your /etc/X11/xorg.conf . SaX didn't configure it properly for me. (I didn't have any of the pressure sensitive features activated). But first,let me know how this initial part goes. I will do my best to help you through this install. It took me a good portion of a day to finally get it running correctly and I know how frustrating it can be.
OK I did that and I got a response from the tablet on event3... so what am I supposed to do from here?

and tnx again for the help...

Last edited by LaLinea; 09-14-2005 at 10:26 PM.
 
Old 09-15-2005, 05:16 AM   #7
Unmindfulawe
Member
 
Registered: Aug 2005
Location: WI
Distribution: openSUSE 11.1/ TinyMe
Posts: 51

Rep: Reputation: 16
No problem at all for the response. It looks as though your driver is installed and ,for some reason, it isn't bound to event0 it's bound to event3. This shouldn't be an issue though. My tablet actually operates on event5. So, this is what you need to do from here...

Step 1.
Open your /etc/X11/xorg.conf file using your favorite editor.
(Be careful editing this file because if you get one setting incorrect your desktop will fail to initiate! Believe me I have made mistakes a couple of times and it wouldn't start up. You may want to save a copy of the xorg.conf file.)

You are going to want to delete the section that Sax created. It should look something like this....

Section "InputDevice"
Driver "wacom"
Identifier "Mouse[1]"
Option "BottomX" "30000"
Option "BottomY" "24000"
Option "Device" "/dev/input/event0"
Option "InputFashion" "Tablet"
Option "Mode" "Absolute"
Option "Name" "GRAPHIRE / INTUOS (USB)"
Option "SendCoreEvents" "on"
Option "Tilt" "on"
Option "Type" "cursor"
Option "USB" "on"
Option "Vendor" "WACOM"
EndSection

So, after your delete this part, go ahead to step2.

Step 2.

You have to add three sections into your xorg.conf file. Using the info that you gave me from the last post here's exactly what you want to add in place of what you deleted in Step1.

Section "InputDevice"
Identifier "Stylus1"
Driver "wacom"
Option "type" "stylus"
Option "Device" "/dev/input/event3"
Option "Mode" "Absolute"
Option "SendCoreEvents" "on"
Option "USB" "on"
Option "Vendor" "WACOM"
EndSection

Section "InputDevice"
Identifier "Cursor1"
Driver "wacom"
Option "type" "cursor"
Option "Device" "/dev/input/event3"
Option "Mode" "Absolute"
Option "SendCoreEvents" "on"
Option "USB" "on"
Option "Vendor" "WACOM"
EndSection

Section "InputDevice"
Identifier "Eraser1"
Driver "wacom"
Option "type" "cursor"
Option "Device" "/dev/input/event3"
Option "Mode" "Absolute"
Option "SendCoreEvents" "on"
Option "USB" "on"
Option "Vendor" "WACOM"
EndSection

You must add all of this if you want your tablet to work properly. But you're not done yet. :-) go on to step 3.

Step 3. Look for the portion of the xorg.conf file that looks like this....

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
EndSection

Go ahead and add the following so that it looks like this.......

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
InputDevice "Cursor1" "SendCoreEvents"
InputDevice "Stylus1" "SendCoreEvents"
InputDevice "Eraser1" "SendCoreEvents"
EndSection

Ok, now you are done editing the xorg.conf file. Go ahead and save the xorg.conf file and restart the xserver.
Once the server boots back up you should be in business. I am now able to use my stylus in Gimp and it has all of the pressure sensing features enabled. I am unsure of what image editing software that you are using but if you would like to know how to configure Gimp to use the pressure sensitive settings go ahead and open this page....

http://linuxwacom.sourceforge.net/index.php/howto/gimp

If you have any further questions please let me know and I may be able to answer them.

Michael
 
Old 09-16-2005, 12:42 AM   #8
LaLinea
LQ Newbie
 
Registered: Aug 2005
Distribution: Suse 9.2
Posts: 9

Original Poster
Rep: Reputation: 0
OK, it seems I will need to bother you some more Michael
I did the changes in xorg.conf and at first booting to system failed. Beeing curious and not wanting to bother you again if not really necessary, I took a look into log file. It said "no screens found" so I figured the problem was in ServerLayout thingy where the Screen identifier was missing(I got it in old file I copied for a backup). And voila...system booted just fine and Wacom tablet is responding, BUT, again like a mouse on steroids No absolute mode for starters, nothing. Still seems like mouse driver is hijacking the tablet or something I tried to run wacomcpl utility, but it refuses to start because it says :
Code:
wacomcpl: using TCLLIBPATH="[list  /usr/lib ]"

Error in startup script: X Error: 167 BadDevice, invalid or uninitialized input device

Error (5): WacomConfigOpenDevice: Failed to open device

Set: Failed to open device 'Cursor1'

    while executing

"exec xsetwacom set $dev FileModel"

    (procedure "createControls" line 25)

    invoked from within

"createControls"

    (file "/usr/bin/wacomcpl-exec" line 1010)
maybe it's best if I just copy my current xorg.conf file so you can take a look if everything is like it's supposed to be...
Code:
# /.../
# SaX generated X11 config file
# Created on: 2005-08-30T15:12:11+0100.
#
# Version: 4.8
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (4.8)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
  FontPath     "/usr/X11R6/lib/X11/fonts/misc:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/local"
  FontPath     "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/Type1"
  FontPath     "/usr/X11R6/lib/X11/fonts/URW"
  FontPath     "/usr/X11R6/lib/X11/fonts/Speedo"
  FontPath     "/usr/X11R6/lib/X11/fonts/PEX"
  FontPath     "/usr/X11R6/lib/X11/fonts/cyrillic"
  FontPath     "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/latin2/Type1"
  FontPath     "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/kwintv"
  FontPath     "/usr/X11R6/lib/X11/fonts/truetype"
  FontPath     "/usr/X11R6/lib/X11/fonts/uni:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/CID"
  FontPath     "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/hellas/Type1"
  FontPath     "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
  FontPath     "/usr/X11R6/lib/X11/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/ttyS0"
  InputDevices "/dev/ttyS1"
  InputDevices "/dev/ttyS2"
  InputDevices "/dev/ttyS3"
  InputDevices "/dev/ttyS4"
  InputDevices "/dev/ttyS5"
  InputDevices "/dev/ttyS6"
  InputDevices "/dev/ttyS7"
  InputDevices "/dev/ttyS8"
  InputDevices "/dev/psaux"
  InputDevices "/dev/logibm"
  InputDevices "/dev/sunmouse"
  InputDevices "/dev/atibm"
  InputDevices "/dev/amigamouse"
  InputDevices "/dev/atarimouse"
  InputDevices "/dev/inportbm"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/mouse"
  InputDevices "/dev/usbmouse"
  InputDevices "/dev/adbmouse"
  InputDevices "/dev/input/mice"
  InputDevices "/dev/input/event0"
  InputDevices "/dev/pointer0"
  InputDevices "/dev/pointer1"
  InputDevices "/dev/pointer2"
  InputDevices "/dev/pointer3"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail"
  Option       "RandR" "on"
EndSection

Section "Module"
  Load         "dbe"
  Load         "type1"
  Load         "freetype"
  Load         "extmod"
  Load         "glx"
  Load         "v4l"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "si,si"
  Option       "XkbModel" "btc9000a"
  Option       "XkbRules" "xfree86"
  Option       "XkbVariant" "xfree86"
EndSection

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Device" "/dev/input/mice"
  Option       "Emulate3Buttons" "on"
  Option       "EmulateWheel" "on"
  Option       "EmulateWheelButton" "4"
  Option       "InputFashion" "Mouse"
  Option       "Name" "PS/2-Mouse;MouseManPlusPS/2"
  Option       "Protocol" "MouseManPlusPS/2"
  Option       "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
  Option       "CalcAlgorithm" "CheckDesktopGeometry"
  DisplaySize  340 270
  HorizSync    30-96
  Identifier   "Monitor[0]"
  ModelName    "106030"
  VendorName   "BELINEA"
  VertRefresh  50-160
  UseModes     "Modes[0]"
EndSection

Section "Modes"
  Identifier   "Modes[0]"
  Modeline 	"1024x768" 131.43 1024 1096 1208 1488 768 769 772 821
  Modeline 	"800x600" 64.06 800 840 968 1040 600 612 621 648 +HSync +VSync
EndSection

Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1024x768" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1024x768" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1280x960" "1280x800" "1280x768" "1152x864" "1024x768" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      32
    Modes      "1024x768" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1024x768" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection

Section "Device"
  BoardName    "GeForce4 Ti 4200"
  BusID        "1:0:0"
  Driver       "nvidia"
  Identifier   "Device[0]"
  Screen       0
  Option       "Rotate" "off"
  VendorName   "NVidia"
EndSection

Section "InputDevice"
  Identifier   "Stylus1"
  Driver       "wacom"    
  Option       "type" "stylus"      
  Option       "Device" "/dev/input/event3"
  Option       "Mode" "Absolute"
  Option       "SendCoreEvents" "on"
  Option       "USB" "on"	      
  Option       "Vendor" "WACOM"	
EndSection

Section "InputDevice"
  Identifier   "Cursor1"
  Driver       "wacom"    
  Option       "type" "cursor"      
  Option       "Device" "/dev/input/event3"	
  Option       "Mode" "Absolute"	  
  Option       "SendCoreEvents" "on"	    
  Option       "USB" "on"	      
  Option       "Vendor" "WACOM"		
EndSection
		
Section "InputDevice"		
  Identifier   "Eraser1"		  
  Driver       "wacom"		    
  Option       "type" "cursor"		      
  Option       "Device" "/dev/input/event3"
  Option       "Mode" "Absolute"			  
  Option       "SendCoreEvents" "on"			    
  Option       "USB" "on"			      
  Option       "Vendor" "WACOM"			
EndSection

Section "ServerLayout"
  Identifier      "Layout[all]"
  InputDevice     "Keyboard[0]" "CoreKeyboard"    
  InputDevice     "Mouse[1]" "CorePointer"      
  Option          "Clone" "off"	
  Option          "Xinerama" "off"	  
  InputDevice     "Cursor1" "SendCoreEvents"	    
  InputDevice     "Stylus1" "SendCoreEvents"	      
  InputDevice     "Eraser1" "SendCoreEvents"		
  Screen          "Screen[0]"
EndSection

Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
EndSection
And again, thanks for your help mate.
 
Old 09-18-2005, 01:16 AM   #9
Unmindfulawe
Member
 
Registered: Aug 2005
Location: WI
Distribution: openSUSE 11.1/ TinyMe
Posts: 51

Rep: Reputation: 16
Hmm, it does seem as though the mouse driver is taking control. And the reason I agree with you is this...

Your system...

Sep 15 04:55:29 linux hal-subfs-mount[6812]:
Sep 15 04:56:40 linux kernel: usbcore: registered new driver wacom
Sep 15 04:56:40 linux kernel: drivers/usb/input/wacom.c: v1.40:USB Wacom Graphir
e and Wacom Intuos tablet driver

my system...
Sep 12 12:01:11 Linux kernel: input: Wacom Intuos2 4x5 on usb-0000:00:0b.1-1 <---- the kernel recognized the tablet here.
Sep 12 12:01:11 Linux kernel: usbcore: registered new driver wacom
Sep 12 12:01:11 Linux kernel: drivers/usb/input/wacom.c: v1.40:USB Wacom Graphire and Wacom Intuos tablet driver

When I unloaded and then reloaded the wacom driver my system then recognized my tablet. Yours did not. Which may mean that your mouse driver is taking control. But all hope isn't lost. There's a way to stop the kernel from recognizing your tablet as a mouse device and that information is contained at this link....

http://linuxwacom.sourceforge.net/in...p/howto/noctrl

I would download the driver from the wacom project...

http://linuxwacom.sourceforge.net/index.php/dl

Unpack the driver to a directory . Go to the console and do this....

cd <to the directory that you unpacked the driver to>

./configure --enable-hid --enable-usbmouse --enable-evdev --enable-mousedev

make

make install

This should install the necessary components that are needed to get your tablet working. After installing the driver again go ahead and change your xorg.conf file the way I discussed in the previous posts and then you should be able to use the tablet with full functionality. If this doesn't work then I'm uncertain as to what is causing the problem. I hope that this helps.

Michael
 
Old 09-18-2005, 01:52 AM   #10
LaLinea
LQ Newbie
 
Registered: Aug 2005
Distribution: Suse 9.2
Posts: 9

Original Poster
Rep: Reputation: 0
OK, I downloaded the driver from linuxwacom site and followed your instructions. But now I stumbled to another problem and that is an error while the thing is executing the make command.
Compiling stops in the middle fo the process and returns this error :
Code:
...
... tons of messages
...
Making all in 2.6.11
make[3]: Entering directory `/home/spot/tempwacom/linuxwacom-0.6.8/src/2.6.11'
    Building linuxwacom drivers for 2.6 kernel.
***Note: Drivers not enabled as modules in your kernel config but requested through configure are NOT built
make -C /usr/src/linux M=/home/spot/tempwacom/linuxwacom-0.6.8/src/2.6.11
make[4]: Entering directory `/usr/src/linux-2.6.11.4-20a'
/home/spot/tempwacom/linuxwacom-0.6.8/src/2.6.11/Makefile:69: *** You requested to build mousedev with configure, but mousedev is not a module in your kernel config.  Stop.
make[4]: *** [_module_/home/spot/tempwacom/linuxwacom-0.6.8/src/2.6.11] Error 2
make[4]: Leaving directory `/usr/src/linux-2.6.11.4-20a'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/home/spot/tempwacom/linuxwacom-0.6.8/src/2.6.11'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/spot/tempwacom/linuxwacom-0.6.8/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/spot/tempwacom/linuxwacom-0.6.8'
make: *** [all] Error 2
Apparently this stops the process : ** You requested to build mousedev with configure, but mousedev is not a module in your kernel config. Stop.

Any ideas? (and I really feel stupid at this point )
 
Old 09-18-2005, 02:56 PM   #11
Unmindfulawe
Member
 
Registered: Aug 2005
Location: WI
Distribution: openSUSE 11.1/ TinyMe
Posts: 51

Rep: Reputation: 16
The plot thickens. Well, what I would suggest is to run the

./configure --enable-hid --enable-usbmouse --enable-evdev --enable-mousedev

again and notice if you get any errors during the execution of that command. If that is the case then chances are you may be missing a package of some sort. I would unpack the package again and start with a clean set of files. Let me know how this goes. When you run the command from above you will have to scroll up to see if you are missing any packages. It will let you know by displaying errors.

Michael
 
Old 09-19-2005, 02:36 AM   #12
LaLinea
LQ Newbie
 
Registered: Aug 2005
Distribution: Suse 9.2
Posts: 9

Original Poster
Rep: Reputation: 0
OK this is gonna be long, but I reckon better this than for me to miss something important.
Here's the output from the configure command :
Code:
linux:/home/spot/tempwacom/linuxwacom-0.6.8 # ./configure --enable-hid --enable-usbmouse --enable-evdev --enable-mousedev
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for gawk... (cached) gawk
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for ld used by GCC... /usr/i586-suse-linux/bin/ld
checking if the linker (/usr/i586-suse-linux/bin/ld) is GNU ld... yes
checking for /usr/i586-suse-linux/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependant libraries... pass_all
checking command to parse /usr/bin/nm -B output... ok
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for ranlib... ranlib
checking for strip... strip
checking for objdir... .libs
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.lo... yes
checking if gcc supports -fno-rtti -fno-exceptions... no
checking whether the linker (/usr/i586-suse-linux/bin/ld) supports shared libraries... yes
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking whether -lc should be explicitly linked in... no
creating libtool
checking for processor type... i686
checking for kernel type... Linux
checking for linux-based kernel... yes
checking for kernel sources... /usr/src/linux
checking for kernel module versioning... yes
checking for gtk-config... no
checking for pkg-config... yes
checking pkg-config for gtk+-2.0... yes
checking for GTK version... 2.6.4
checking for X lib directory... found
checking for tclsh... /usr/bin/tclsh
checking for tcl version... 8.4
checking for tcl header files... /usr/include/
checking for tk header files... found
checking ncurses.h usability... yes
checking ncurses.h presence... yes
checking for ncurses.h... yes
***
*** WARNING:
*** Unable to compile wacom_drv.o without XF86 build environment
*** or Xorg SDK.
*** wacom_drv.o will not be built
***
checking for updated field names in hid-core.c... yes, using 2.6.11
checking for HID_QUIRK... missing, assuming quirks are OK
checking if gcc accepts -fno-merge-constants... yes

configure: creating ./config.status
config.status: creating Makefile
config.status: creating mkxincludes
config.status: creating src/Makefile
config.status: creating src/2.4/Makefile
config.status: creating src/2.4.22/Makefile
config.status: creating src/2.6/Makefile
config.status: creating src/2.6.2/Makefile
config.status: creating src/2.6.3/Makefile
config.status: creating src/2.6.4/Makefile
config.status: creating src/2.6.5/Makefile
config.status: creating src/2.6.6/Makefile
config.status: creating src/2.6.7/Makefile
config.status: creating src/2.6.8/Makefile
config.status: creating src/2.6.9/Makefile
config.status: creating src/2.6.10/Makefile
config.status: creating src/2.6.11/Makefile
config.status: creating src/wacomxi/Makefile
config.status: creating src/wacomxi/wacomcpl
config.status: creating config.h
config.status: executing depfiles commands

----------------------------------------
  BUILD ENVIRONMENT:
       architecture - i686
       linux kernel - yes 2.6.11
  module versioning - yes -DCONFIG_MODVERSIONS -DMODVERSIONS -include /usr/src/linux/include/linux/modversions.h
      kernel source - yes /usr/src/linux
           Xorg SDK - no
          XSERVER64 - no
               XLib - yes /usr/X11R6/lib
                TCL - yes /usr/include/
                 TK - yes /usr
            ncurses - yes
                GTK - 2.6.4

  BUILD OPTIONS:
            wacom.o - no
            wacdump - yes
             xidump - yes
        libwacomcfg - yes
         libwacomxi - yes
          xsetwacom - yes
              hid.o - yes
         usbmouse.o - yes
            evdev.o - yes
         mousedev.o - yes
            input.o - no
        tabletdev.o - no
        wacom_drv.o - no
----------------------------------------
There is a warning that wacom_drv.o cannot be build without XF86 build environment or Xorg SDK. I checked the system and it seem that XORG-X11 SDK is installed(if that is what we are talking about here) and as far as XF86 is concerned, there is installation of xf86tools on the system (if, again, that is actually what this warning is referring to).

Any idea on what is wrong here?
 
Old 09-19-2005, 02:46 AM   #13
LaLinea
LQ Newbie
 
Registered: Aug 2005
Distribution: Suse 9.2
Posts: 9

Original Poster
Rep: Reputation: 0
Hm, and actually after some more research on the wacomlinux project this catched my eye :

For kernel 2.6, you need to configure the kernel modules (wacom, hid, mousedev, usbmouse, evdev) under your kernel source directory before configuring linuxwacom.

Maybe this has something to do with the error? (as it says You requested to build mousedev with configure, but mousedev is not a module in your kernel config. Stop.)??
 
Old 09-23-2005, 06:52 PM   #14
Unmindfulawe
Member
 
Registered: Aug 2005
Location: WI
Distribution: openSUSE 11.1/ TinyMe
Posts: 51

Rep: Reputation: 16
Hmm, I'm unsure what exactly they are talking about by building those different modules before installing the driver. There's one more thing that I can think of though. Just try installing the driver ,and seeing that the XORG-X11 SDK package is the one you are looking for, try using the following command.

./configure --enable-wacom --with-xorg-sdk="The directory where your SDK file is located"

int my case the command was like this.

./configure --enable-wacom --with-xorg-sdk=/usr/X11R6/lib/Server

the portion that says "--with-xorg-sdk=/usr/X11R6/lib/Server" tells where your Xorg sdk package is located. If you are uncertain where yours is located do a search for the file "xf86Version.h". There is one strange thing though. In my case my xf86Version.h file was located in the directory /usr/X11R6/lib/Server/include . but notice you don't need to place /include at the end of where the directory is actually located it automatically does that for you and placing it there would only create more errors. I hope that this helps out.

Michael
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
WACOM Intuos.3 A5 tablet kxs Linux - Hardware 6 02-06-2007 02:49 PM
Wacom tablet for Suse Pro 9.2 maelstrom209 SUSE / openSUSE 8 06-25-2006 10:10 AM
Wacom Intuos 2 & Fedora 4 oryeen Linux - Hardware 0 10-27-2005 10:37 AM
wacom intuos seria tablet installation problem pirozzi Linux - Hardware 1 01-14-2004 11:17 AM
Wacom Tablet and wacom drivers Mallow005 Linux - General 1 12-27-2002 02:26 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 04:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration