-   Linux - Hardware (
-   -   SuSE 9.3 USB Flash Drive Auto Mount Stopped Working (

nuro305 04-10-2006 04:09 PM

SuSE 9.3 USB Flash Drive Auto Mount Stopped Working
Hey Dudes/Dudets,

I have SuSE 9.3 and my USB Flash drive always worked, plug it in, little icon popped up and it was available with proper permissions.

Today it does not mount. I can mount it and see it with the MOUNT command as /dev/sda1 (wrong perms)

Can anyone think of a setting YAST, KDE or otherwise, I may have changed to cause this?

All I have done lately is get all On-Line updates and change the Security settings to "Networked Workstation" in YAST and did an iptables -F (the latter messed up a few Deamons I had to restart)

Is this a SuSE Security issue I messed up?

I tested the drive in Windows and it warks fine there...


burntfuse 04-11-2006 01:43 PM

I think SuSE uses automount to mount drives (someone please correct me if I'm wrong). Try opening a terminal and typing "ps -ef | grep 'automountd'" to make sure it's running. If it is, then it's probably something harder to solve.

nuro305 04-11-2006 03:58 PM

Cool, now were getting somewhere........

The command of ps -ef | grep 'automountd' returns:
myusername 10361 10352 0 14:03 pts/1 00:00:00 grep automountd
Seems like it's there but I can't tell if it's running.

I went into YAST/System/Services and found an autofs service and it was NOT running. When I tried to start it I got:

/etc/init.d/autofs start returned 6 (program is not configured):
Starting service automounter ("files nis" does not provide any mounts)..skipped

So, I'm still wondering why/how I managed to turn Automount off? I now also have to manually mount my CD .... Keeping in mind, this system has been mounting and working flawlessly for a year...

Additional thoughts are much appreciated!

nuro305 04-13-2006 11:40 AM

Additional Info.
I checked another SuSE 9.3 workstation at home and the /etc/fstab files are exactly the same, and the other system still automatically mounts the same USB drive and CD's.

I noticed on the working machine with the 'top' command running that 'suseplugger' jumps in and mounts the USB drive.

I do have suseplugger installed and running on the machine in question. It seems to be corrupted or something though...

Any thoughts on how to fix or reinstall it?


AwesomeMachine 04-13-2006 12:26 PM

Go in the runtime level editor:

Control Center>Yast Modules>System>runlevel editor

Put it in expert mode

Make sure everything you need is running.

If it isn't, enable it, but do not start it. It will start on bootup. When you have everything you need enabled, reboot.

That 'grep automountd' that was returned by ps is the grep command you were running to find automountd, not automountd itself.

nuro305 04-19-2006 03:34 PM


Indeed the "autofs" daemon was not running. I enabled it for Run Levels 3&5 and rebooted.

It's still not runing, I tried to start it but i get "Starting service automounter ("file nis" does not provide any mounts)...skipped

Interesting !? What in the heck is the nis file ???


burntfuse 04-20-2006 09:04 PM


Originally Posted by AwesomeMachine
That 'grep automountd' that was returned by ps is the grep command you were running to find automountd, not automountd itself.

Yeah, I should've mentioned that, if it just said 'automount' instead of 'grep automount' then automount would've been running.

nrichard 09-20-2006 04:50 PM

SuSE 10.1 USB Flash Drive Auto Mount Stopped Working

I'm having the same problem with SUSE 10.1. How did you finally solve this one in the end?


mokelly1 10-13-2006 03:59 PM

Suse 10 autofs
I cannot get autofs to start either. Has anyone got the answer to this one?

jlehew 12-12-2006 10:39 AM

Automounting in SLED 10

Ive been having the same issue with the automount but Ive figured out that the udev and haldaemon are not running at boot time so there is no automounting. I changed those two daemons to boot run levels with 3&5 and it seems to be fine now.

I do have another question, is there anyone having issues with the NIC not being active at boot. the start is on auto but wont start without running YAST and reading the network settings. Any ideas????? thanks


nuro305 12-12-2006 11:04 AM

I'm not trying to confuse the issue, but I just wrote off all of these problems and spent the best $50.00 of my life and upgraded to SLED 10 and I have no problems with ANYTHING. I'm running it on a Gateway Desktop, Alienware notebook and a Panasonic notebook ALL with no problems.

I also got the SLED 10 SDK from so I can have tools like Apache, Eclipse, Etc...

I'd recommend the same to everyone who just needs to work and stop messing around with stuff like this ;-)

polrus 04-15-2007 05:21 AM

it used to work
i have exactly the same issue with

Starting service automounter ("files nis" does not provide any mounts)

on my suse 10.1 and the strange think is that some time ago it worked OK and suddenly stopped

All times are GMT -5. The time now is 02:10 AM.