LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   SUSE 9.1 Printer Configuration trouble (https://www.linuxquestions.org/questions/linux-hardware-18/suse-9-1-printer-configuration-trouble-211313/)

Malacandra 07-29-2004 11:44 PM

SUSE 9.1 Printer Configuration trouble
 
OK...I finally figured out a trick in BIOS to get my USB printer recognized by SUSE. (Disabled USB Legacy in BIOS) The printer is an HP Photosmart 1000

next, going through YaST, I am able to see the printer and even get a "Hello, world" test page to print. However, when clicking "finish" to configure, the following error occurs:

client-error-request-value-too-long

I can't make heads or tails of it. I am surprised because it's taken me so long to even get SUSE to see the USB port and finally to successfully print a test page. But it won't finish the config and thus the printer is useless.

Been struggling with this all week and hope someone has a good answer!

Thanks in advance,
Mark

PS - Searched and didn't find much on this, so sorry if the answers already there somewhere!

minrich 07-30-2004 06:50 AM

Try Linuxprinting.org, if it is a P1000 then this should work:

http://www.linuxprinting.org/show_pr...otoSmart_P1000

Post back here if you don't have any joy.

Malacandra 07-30-2004 12:59 PM

No joy
 
No joy in the sense that I haven't fixed it which means I have no joy over my printer.

OK...downloaded the HP P1000 driver (the one recommended). I can choose from a list of PPD files when configuring the printer, but none of them work. Here is the message I receive repeatedly, at every attempt.

"An error ocurred while communicating with the CUPS server while saving queue y2test.
cups(File)DoRequest error: client-error-request-value-too-long"

immediately after that a second message

"Unable to print the test page.
Output from lpr:
lpr: unable to print file: client-error-request-too-long"


This happens when I hit "test" (any of three options) as well as when you click "Finish" (whether you test or not). The upshot is that the printer is left unconfigured.

I am a complete Linux n00b--does this error mean that something is not connecting to the server? Is that the driver? Again, I am able to get a connection test to print successfully. I feel like I'm close but not there yet...

Help!

Thanks,
Mark

minrich 07-30-2004 01:32 PM

When you go to install printer or setup printer or whatever do you get a choice at the bottom of the screen to choose lpr and/or cups? If so choose cups and try again. I only have Suse 9.0 running as a Virtual machine, and I would have to know whether you are running kde or gnome desktop to be more specific, but I would advise that I successfully got my IP-connected Konica-Minolta magicolor 2300DL color laser to work on suse after following 'religiously, the instructions that I found on linuxprinting.org. So don't give up yet.

Malacandra 07-30-2004 11:07 PM

Well, there is a choice, but it's set to CUPS. It seems to me that the CUPS server is not being "talked to" for some reason. Just not sure what's going on.

Mark

minrich 07-31-2004 09:48 AM

Hi, do a ps aux in a console and check to see if cups is running.

then try a cups restart:

/etc/init.d/cups restart ENTER

I found an excellent CUPS Software Administration Manual under Administration- Hardware-cups in my Suse help Center, the one with the icon of a 'life saving ring'.

Otherwise, all I can suggest is that you check all your settings on Crontrol Center- Peripherals - Printers - [your printer name] especially the driver set-up and then restart cups again. If I recall correctly, I logged out and back in to chack that cups was starting automatically,and everything was running smoothly.

HTH

Malacandra 07-31-2004 03:55 PM

Got it! Got it! GOT IT!
 
Woooooo hooooooo!!

It works. I can print. Here's what I did: simple, really: I went into YaST, selected Install/Remove software. I then uninstalled everything it found with CUPS in it (something like 5 packages). I then reinstalled the everything. (from the SUSE CD). Went through printer configuration and it all works now!

Thanks for everyone's help. Hope this will help someone else to muddle through.

Mark

minrich 07-31-2004 04:58 PM

Congratulations

And welcome to LinuxQuestions.org, now you are an expert you can help someone else!

Cheers


All times are GMT -5. The time now is 04:46 PM.