LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 02-15-2004, 02:26 PM   #1
uknowimfreaky
LQ Newbie
 
Registered: Feb 2004
Location: nj
Distribution: SuSE 9.0
Posts: 11

Rep: Reputation: 0
Angry Suse 9.0 and cable modem setup HELPPPPP!!!!


i am using Suse 9.0, it recognizes my xircom ethernet card...but no internet yet...how can I get this to run? Where is it that you type what? I dont understand!!! please help me!!! I know about computers as much as I know about astrophysiscs....NADA! Can someone give me idiot proof steps to set this up??

Thanks so much!
Edna
 
Old 02-15-2004, 02:54 PM   #2
fantanas
LQ Newbie
 
Registered: Aug 2002
Location: New England (USA)
Posts: 10

Rep: Reputation: 0
If you are a newbie, can't you set it up via YAST?
 
Old 02-15-2004, 04:48 PM   #3
aarggh
LQ Newbie
 
Registered: Aug 2003
Distribution: SuSE
Posts: 11

Rep: Reputation: 0
As fantanas said, run yast to setup the card. I sounds like the card has been detected but just hasn't settings enabled on it. Open a terminal by clicking on it's icon in the lower left taskbar, type "yast2" without the quotes, and click on the "Network Basic - Network Card Configuration" option. You may now enable/disable the device, and assign static or dynamic ethernet details. It's as easy as that!
 
Old 02-16-2004, 11:55 AM   #4
uknowimfreaky
LQ Newbie
 
Registered: Feb 2004
Location: nj
Distribution: SuSE 9.0
Posts: 11

Original Poster
Rep: Reputation: 0
I think the ethernet card configuration is good, it is set up to get the ip address automatic from the isp (I called optimum online and they told me they do not use static ip) anyways, the internet does not work...is there anything else I can do?? When you say "open a terminal" do you refer to Konsole?

Thanks for your replies...
 
Old 02-16-2004, 04:13 PM   #5
aarggh
LQ Newbie
 
Registered: Aug 2003
Distribution: SuSE
Posts: 11

Rep: Reputation: 0
Yes, I meant a console. Open one up and type "ifconfig" to see your network settings. It should show an ip address and netmask for your machine as well as some adapter info and stats.

Typing "route -n" will also show the routing information. You basically need a catchall of "0.0.0.0" being pointed to the gateway set by your isp. If these don't show a default route, or you can't see a valid address for your system, check the firewall settings. Maybe the firewall is enabled and blocking DHCP requests from your machine? Can you also ping an outside address like www.suse.com? If you can, then have you enabled proxies in your browser when you don't need to, or, vice-versa?
 
Old 02-17-2004, 01:24 PM   #6
uknowimfreaky
LQ Newbie
 
Registered: Feb 2004
Location: nj
Distribution: SuSE 9.0
Posts: 11

Original Poster
Rep: Reputation: 0
Could you tell me where are the firewall settings? What if I don't get an IP? How do I ping, do I write "ping www.suse.com"?
I went to the SUSE website and they give the following directions:

If you´ve already configured your network card, please continue with 8.
Login as root and start "yast".
Select "System Administration" -> "Integrate hardware into system" -> "Configure network device".
As network type enter "eth0".
As networking device module please select your card from the list.
At "module options" type in the parameter for the IO-Port etc.. Have a look into the manual, chapter 14 "Kernel Parameter". ATTENTION! In case of a PCI-card you do not have to specify those parameters.
Select "Next". Go back to the main menue of YaST (press "esc" twice).
Choose "system administration" -> "network configuration" -> "network base configuration".
Now you are in the dialogue "selection of network".
Please press F5 to configure the device "ethernet" (whether it is not already inscribed in "device-name", e.g. eth0).
Press F3 and select "DHCP".
Afterwards please press F4 to activate this device.
With "F10" the configuration will be saved.
Select "system administration" ->"change configuration file" and search for the variable "DHCLIENT" and set it to "yes" to start it every time when you boot your system. (This step isn´t necessary since SuSE Linux Version 7.1!)
Now exit YaST.
Type in "rcdhclient start" to activate the network access. Afterwards you can test the connection with e.g. "ping www.suse.de".

also, I cannot follow the steps as they describe them. for example I can start Yast, but anywhere does it say system administration nor the rest of the stuff it says on the step...
If somebody help me please!

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant setup my cable modem despite my perseverance allthor Linux - Networking 12 02-19-2005 03:48 PM
USB Cable modem setup mojo_risin SUSE / openSUSE 1 02-17-2005 12:09 AM
Cable modem setup milir Mandriva 4 08-06-2004 09:23 PM
Need help with cable modem setup saxmanohs Linux - Newbie 6 01-03-2002 01:59 PM
cable modem setup Danobri Linux - Networking 10 10-15-2001 09:09 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration