-   Linux - Hardware (
-   -   SuSE 8.2 and Turtle Beach sound (

Achtunger 11-10-2003 08:06 PM

SuSE 8.2 and Turtle Beach sound
Hi folks,

I recently installed Suse 8.2 on an old Dell PII450. It seems to mostly work fine, except that I can't get the sound to work on it. It's an old Turtle Beach Montego card, using and Aureal 8820 chip. First I tried getting Soundforge drivers for the card. But they wouldn't compile right, no matter how much I tried to mess with the code to eliminate errors. Then I tried downloading the OSS driver, but I can't get it to install. Instead it just says that my installation package does not contain the precompiled modules for the kernel version I am running.

I think I need to get ALSA drivers now, but I'm not totally sure if they will work. Am I going about this properly? Is there something I need to do with the Kernel? Linux newbie here, so I'd appreciate it in plain English, if thats ok. :D


phanly 11-10-2003 09:19 PM

make sure the kernel-source is installed before you start eg:
[root@localhost alsa-utils-0.9.8]# urpmi kernel-source

If you don't have permission type su (to login as a Super User)

Read this first so you can make the relevant changes based on the patch when it appears to fail:
The changes are made in the file mentioned in the top of each section and the changes are the addition of the lines marked with a +

Read the directions at: and others linked but particularly
but note that you probably won't have the files in a different location than a downloads directory in the same path as in the example, so you will have to make some adjustments. and download the files versions 0.9.8 there are 4 or 5 different files driver, lib, oss, utils, tools. They are all tar.bz2

Use the Quick install directions above. The drivers file takes about 30 mins to do make on my 400mHz pii400.

Check whether you need ot make the changes suggested in the patch mentioned in the post referred to above.

Even after all this I end up with a failure during the modprobe stage because of:
unresolved symbol snd_verbose_printk

I am trying to get answers to this from the alsa-devel lists at:
You might like to view the archives or search the lists. The alsa-user list also has some posts with the same problem I am having.

The only other post I have seen that suggests that a solution has worked to unresolved symbols issues is:

You can try with a search for your problem eg:
unresolved symbol snd_verbose_printk
and that may turn up a solution.

You might be luckier than me because clearly some people are having success with the new alsa drivers.

Good luck

Achtunger 11-11-2003 12:23 PM

I'll give it a shot tonight.

phanly 11-11-2003 05:17 PM

Mine works fine now, so it can be done!

The exact reference to the Quick install instructions referred to in my earlier post is:

After I had everything working (having checked using lsmod from the command line as su to see that snd-au8820 was in the list) I still had some problems with sound stopping working and kmix having a blank screen. These problems were solved when I followed the directions at:

My reference to the page:
should also have added that the post you need to read is:
[Alsa-devel] aureal driver compile problem and patch
From: Carolyn and Eric Hathaway <10/30/2003>
This tells you how to solve problems caused by different compiler versions having been used compared to what your distro has installed eg gcc2 vs gcc3 and how to patch various makefiles to avoid some unresolved symbol problems.

Don't forget you have to configure before you make.

My problem with:
unresolved symbol snd_verbose_printk
was solved by using a different configure line someone suggested:
./configure --with-isapnp=no --with-cards=au8820 --with-sequencer=yes --with-oss=yes --disable-verbose-printk

1 Download all alsa-***- 0.9.8 tar.bz2 files into a new directory. If you want to exactly follow the Quick install instructions above it needs to be in the same place as his Downloads directory in the example
2 unzip
3 make Hathaway's suggested changes re gcc2 > gcc3 and patch makefiles as suggested
4 run the configure suggested above (modified for your system if necessary) while in the driver unzipped directory
5 follow the Quick Install directions remembering that you *may have to ./configure *some of the others (utils, tools, oss) first as well - I just tried them all.
6 follow the directions re the modules.conf file
7 check that the snd-au8820 module has loaded by doing lsmod from the command line
7 open alsamixergui and unmute and increase volumes of the master and relevant others
8 try it all out and repost if you still have problems

Hope this gets you there

mixaha 01-24-2004 11:31 AM

modprobe aureal 8830

Hallo from newbie

I tried to compile the alsa-driver 0.9.8 as well, everything was fine until modprobe
As well the aureal 8830 driver is not in the alsa matrix when I try to install soundcard via yast2

with alsaconf the messages are:
loading sound driver: snd-au8830 Warning: ignoring snd_major=116, no such parameter in this module
module snd loaded with warnings
/lib/modules/2.4.19-4GB/kernel/sound/pci/au88x0/snd-au8830.o: unresolved symbol snd_mpu401_uart_interrupt
/lib/modules/2.4.19-4GB/kernel/sound/pci/au88x0/snd-au8830.o: insmod /lib/modules/2.4.19-4GB/kernel/sound/pci/au88x0/snd-au8830.o failed
/lib/modules/2.4.19-4GB/kernel/sound/pci/au88x0/snd-au8830.o: insmod snd-au8830 failed

I tried to read the Hathaway`s suggested...., but I can`t find it with the links mentioned above,it is not in the thread anymore.
So I don`t know what to do now
Can you help?


All times are GMT -5. The time now is 08:54 AM.