Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 05-04-2006, 05:15 AM   #1
Registered: Mar 2006
Distribution: Archlinux
Posts: 42

Rep: Reputation: 15
Suse 10 - Display Problem During Boot-up

Distro: Suse 10.0
PC: P3, 450Mhz (old Gateway machine)
Video Card: ATI 3D Rage Pro AGP 1x/2x
Monitor: Dell 1505FP (analog)

I am have a very irritating problem during boot-up. The Grub bootloader displays properly and allows selection of operating system. The screen then displays the error message “1. Analog Input. Cannot Display This Video Mode”. This continues until the process reaches the screen which shows the 3 symbols for tools, desktop, and KDE, which displays properly. Everything then works fine until I turn the machine off, when I get the same error message from the monitor during shutdown.

The monitor can handle a maximum resolution of 1024 x 768, so I assume that the initial phase of boot-up is trying to use a higher resolution. I have tried re-setting the monitor in Sax2, with no success. I have also examined /etc/x11/xorg.conf, which seems to have the correct information for the display.

Although this problem is not stopping me using the system, it is driving me mad!!

Can anyone save my sanity, please?

I am quite new to Linux, and still learning.

Thanks in advance
Old 05-05-2006, 02:28 PM   #2
LQ Addict
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,894

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Try this: at the grub menu, you have a boot prompt underneath the menu options. Add: vga=0x318 (a code for 1024x768 resolution) which should overide boot options in your /boot/grub/menu.lst.

If it works, when you are booted into SuSE, edit your menu.lst to add the vga=0x318 to the 'kernel' line, and it should work every time you boot.

Source: this thread from another board:
Old 05-06-2006, 05:41 AM   #3
Registered: Mar 2006
Distribution: Archlinux
Posts: 42

Original Poster
Rep: Reputation: 15
Thanks, Bigrigdriver, and for the link to the other thread. Thought the little so-and-so must be hiding in there somewhere!

I'll try this out, and let you know what happens.
Old 05-16-2006, 10:18 AM   #4
Registered: Mar 2006
Distribution: Archlinux
Posts: 42

Original Poster
Rep: Reputation: 15

I finally got time to try your suggestion, and it worked fine! Many thanks.

After I got things to work, I did a bit more research, and discovered that Yast>System>Bootloader>Edit lets you set this and other parameters used at boot-up by Grub 1.5. By selecting 16-bit colour depth (vga=0x317), I also got the spalsh-screen to display properly!

Once again, thanks for you help


display, hardware

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Suse 10.0 Display Problem drwsecond SUSE / openSUSE 2 03-25-2006 12:34 PM
SUSE 10 Installation Problem, After Intial Boot, Black Display refp16 Linux - Laptop and Netbook 8 10-26-2005 08:21 PM
Display Problem in Suse 9.2 delamatrix SUSE / openSUSE 2 08-02-2005 10:37 AM
Display problem with SuSE 9.1 Theophylact Linux - Software 10 05-22-2005 07:26 PM
Suse 9.1 Display Problem boudahsister SUSE / openSUSE 1 02-01-2005 01:20 PM > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:03 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration