-   Linux - Hardware (
-   -   SuSE 10.1 on Dell Dimension E520 (

tobipers 11-09-2006 05:18 AM

SuSE 10.1 on Dell Dimension E520
I have just tried to install SuSE 10.1 on a Dell Dimension E520, and I ran into a small problem. The installation could not find the network card, a Intel 825xx 10/100 Platform LAN Connect Device. I have dual boot and the network card works find under Windows. Have anybody had similar experience and possible solutions?



tobipers 11-09-2006 07:11 AM

some more info...

The /sbin/lspci command gives:

00:19.0 Ethernet controller: Intel Corporation Unknown device 104c (rev 02)


bertramgeck 11-19-2006 01:09 PM

Same problem....tried to install Suse 10.1 twice on my new E520, no network card recognized.
Any ideas ?

techieg 11-22-2006 11:20 PM

FC4 on Dell Dimesion E520
I tried to install Fedora Core 4 on a Dell DImension E520 and it comes up saying it cannot find device drivers for the disk controller. Where can I get such so I can proceed with installation.

bertramgeck 11-24-2006 12:55 AM

I added a 3Com NIC Card, that was identified immediately and setup by SUSE 10.1.
That was the fastest way, as no SUSE 10.1 driver for the original NIC-Card in the DELL E520 was available.

bimbam 11-27-2006 12:19 PM

Suse 10.1 on Dell Dimension E520
Just got my Dell E520 an ran into the same problem. I downloaded the 2.6.18 kernel sources (using antoher PC of course), recompiled the kernel, and the onboard network card works fine now.

If you do not want to recompile the kernel yourself, you could wait for Suse 10.2 (scheduled dec 7th 2006) with kernel-default-, or use Fedora Core 6 (but I didn't try FC6 yet).

Hope this helps.

bertramgeck 11-28-2006 01:53 AM

Hi bimbam,

thanks for the answer. This clarifies the issue with the onboard NIC Card.


speut 01-04-2007 08:41 PM

I work with live cd's so you never know what nic cards folks have.

I have found this in my travels.

"ANY NIC that has INTEL in it's name is TABOO!!!"

My solution? USB nic.

startech usb100s is a dream.

They are really cheap. We just buy a buch and give it to the users who have TABOO INTEL cards.

All times are GMT -5. The time now is 01:57 PM.