LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   SuSE 10.0 CD/DVD device mapping problem! (https://www.linuxquestions.org/questions/linux-hardware-18/suse-10-0-cd-dvd-device-mapping-problem-380179/)

david.dales 11-05-2005 08:19 AM

SuSE 10.0 CD/DVD device mapping problem!
 
Dell 9150 Brand new
Intel 650HT 3,4Ghz processor
1GB RAM
2x WD 160GB SATA HDD
Suse 10.0
DVD ROM
DVD RW

I'm having a strange problem with suse where my dvd drives are mapped as the wrong devices. Or at least what I suspect are the wrong devices.

DVD Rom 1st device sr0:
/dev lrwxrwxrwx 1 root root 3 2005-11-05 14:58 dvd -> sr0

DVD RW 2nd device sr1:
/dev lrwxrwxrwx 1 root root 3 2005-11-05 14:58 cdrom -> sr1

FSTAB:
/dev/cdrom /media/cdrom subfs noauto,users,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0

/dev/dvd /media/dvd subfs noauto,users,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0


I tried to create a new link in dev to recognize the DVDRW as dvdr and naturally created the /media directory and the corresponding fstab entry.

However, after a reboot, the /dev/dvdr link disappears.

Next, I also did an rm on /dev/cdrom and /dev/dvd and relinked them to the corresponding devices /dev/sr0 and /dev/sr1 respectively.

Again, after reboot, they automatically go back to the reverse order.

This is causing me headaches with DVD Decrypter 3.5.4 under Wine because the devices won't seem to stay put as I configure them by hand.

I didn't have this issue with Suse 9.3. I set the devices and links and fstab entries and they stayed that way.

Any suggestions would be greatly appreciated!

Thanks in advance

Paul7 11-05-2005 08:53 AM

Dit you make an update from your old system or you made a new installation?
Because the devices are loojing very strange,

david.dales 11-07-2005 01:14 AM

This is a new installation NO update.

I don't understand why the DVD devices are getting mapped like they are. After a little more investigation, I also looked in Yast under Hardware and then CD ROMs. In the list they are marked correctly as sr0 ROM and sr1 Writer. However, you can click on the Add button to integrate them into the system. There they also list the fstab entries backwards and each device is listed twice.

Paul7 11-07-2005 09:37 AM

I'm not sure, but Ifeel there is something wrong with automount. but Isee this only with floppy drive. Try following: umount the devices and mount the in consolemode.
What is happend then?
also remove the dups fom fstab.
Check what is habbend after remove and reboot

david.dales 11-07-2005 09:43 AM

Ok, there are no duplicate entries in my fstab.

The devices aren't mounted in the first place because they're optical drives. I don't understand exactly what you mean with the manual mounting comment.

Of course I can mount them in the console but that doesn't tell me anything because you can force them to mount to any directory you want as long as it exists and it's not already mounted.

Paul7 11-07-2005 10:18 AM

I mean:
mount -t CDROM /dev/ .... /home/mydir
or like this

david.dales 11-15-2005 02:13 AM

Yes, I can manually mount them.

My concern is that I want to create a link in the /dev directory.

Example:

ln -s /dev/sr0 dvd
ln -s /dev/sr1 dvdr

That will only work until the next reboot.

I don't understand how the devices and links under /dev are being generated in Suse 10.

I even tried adding the device names that I wanted, if they weren't there already, to the /etc/longindevperms and changed the permissions accordingly after creating the links in the /dev directory.

Same result, the links that I created by hand disappear upon reboot.


All times are GMT -5. The time now is 07:04 AM.