LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 10-30-2004, 10:16 PM   #1
sanhitomi
LQ Newbie
 
Registered: Oct 2004
Posts: 3

Rep: Reputation: 0
Surround Sound Problem


Hello there;
I am new to linux...very new so please bear with me.
I have installed a Sound Blaster Live card on my system to get 4 speaker sound when watching dvd's. IT works perfectly while in windows so i know the speaker set up and hardware is okay.
The problem is that i get the same audio coming from both the front and rear speakers no matter what i play (mp3, dvd, audio cd etc...) or using what (mplayer, xine, ogle etc) . The other wierd thing is that on the Gnome mixer i have 4 Mixers:
A sigmatel OSS one
a realtek OSS one
A sound blaster ALSA one
and a VIA ALSA one (from the bulit in auido on mother board)

and here is where it get really freaky.
the sigmatel mixer will control the front speakers with either it's PCM or PCM2 channel
the Wave Surround channel on the SBLive one conttrols the rear speakers.
BUt it gets even wierder.
If i mute the sigmatel mixer the back speakers stay on but if i mute the SBLive one the front and back speakers go mute.

I have search around and have not found anything on such an issue.

As for my system:
Fedora core 2
Kernel 2.6.5-1.358
Sound Blaster Live PCI
Nvidia Geforce 2 64 meg video card
640 Megs of ram
AMD Duron 1300Mhz
Anything else you need to know please just ask

Last edited by sanhitomi; 10-30-2004 at 10:22 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Surround Sound? LegendBreath Linux - Hardware 1 06-06-2005 01:11 PM
Sound blaster Live! 24bit + Surround sound Jay_highlands Linux - Hardware 3 05-14-2005 01:37 AM
No Surround Sound sanhitomi Linux - Hardware 6 11-08-2004 03:55 AM
Sound Blaster Audigy Surround Sound GameboyHippo Linux - Hardware 0 12-04-2003 08:15 PM
Problem with Surround Sound izmeh Red Hat 1 10-25-2003 06:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 01:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration