LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 11-16-2005, 07:19 PM   #1
gvaught
Member
 
Registered: Sep 2003
Location: MidWest
Distribution: Debian GNU/Linux 8 (jessie)
Posts: 199

Rep: Reputation: 30
"supported" sound card won't work...


Okay, I've been looking (off-and-on) for somewhere around 6 months or more. I am fairly convinced that (1) my card is a really obscure piece of crap and (2) I'm not going to find anyone else with the issues I have.

My card is an Audio Excel AV 51A. The box says it comes with Linux drivers. And there are files on the CD, under a directory named "Linux", but I can't get anything to go. So, I have no idea if this card is an unsupported piece of crap (probably), my sound system is not configured correctly or I'm just an ignoramous who should go back to Windows and live with the limitations of my intelligence.

Let's see, I've managed to vent my frustration, bash Micro$oft and give a small amount of info. Not a bad start. I am listing the results of lspci below. I hope someone sees what I need to know and can explain it to me.

Code:
arthur:~$ lspci
0000:00:00.0 Host bridge: Intel Corp. 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
0000:00:01.0 PCI bridge: Intel Corp. 82865G/PE/P PCI to AGP Controller (rev 02)
0000:00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #1 (rev 02)
0000:00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #2 (rev 02)
0000:00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #3 (rev 02)
0000:00:1d.3 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #4 (rev 02)
0000:00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev c2)
0000:00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Bridge (rev 02)
0000:00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) Ultra ATA 100 Storage Controller (rev 02)
0000:00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) Serial ATA 150 Storage Controller (rev 02)
0000:00:1f.3 SMBus: Intel Corp. 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250 If [Radeon 9000] (rev 01)
0000:01:00.1 Display controller: ATI Technologies Inc Radeon RV250 [Radeon 9000] (Secondary) (rev 01)
0000:02:00.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
0000:02:01.0 Ethernet controller: D-Link System Inc RTL8139 Ethernet (rev 10)
0000:02:08.0 Ethernet controller: Intel Corp. 82562EZ 10/100 Ethernet Controller (rev 01)
I'm sure there's something else I should provide, but I'm pretty stinkin' lost at this point.

I'm running Debian 3.1r0. As some of you will be able to tell from above, this box was originally built (by and for someone else) to be a better-than-average web design box on a Windows platform. I am hoping it's not too deep into that realm that I can't get it to do what I want in Linux.

If there is anything, information-wise, that I can provide to help someone help me - just let me know. I'll do what I can to make this easier on someone else. I just want help.

 
Old 11-16-2005, 07:30 PM   #2
freakyg
Member
 
Registered: Apr 2005
Distribution: LFS 5.0 and 6.1
Posts: 705

Rep: Reputation: 30
http://www.linuxquestions.org/hcl/sh...&cat=71&page=1

read this
 
Old 11-16-2005, 07:41 PM   #3
gvaught
Member
 
Registered: Sep 2003
Location: MidWest
Distribution: Debian GNU/Linux 8 (jessie)
Posts: 199

Original Poster
Rep: Reputation: 30
Okay, I read it. Most ppl have no prob. Some have issues. No one gave any insight as to how I could get my card to work.

Any more help out there?
 
Old 11-16-2005, 09:13 PM   #4
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
Frankly, it looks like the basic and standard you have 2 soundcards installed issue. You have onboard, and you have the one you want. Onboard nearly always overrides priority and it the default soundarcard.
You just need to disable that card in the bios, so you have only a single sound card.
 
Old 11-17-2005, 06:36 PM   #5
gvaught
Member
 
Registered: Sep 2003
Location: MidWest
Distribution: Debian GNU/Linux 8 (jessie)
Posts: 199

Original Poster
Rep: Reputation: 30
In BIOS, okay. I think I can do that (although I've never done it before). I'll be back later to let you know what happened.
 
Old 11-17-2005, 07:14 PM   #6
gvaught
Member
 
Registered: Sep 2003
Location: MidWest
Distribution: Debian GNU/Linux 8 (jessie)
Posts: 199

Original Poster
Rep: Reputation: 30
"And the beat goes on..."

But it's going somewhere besides my speakers...

Code:
arthur:~$ lspci
0000:00:00.0 Host bridge: Intel Corp. 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
0000:00:01.0 PCI bridge: Intel Corp. 82865G/PE/P PCI to AGP Controller (rev 02)
0000:00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #1 (rev 02)
0000:00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #2 (rev 02)
0000:00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #3 (rev 02)
0000:00:1d.3 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #4 (rev 02)
0000:00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev c2)
0000:00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Bridge (rev 02)
0000:00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) Ultra ATA 100 Storage Controller (rev 02)
0000:00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) Serial ATA 150 Storage Controller (rev 02)
0000:00:1f.3 SMBus: Intel Corp. 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250 If [Radeon 9000] (rev 01)
0000:01:00.1 Display controller: ATI Technologies Inc Radeon RV250 [Radeon 9000] (Secondary) (rev 01)
0000:02:00.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
0000:02:01.0 Ethernet controller: D-Link System Inc RTL8139 Ethernet (rev 10)
0000:02:08.0 Ethernet controller: Intel Corp. 82562EZ 10/100 Ethernet Controller (rev 01)
Okay, one. One single, solitary, little sound controller listed. And still no sound, noise, distortion, anything from my speakers.

I've read enough to know that others have had success with this chipset, although I'm not so certain about this card. Is there a configuration file I should be checking/posting to get the desired sounds to emit from my speakers without rebooting into Windows?

BTW, I don't know who posted it - or in which thread I read it - but to the individual who decided to advise the use of lspci I wish to extend my most hearfelt gratitude. Not only can I see what's installed, but the important part of what's installed - the chipset and/or manufacturer!!!

According to apt-get install alsa it is already installed and at the latest version. It's not showing up in the process list, so I'm not sure where to go from here. I'm going to post this and get to searching and reading on how to use alsa. Apparently there's more to it than installing, but no man page to tell me what...

I look forward to hearing from someone (even if it's to tell me to keep reading), soon.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"Automatic detection of the sound card did not work.", this one is a little different SubyFan12 Linux - Hardware 1 06-05-2005 04:52 PM
"<" ">" Keyboard keys on Toshiba Satellite 1005-s157 dont work RodCas Linux - Laptop and Netbook 1 05-08-2004 04:22 PM
charset "UTF-8" not supported, using "ISO8859-1". satishpatel Linux - Software 3 04-09-2004 07:11 AM
Must I "append" the LILO to make the eth1 card work? piratebiter Linux - Networking 5 08-31-2003 10:56 AM
So what ethernet card is supported "as standard" by 2.2.19 kernel?... Simon W Linux - Networking 2 02-14-2002 01:25 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 02:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration