LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 03-17-2005, 07:13 PM   #1
linkmark
LQ Newbie
 
Registered: May 2004
Location: Belgium
Distribution: Gentoo
Posts: 28

Rep: Reputation: 15
SUN SparcStation 10 external scsi cd-rom problem


I have a Sun SparcStation 10 (http://www.obsolyte.com/sun_ss10/) where I want to install Gentoo on.
It has an external scsi cd-rom reader, I connected it correctly and also the scsi terminator is there where it should be.
It has an old MDK 7.1 install on the 1 scsi hardisk, when MDK boots it detects the scsi cd-rom correctly. When I enter OpenBoot (stop-a) and do 'probe-scsi-all' it also detects that same external cd-rom =>

Target 6
Unit 0 Removable read only device SONY CD-ROM CDU-8012 3.1e


When I enter 'test cdrom' i get this =>

cdrom selftest failed. Return code = -1 (i googled on that but didn't find a thing)

Now, where it all started, when I do 'boot cdrom' it does this =>

Boot device: /iommu/sbus/espdma@f,400000/esp@f,800000/sd@6,0:d File and args:

And then it does nothing more. When I do 'stop-a' again I get the OpenBoot prompt again. But the strange thing is that he doesn't read the cd-rom inside the scsi external cdrom (the read-led doesn't turn on).
He only reads the cdrom when I do a 'test-all' first , and if I then do 'boot cdrom' he reads for a few seconds (the read-led turns on) and the led goes off and again nothing happens. I can't try the external cd-rom coz I don't have acces to the installed MDK (I got the Sparc from the teacher of my evening school). I realy don't know what to do or what's worng, google also didn't help me very mutch.
This is the first Sparc I'm trying to work with, so that means I don't know a lot about it.

Thanks in advanced!
linkmark
 
Old 04-11-2005, 08:56 AM   #2
t3gah
Member
 
Registered: Dec 2004
Distribution: SuSE, RedHat, ubuntu, Debian
Posts: 734

Rep: Reputation: 30
Re: SUN SparcStation 10 external scsi cd-rom problem

Quote:
Originally posted by linkmark
I have a Sun SparcStation 10 (http://www.obsolyte.com/sun_ss10/) where I want to install Gentoo on.
It has an external scsi cd-rom reader, I connected it correctly and also the scsi terminator is there where it should be.
It has an old MDK 7.1 install on the 1 scsi hardisk, when MDK boots it detects the scsi cd-rom correctly. When I enter OpenBoot (stop-a) and do 'probe-scsi-all' it also detects that same external cd-rom =>

Code:
Target 6
Unit 0		Removable read only device	      SONY	CD-ROM CDU-8012 3.1e
When I enter 'test cdrom' i get this =>

Code:
cdrom selftest failed. Return code = -1
(i googled on that but didn't find a thing)

Now, where it all started, when I do 'boot cdrom' it does this =>

Code:
Boot device: /iommu/sbus/espdma@f,400000/esp@f,800000/sd@6,0:d     File and args:
And then it does nothing more. When I do 'stop-a' again I get the OpenBoot prompt again. But the strange thing is that he doesn't read the cd-rom inside the scsi external cdrom (the read-led doesn't turn on).
He only reads the cdrom when I do a 'test-all' first , and if I then do 'boot cdrom' he reads for a few seconds (the read-led turns on) and the led goes off and again nothing happens. I can't try the external cd-rom coz I don't have acces to the installed MDK (I got the Sparc from the teacher of my evening school). I realy don't know what to do or what's wrong, google also didn't help me very much.

This is the first Sparc I'm trying to work with, so that means I don't know a lot about it.

Thanks in advanced!
linkmark
Is this one of those SCSI external CD-ROM drives that has a dip switch or jumper switch on the back of it for SCSI termination?

Did you reseat the cables to make sure it's not a connectivity issue?

Did you try a different CD-ROM?

Did you try the Solaris set you can download from sun.com?
 
Old 04-12-2005, 07:37 AM   #3
linkmark
LQ Newbie
 
Registered: May 2004
Location: Belgium
Distribution: Gentoo
Posts: 28

Original Poster
Rep: Reputation: 15
Thx for ur reply t3gah, but I fixed the problem already.
On the back of the external SCSI cd-rom drive is a switch where u can switch between nr's. I found on a site that it must be 6, but it was configured to 5. And then it worked.
I should have deleted this post but i forgoton it.

Thx!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with SCSI CD ROM R/W orifux Linux - Hardware 3 12-04-2004 02:16 PM
Sun SparcStation 10 - can it be booted with no monitor? lazlow69 Linux - Hardware 3 03-29-2004 10:58 PM
Normal SDRAM in Sun SparcStation 5 Jestrik Solaris / OpenSolaris 1 03-14-2004 11:49 AM
Sun SPARCstation 10 Pizza Box Rebuild... cparker15 Solaris / OpenSolaris 8 09-03-2003 07:45 AM
Bootserver config for diskless Sun SPARCstation moetjojo Linux - Networking 0 10-22-2002 11:28 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 04:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration