-   Linux - Hardware (
-   -   Stupidly ran "cat /dev/urandom > /dev/mem", worried I broke firmware (

crosstalk 10-24-2010 09:17 PM

Stupidly ran "cat /dev/urandom > /dev/mem", worried I broke firmware
Well, I was playing around with /dev/mem, and just to see if I could write to memory with it, I ran

cat /dev/urandom > /dev/mem
When I rebooted, I found that X11 didn't recognize either my synaptics touchpad or my desktop background.

Is it possible I overwrote some important firmware, or did I just nuke a couple of important files (which I can repair)?

I am running Gentoo Linux.

Thank you for any help.

EDIT: On the third boot, it recognized my mouse correctly. I am currently running "emerge -e world". I feel stupid -- I should've realized that overwriting kernel memory could mess with filesystems.

bulls_i3 10-25-2010 05:09 PM

/dev is not a real part of the filesystem, but just contains pointers to your devices.

AFAIK, rebooting should fix the problem, since nothing was actually "written".

(Although, you could have corrupted your memory in such a way that caused the kernel to do something unexpected, e.g. overwrite some important files, in which case a "write" did happen. But I think a scenario like that is extremely unlikely. I think you'd get weird behaviour and probably crashes before that happens.)

Try booting into a non-X11 runlevel, and see if you can find any problems. It seems like your currently problem might be X11 specific.

crosstalk 10-25-2010 05:27 PM

That was what I wanted to hear.

Since it didn't work after I rebooted, I knew that it had either messed with some files or with the firmware for the touchpad (if the touchpad has firmware). I just wanted to make sure it couldn't be the latter (which would be harder to fix).

Until I start X, everything seems to run fine. It has been running all day (9.5 hours) doing an "emerge -e world" (which reinstalls everything, for non-Gentoo folk) (it's a 1.6 GHz Pentium M-based laptop).

Thank you.

(I'll add [solved] after I can test it.)

EDIT: Plus or minus, almost everything seems to work.

All times are GMT -5. The time now is 10:59 PM.