LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   strategy to replace mobo (https://www.linuxquestions.org/questions/linux-hardware-18/strategy-to-replace-mobo-603975/)

dgermann 12-02-2007 02:47 PM

strategy to replace mobo
 
Hi--

I farkled my mobo last night. Actually had a fire on it while installing new memory!

So: now I am getting a new mobo. Old one was Intel 915GAVL; new one is Intel DG33FB with Intel core 2 duo E4300.

The hardware tech says the bootup sequence (I currently have Ubuntu Dapper 6.06 on the HDD) does not recognize the chipset. Just to be sure I had something that I could put a new OS on, I had him put in a new serial ATA HDD 80 gig drive.

Now my question is how do I go about restoring my system so I have access to what was there before, both data and apps and OS?

1. Do I install Ubuntu Gutsy 7.10 on the new drive, boot from there and then mount the old drive with some new designation, like /olddrive?

2. Do I simply get a live CD, boot from there and then make some changes in config files? Which config files or other changes?

3. Something else entirely?

It might help to know that I have an nvidia graphics card on it and from that am running dual monitors using Twinview.

Thanks!

syg00 12-02-2007 03:11 PM

Grab a liveCD and copy /home out to a new partition - either disk, doesn't matter, but on the new one makes sense.
Grab the "alternate" CD for gutsy, and install onto the new disk, nominating the /home partition (not to be formatted), and install fresh.
You can't upgrade from Dapper, so this would be a good way to do it - and if it all goes to hell, you still have you old disk intact.
You can get the NVIDIA driver on gutsy - easy.

moxieman99 12-02-2007 03:29 PM

Quote:

Originally Posted by dgermann (Post 2977771)
Hi--

I farkled my mobo last night. Actually had a fire on it while installing new memory!

Thanks!

I am DYING to know how you did that.

David1357 12-02-2007 04:25 PM

Quote:

Originally Posted by moxieman99 (Post 2977798)
I am DYING to know how you did that.

He should be forced to provide pics before we help any more.

dgermann 12-02-2007 04:55 PM

syg00--

Thanks for your quick response!

A couple of questions--1. I am guessing that your two lines that start "Grab" are alternatives, not step one and step two of the same thing. Correct?

2. Oops! I got the regular CD. How important is the "alternate CD?" Can I find the same files on the one I grabbed?

3. What does it mean I cannot upgrade from Dapper?

4. How do I make a new partition on the new disk? It has been years since I figured out how to make partitions....

5. Here is some additional info:

As it stands, it will only partially boot: It starts to boot and hangs at "waiting for root file system."

After several minutes it says "PCI: Failed to allocate mem resource #6:" and a bunch of numbers. Then "ALERT! /dev/sda1 does not exist. Dropping to a shell!" Then it gives me a BusyBox shell.

The fire? I shut down the computer, unplugged it. Inserted memory sticks. Powered back on. When I turned the power on, there was a little light that came on near the memory sticks, and near it, a flame! It took me a few seconds to figure out I needed to pull the plug instead of hit switches to shut off the power, but when I did, the fire died away. Tech guy said it could have been just the time for the mobo to give up. Or maybe I put the sticks in incorrectly. Bottom line: I don't know how it happened.

Any idea how to get past that place in the boot sequence?

moxieman99 and David1357--hope that answered your questions about the fire. If not, film at 11:00! (Sorry, no film!)

Thanks folks!

syg00 12-02-2007 08:28 PM

Do everything I suggested. If you get a liveCD with gparted you can do the partitioning from that. It's a GUI similar to partition magic. You need the alternate CD to control the install better - like assigning partitions to mount points. I don't think the normal installer allows expert/advanced options - never used to anyway.

Ubuntu update manager doesn't support skipping level(s) - so to go from 6.06 to 7.10 (skipping 7.04) you have to do a clean install.

To test the boot, take the S-ATA disk out and see if that works.

dgermann 12-02-2007 09:05 PM

syg00--

OK, Thanks!

OK, the new drive (is that SATA? It has a thin red cable, about 1/4 inch wide, while the old one has a flatter, wider--1 1/2 inches--and grey cable) is plugged into both the old drive and the mobo. So do I just disconnect it from the power source and the mobo and try that?

Are there any jumpers or other connections I need to change to see if I can just boot up the old disk?

If it does not make sense to jump from 6.06 to 7.10, then how do I just keep the 6.06 system I have on there? What if I do the download for the 6.06 system?

I think the tech said it would not boot up when he had only the old drive in the machine.

Is it possible it is trying to boot from the completely blank new drive and that is why it complains about no root file system on sda1?

Thanks for your help. I will get back to this tomorrow when I am fresher.

Thanks!

syg00 12-03-2007 06:48 AM

I think I misunderstood - I thought you were trying to boot from the old disk.
If you are seeing this attempting to boot the CD, then it's likely either;
i) you didn't burn the CD as an "image", or
ii) you don't have the CD before the hard disk(s) in the BIOS boot order.

Adjust as appropriate.

dgermann 12-03-2007 07:23 PM

syg00--

Nope, you did not misunderstand. I do want to boot from the old drive.

An update: It turns out that both the drives are SATA. The old drive is 200GB, the new is 80GB, if that helps.

They are plugged into slots SATA0 (new drive) and SATA1 (old drive). The schematic says the other two SATA slots are SATA4 and SATA5. The grey cable is for a floppy.

There was a sheet of paper in the mobo box which said that for non-Vista OS installation to go into bios > Advanced > Drive and change it to configure SATA as ide. It had been AHCI. I made this change but it still stopped at Waiting for Root File System

I played around by hitting <es> to go to the Grub menu. The first entry is "root (hd0,0)". I don't think that is something to change.

The second entry is "kernel /boot/vmlinuz-2.6.15-29-386 root=/dev/sda1 ro quiet splash". This looks like it. Changing sda1 to hda1.

Nope, still stalls out at Waiting for root file system.

If I switch to ctrl-alt-F1, I see this error: "[17179570.980000] PCI: Failed to allocate mem resource #6:20000@90000000 for 0000:01:00.0"

This time it says /dev/hda1 does not exist. (Instead of sda1).

Oh, it also says "/bin/sh: can't access tty; job control turned off".

Is any of this any progress?

dgermann 12-03-2007 09:34 PM

Hi all--

I tried a live CD for Gutsy 7.10. Started gparted and it showed partitions on my old drive at sdb1 (had a boot flag), sdb2, and sdb5.

Thinking I had this thing licked, I went in to grub and edited the kernel line that referred to sda1 to sdb1, and no go. Same waiting for root filesystem. Then tried sdb2 and sdb5, with same results.

Are there any clues here?

Thanks!

syg00 12-03-2007 10:22 PM

Quote:

Originally Posted by dgermann (Post 2977771)
The hardware tech says the bootup sequence (I currently have Ubuntu Dapper 6.06 on the HDD) does not recognize the chipset.

Pat that boy on the back.
This is your problem - Feisty has the support (and can thus see {both} the dirves o.k.), but Dapper doesn't.
Install Feisty and you should be able to get at your data o.k. - it'll probably also setup mount-points for both disks for you as well. Maybe - the alternate may not, but you'll have the opportunity to do it as part of the install if you go that way.

dgermann 12-03-2007 10:47 PM

Tried something else:

Used the 7.10 live cd and managed to mount /dev/sdb1 to a mount point /sdb1 as an ext3 file system.

Then I went in there and found all my files, so I know they exist and the machine can see them.

Then in sdb1 I sudo gedited /etc/fstab and /boot/grub/menu.lst to change sda to sdb.

Umounted, rebooted and...it still hung at Waiting, this time saying it could not find sdb1.

Found some posts various places on the Web suggesting changing some files in initramfs, and even running a command to update or re-install that, but I could find no man nor info files on it, so did not want to just jump in and do that.

Is this helping? Surely there is a way to mount from the old drive?

Thanks!

Going to get some sleep now....

dgermann 12-03-2007 10:57 PM

syg00--

OK! You're on to something.

Do you think using Gutsy 7.10 would work, too?

If so, here is what I see as the steps--

1. Install Gutsy or Feisty to the new drive.

2. Mount the old drive under the new system.

3. Somehow (this is where I am lost) upgrade the Dapper 6.06 to now be 7.10.

So how do I do step 3?

What I want to do is preserve my settings and preferences in things like OOo and Evolution (including mail contact lists).

Two other thoughts suggest themselves to me:

A. Just install Gutsy on the new drive, then figure out how to import my files and settings from the old drive.

B. Put the hard drive in another box that has the same configuration as the old computer and mobo, do an upgrade to Gutsy, and then physically reinstall the old drive on this new box.

Does any of this make any sense at this late hour? What would be my best choice, and why?

Thanks for pointing me in the right direction, syg00!

syg00 12-03-2007 11:08 PM

Sorry, I meant Gutsy/gusty/7.10 ... whatever.
See my first response.

dgermann 12-04-2007 09:29 AM

syg00--

Many thanks.

Rereading your first response you say "nominating" the /home partition. I am not sure what you mean by nominating.

Once I have done as you suggested, how do I get my old settings back, say in OOo where I have many custom key combinations and autotexts? Or the addressbooks and archived mail in Evo?

Thanks!


All times are GMT -5. The time now is 11:17 AM.