-   Linux - Hardware (
-   -   Strange USB problems - it works AND it works not (

Nightfrost 10-07-2004 03:28 PM

Strange USB problems - it works AND it works not
I'm having a rather strange problem with my USB. I have searched these forums but couldn't find anything relevant. I know there are LOTS on USB-issues out there, but to be frank, I hardly know what to look for. Well, what I'm trying to say is that I'm sorry if this problem has been resolved in another thread and that case I'd be most thankful if someone would redirect me.

I'm using, debian based Kanotix, kernel

Now, to the problem:

I have a built in 7-in-1 mem-card reader, with an SD-card, working beautifully. I also have a firewire external HDD, working like a charm. If I enter my USB-stick or use the USB-port for the external HDD, they won't get detected. I get the following message (dmesg):


[<c0107742>] __report_bad_irq+0x22/0x80
 [<c0107810>] note_interrupt+0x50/0x80
 [<c0107a88>] do_IRQ+0x138/0x150
 [<c0106118>] common_interrupt+0x18/0x20
 [<c0100f3b>] inflate_codes+0x4ab/0x540
 [<c011d6d1>] __do_softirq+0x31/0x90
 [<c011d756>] do_softirq+0x26/0x30
 [<c0107a65>] do_IRQ+0x115/0x150
 [<c0106118>] common_interrupt+0x18/0x20
 [<c0104113>] mwait_idle+0x33/0x50
 [<c01040c5>] cpu_idle+0x25/0x40
 [<c052e6b1>] start_kernel+0x191/0x1d0
[<f8f2b050>] (snd_emu10k1_interrupt+0x0/0x370 [snd_emu10k1])
Disabling IRQ #11

Now, if I restart my computer with the USB-stick in the USB-drive. It gets detected.

Everything has worked earlier though. Unfortunately, I don't remember if it was with a different kernel or not.

If anyone feels like illuminating me, I would love to know what the message returned means. Thanks a lot.

busbarn 10-07-2004 04:50 PM

I've read somewhere that the 2.6.8 kernel has usb troubles with some distros. It might be 2.6.7--sorry I can't remember. It's also possible that your usb controller is on the fritz. Try loading a live cd, and then plug in your usb stuff and see if that works.

Nightfrost 10-07-2004 06:07 PM

thanks for the suggestion. I've already tried it with the Kanotix LiveCD but I had the same problem. I just tried with a Gentoo 2004.2 LiveCD and everything seemed to work fine. So, the probably is most probably with the kernel. Now, I'm just gonna figure out how to compile an older kernel :)

All times are GMT -5. The time now is 06:14 AM.