LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   Strange noises and delay with unformatted SATA3 hard drive on SATA2 port (http://www.linuxquestions.org/questions/showthread.php?t=4175444694)

masterclassic 01-08-2013 12:55 PM

Strange noises and delay with unformatted SATA3 hard drive on SATA2 port
 
The system:
Motherboard ASUS P5B Deluxe WiFi (SATA2 Intel ICH8 controller, 6 ports, in IDE mode)
CPU Intel Core2 Duo (2.4 GHz)
2 GiB RAM
2 SATA2 hard drives Seagate 320GB-system HD, 500GB)
3 SATA2 hard drives WD Green (3 x 2TB) data disks
2 optical drives (ATA)
1 floppy drive 1.44 MiB (3 1/2)
Main O.S. win XP.


I try to add a new WD20EARX hard drive (2TB SATA3). I disconnected one of the already connected 2TB HDs and connected the new drive to the power and data cables. On power-on (POST) it was quite long to detect the new drive. The drive was correctly reported in the BIOS setup. I remarked rhythmic noises during this phase, something like 4 or 5 per second, very regular. It wasn't the irregular noises we hear from dying drives. I never had such noises in the past, connecting new SATA2 drives.

Furthermore, after partitioning, copying data from another partition and running chkdsk from xp on boot-up, the drive was silent, like the remaining drives. This was true for the POST, and running XP or Linux livecds.
I have to add that format and partition copy with GParted were very long, I think. About 10 minutes for the (quick) ntfs format, instead of 1 minute or so I expected. Something like 4 hours for 400GiB copy, from SATA to SATA (no USB).

But, I found that the copy wasn't correct, and the data were largely corrupted. So, I decided to repeat the process. I did disconnect all other drives, boot into GParted live, I deleted the partition and erased the first 10 MiB of the hard drive (with dd from the terminal) to be sure that there is nothing wrong from the previous session. After reboot, the strange regular noises were back, as well as the delay to be detected in the POST.
The drive is reported healthy and OK by SMART in the POST.

What do you think?
I didn't find anything similar in Linuxquestions or elsewhere. I find info about defective or dying drives, but this stopped once the drive formatted and reappeared after deleting the partitions and the partition table.

- Can there be any issue for the unformatted SATA3 drive on the SATA2 controller?
- Anything to do with jumpers? WD claims that there is no need of jumpers to connect it to a SATA2 controller. No need to use the special jumper for the alignment, as the partitioning is done by Linux.
- Any BIOS issue?

TobiSGD 01-08-2013 02:50 PM

Some mainboards have difficulties with some specific SATA3 disks, this may be an issue here. It may also be a faulty or not correctly fitting SATA data cable. I would try to change that first, to rule this out.
After that I would recommend to test the disk with manufacturer's diagnosis tool. If the drive passes the test I would recommend to test the disk in a different computer, if possible.

masterclassic 01-10-2013 07:00 AM

Thank you TobiSGD.
I checked the cables, no solution.
I tried from win xp (although I am more confident to the Linux tools), just in case... : I tried 2-3 times to have the drive detected by the disk manager, I created a partition but wasn't allowed to format it at all!

It seems that there is a hardware problem in the drive.
I had a second drive of this same model (bought from some other computer shop a few days later). I tried it instead and found that everything was much easier and faster. The drive appeared in the POST almost immediately (with a delay of just 1-2 seconds). Creating the partition table was a matter of 2 seconds for GParted, same for the creation of a new unformatted partition. The (quick) format took no more than 5-10 seconds. All this, with no jumper on the drive. However, I forgot to check dmesg. I have to check this too.

From this, I understand that the problem is related to the drive it self, not to the BIOS or the software. That's why I gave it back to the service with no further check, to be replaced. However, I will test the working drive, to be sure that everything is right. I remarked that the transfer rate is rather lower than the sata2 drives, but I think it is minor problem. I try to avoid BIOS update if not absolutely necessary. From the other side, I have 1 PCI-e port only, so I have to choose a SATA3 controller or a USB3 card.

I will post latest news about the hardware issue, in the next few days.
:)

TobiSGD 01-10-2013 07:26 AM

SATA3 disks are not really faster than SATA2 disks, the main purpose for those high specs of SATA3 is the ability to handle the speeds of modern SSDs, so you can't expect a significant speedup just because a disk has a SATA3 interface.

masterclassic 01-10-2013 09:17 AM

Quote:

Originally Posted by TobiSGD (Post 4866994)
SATA3 disks are not really faster than SATA2 disks, the main purpose for those high specs of SATA3 is the ability to handle the speeds of modern SSDs, so you can't expect a significant speedup just because a disk has a SATA3 interface.

Furthermore, we can't expect any speedup at all by connecting the drive to s SATA2 port ;)
It seems that there are less and less SATA2 drives in the market.

I understand well that numbers like 1.5 or 3 or 6 gbit/s refer to the interface, not to the data source (the rotating hard drive). Perhaps it is true for the cached content only.
The basic SATA 1.5 gbit/s means 187.5 MB/s, i.e. about 10 GiB/minute. I never noticed myself more than 5 GiB/minute for a big volume transfer (100 GiB or more) between drives.
I just wondered why a first fast check gave even slower speeds than that (4 or 4.5 minutes for 15 GiB of data). Anyway, reliability is more important than extreme speed, for me. :)

masterclassic 01-17-2013 08:10 AM

More news:

The hard drive was defective of damaged. The service lab checked it and gave me a new one (same model).

I can't exclude that the drive was damaged in the shop, due to some fall to the floor. The packaging is really bad, just a fine plastic sealed cover. (I remember the packaging of the old hard drives, at the era of, say, 2GB (instead of TB! ). A case of very thick cardboard and a thick plastic foam cover.)

I have to install and partition it in the next few days.

masterclassic 01-22-2013 12:52 PM

I installed the new hard drive. No problem this time.
Thank you very much, all!


All times are GMT -5. The time now is 07:05 PM.