-   Linux - Hardware (
-   -   startX not working (

sathish 02-03-2003 06:13 AM

startX not working
Having successfully installed RedHat Linux 7.2 in a P4 machine with 512 MB RAM & Intel D845GLLY chipset,Iam not able to invoke X windows.I get the following response from issuing the “startx” command:

XFree86 Version 4.1.0 (Red Hat Linux release: 4.1.0-3) / X Window System
(protocol Version 11, revision 0, vendor release 6510)
Release Date: 2 June 2001
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems. (See http://www.XFree86.Org/FAQ)
Build Operating System: Linux 2.4.7-0.13.1smp i686 [ELF]
Build Host:

Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Mon Feb 3 16:43:14 2003
(==) Using config file: "/root/XF86Config"
Parse error on line 2 of section (null) in file /root/XF86Config
"key" is not a valid keyword in this section.
(EE) Problem parsing the config file
(EE) Error from xf86HandleConfigFile()

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to

I tried the installation in a P3 machine with 810 chipset and everything is working fine.I think the problem is with the chipset. Can any body help me to solve the problem ...?


rootboy 02-03-2003 06:41 AM

Sounds like your XF86Config file is:

a) Not where it is supposed to be (/etc/X11/ is where *I think* it ought to be for Redhat)

b) Corrupted. You didn't happen to edit it using a DOS editor by chance? Post it here if you would.

Redhat has X configurator programs, but as an SuSE user, I don't know exactly what they are (/usr/X11R6/xf86config4 maybe?)

Just curious, but why aren't you using a more recent version of Redhat?


Dathto 02-03-2003 06:45 AM

open the /root/XF86Config start looking on line 2 .
either remove the word "key" and test it or if this wont work you have to take a look at the syntax in this file (easy to understand)

PS: always make a copy from that file before editing it ;)

webboss 02-07-2003 07:14 AM

Hi Satish,
If you r using Red Hat use "XConfigurator" or "xsetup". Check the upper and lowercase of the commands I have mentioned.
Red Hat has this XConfigurator program for setting up xwindow.

Hope this should solve the problem.

All times are GMT -5. The time now is 09:56 PM.