Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 09-30-2003, 01:18 PM   #1
Registered: Sep 2003
Location: Ontario, Canada
Distribution: Gentoo 2004.3
Posts: 195

Rep: Reputation: 30
starting into text mode after installing NVIDIA driver

I went to the NVIDIA for linux discussions to get help on this (makes sense right?) and they're not even answering my posts. I've gotten great results here so I'm trying again

I just recently installed the newest NVIDIA drivers and followed all the instructions. Now when starting up I come to a text only login screen. I can type in my login or root and login but I'm in a console like text screen and I don't have my desktop.

If I restart my computer, one of the options on my grub loading is failsafe, when I choose that I have the option of grapic and network startup or text and network startup. If I choose the graphic and network option I can get back to my desktop just fine. It's just a pain. When I do it that way I get the NVidia splash screen and the driver appears (as far as I can tell) to be working fine. I just want it to start into the X server automatically like it used to

Now, when I installed the driver I restarted into the text only mode to do it (I think that may be the problem). I've change my XFree86-4 file. I've noticed a similar problem like this on the NVidia FAQ but it says that for that issue you will get an error in the XFree86.0.log file which I'm not getting. Plus it says that driver doesn't work properly, which mine seems to be.

I believe it mentions it already but I'm using Mandrake 9.1. specs are:

Pentium 4 1.4 GHz
Asus P4T motherboard
Geforce 4 Ti 4200
Old 09-30-2003, 01:40 PM   #2
Registered: May 2003
Location: Guadalajara, Mexico
Distribution: Mandrake
Posts: 46

Rep: Reputation: 15
Hi kaega2

Just go to Mandrake Control Center and choose "Boot" then "Boot Config" and check the box "Launch the graphical environmnet when your system starts" or something similar and that's all.

You can start the X mode typing startx in the text console.


Last edited by Madrinator; 09-30-2003 at 01:48 PM.
Old 09-30-2003, 02:51 PM   #3
Registered: Sep 2003
Location: Ontario, Canada
Distribution: Gentoo 2004.3
Posts: 195

Original Poster
Rep: Reputation: 30
Thanks Madrinator. You're advice didn't solve the problem but it's helping me get there. The option to start it automatically was already checked. So I unchecked it and then tried starting X manually. I'm now getting the error as described on the NVidia FAQ, so I can follow their troublshooting to fix the issue. Thank you again


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Oracle10G in Text mode vipspark Linux - Enterprise 1 03-21-2005 11:46 AM
installing suse 9.1 in text mode mike4realz Linux - Newbie 1 02-20-2005 05:40 AM
text mode is unusable (not working) if nvidia 3D drivers are enabled K6H Linux - Software 6 01-12-2005 07:06 AM
starting in text mode ickselglic Linux - General 2 03-09-2004 10:24 PM
can only run text mode x driver wont work in redhat 7.0 rob,carly Linux - Software 2 08-13-2003 04:48 PM > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:54 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration