LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Sportster Flash 56000 Rev. 10.3.80 serial dial but can't connect (pppd error i think) (https://www.linuxquestions.org/questions/linux-hardware-18/sportster-flash-56000-rev-10-3-80-serial-dial-but-cant-connect-pppd-error-i-think-349174/)

nik*s 08-02-2005 08:35 AM

Sportster Flash 56000 Rev. 10.3.80 serial dial but can't connect (pppd error i think)
 
hello,is my first time that i post.I have a Sportster Flash 56000 Rev. 10.3.80 ext paralel to serial & Debian sarge r3.1 2.6.8 and when i dial with wvdial it gives me:"-->WvDial: Internet dialer version 1.54.0
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT(mynumber)
--> Waiting for carrier.
ATDT(mynumber)
CONNECT/ARQ
User Access Verification
Username:
--> Carrier detected. Waiting for prompt.
Username:
--> Looks like a login prompt.
--> Sending:(name)
(name)
Password:
--> Looks like a password prompt.
--> Sending: (password)
Login succefull.
Entering PPP mode.
Async interface address is unnumbered (FastEthernet0)
Your IP address is (ipadress). MTU is 1500 bytes
--> Looks like a welcome message.
--> Starting pppd at Mon Aug 1 01:35:14 2005
--> pid of pppd: 4889
--> Using interface ppp1
--> local IP address (ipadress)
--> remote IP address (ipadress)
--> primary DNS address (ipadress)
--> secondary DNS address (ipadress)"And with kppp it dial but it stop with err1.(i have dynamic conection).Sorry about my length i hope that i was helpful.

oot 08-03-2005 08:11 PM

OK... the wvdial part looks normal, and looks like you're connected successfully.

Here's a few questions:

1. After you've run wvdial, does it stay like that, or does it dump you back to a terminal? When you pick up your phone, do you keep hearing modem noise, or had it stopped once wvdial printed out all that info?

2. Please post the output of the command "route", before AND after you have run wvdial.

3. Please post the output of /etc/resolv.conf before AND after you have run wvdial.

4. Try pinging 216.239.39.99 (this is Google's IP address) after you have run wvdial.

nik*s 08-04-2005 01:56 PM

Thank you for reply to my post.:
I doing this with no network.(my win32/gateway (home 2 pc net) is closed) and with closed firewall
when i pick up my phone i dont hear nothing and wvdial stay at the term from where i run it.
route before:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
localnet * 255.255.255.0 U 0 0 0 eth0
defa (my win32/workgroup) 0.0.0.0 UG 0 0 0 eth0
route AFTER:
Destination Gateway Genmask Flags Metric Ref Use Iface
62.38.4.15 * 255.255.255.255 UH 0 0 0 ppp0
localnet * 255.255.255.0 U 0 0 0 eth0
default (my win32/workgroup) 0.0.0.0 UG 0 0 0 eth0

(i was put my linux for domain and for host win32 workgroup i use a win32 gateway and samba. one friend sugested me that maybe i must put my modem for first gateway i try it but i am very confused and tired already so i give it up and i start looking for help.)

resolv BEFORE:
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver (my gateway adress win32)
search (my win32 workgroup)

resolv AFTER:
nameserver (my gateway adress win)
nameserver 194.30.220.114
nameserver 194.30.220.117
search (my win workgroup)

PING 216.239.39.99 (216.239.39.99) 56(84) bytes of data.
From (my network address???) maybe i get my pc confused too! icmp_seq=1 Destination Host Unreachable

ifconfig:
ppp0 Link encap:Point-to-Point Protocol
inet addr:62.38.227.232 P-t-P:62.38.4.15 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:256 (256.0 b) TX bytes:97 (97.0 b)

sorry for my english.

nik*s 08-07-2005 08:55 AM

watch out ppp and eth gateway
 
hello i made it. it was easier than i though and thanks oot and the aboutdebian.com tutor
the only think that i have to do is to open a console and press:' route del default eth0' because eth0 represented my windows gateway as default(i reach the internet with it before) and was created a deadend!Sow i delete it and the 'route' takes ppp0 as default when i connect.

nik*s 08-07-2005 08:58 AM

and this was the reason that it was ping from my internal network address.but now all works fine and im post from linux. : )


All times are GMT -5. The time now is 06:09 AM.