Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 02-11-2004, 12:40 AM   #1
LQ Newbie
Registered: Nov 2003
Location: Galveston, TX
Distribution: Slackware 9.1
Posts: 5

Rep: Reputation: 0
Network: Speedstream 1020 problems on Mandrake 9.2

I'm running a dual-boot setup with WinXP Pro and Mandrake 9.2. i'm trying to move over to Linux as my primary OS, but a major hindrance has been that i haven not been able to get my network card configured correctly. i have a Siemens Speedstream 1020 (rev 2). I've researched as much as i can, and read all the threads and posts - active and archived - i can find on this, and have not been able to get it working for me. Here is all the information i've collected while running all the third-hand advice i've found:

Harddrake2 v9.1.1 info:
Vendor: (null)
Bus: PCI
Bus identification: 1432:9130:111a:1020
Location on the bus: 0:9:0
Module: unknown


[root@localhost jacob]# uname -r


[root@localhost jacob]# cat /proc/pci
Bus 0, device 9, function 0:
Ethernet controller: PCI device 1432:9130 (Edimax Computer Co.) (rev 16).
IRQ 10.
Master Capable. Latency=32. Min Gnt=32.Max Lat=64.
I/O at 0xd000 [0xd0ff].
Non-prefetchable 32 bit memory at 0xef000000 [0xef0000ff].


[root@localhost jacob]# /sbin/ifconfig -a
lo Link encap:Local Loopback
inet addr: Mask:
RX packets:597 errors:0 dropped:0 overruns:0 frame:0
TX packets:597 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:40329 (39.3 Kb) TX bytes:40329 (39.3 Kb)


[root@localhost jacob]# lsmod
Module Size Used by Not tainted
udf 88736 0 (autoclean)
lp 8160 0
parport_pc 25544 1
parport 34472 1 [lp parport_pc]
radeon 108512 14
agpgart 48292 3 (autoclean)
cmpci 33060 0
soundcore 6340 0 [cmpci]
gameport 3268 0 [cmpci]
nfsd 75280 0 (autoclean)
af_packet 14856 0 (autoclean)
sr_mod 19384 0 (autoclean)
floppy 55932 0
nls_cp850 4284 1 (autoclean)
vfat 11820 1 (autoclean)
fat 38040 0 (autoclean) [vfat]
nls_iso8859-1 3484 2 (autoclean)
ntfs 77292 1 (autoclean)
usbmouse 2936 0 (unused)
supermount 84032 3 (autoclean)
keybdev 2756 0 (unused)
mousedev 5428 1
hid 24164 0 (unused)
ide-cd 33956 0
cdrom 32608 0 [sr_mod ide-cd]
input 5696 0 [usbmouse keybdev mousedev hid]
ide-scsi 11376 0
scsi_mod 106176 2 [sr_mod ide-scsi]
usb-uhci 25136 0 (unused)
usbcore 74988 1 [usbmouse hid usb-uhci]
rtc 9004 0 (autoclean)
ext3 60048 1
jbd 39264 1 [ext3]


if there's anything else i need to do, let me know. i've done other things also (primarily modprobes), but these are the only things that have given useful results.
Eventually, i need to get set up on my school network using DHCP, but this first.

Thanks ahead for any help,

Last edited by MaddJackKidd; 02-11-2004 at 12:55 AM.
Old 02-11-2004, 05:56 PM   #2
LQ Newbie
Registered: Nov 2003
Location: Galveston, TX
Distribution: Slackware 9.1
Posts: 5

Original Poster
Rep: Reputation: 0
More Info

After reading finegan's "what to post" thread, i ran "dmesg".
When i tried to run "/sbin/lspci" is told me "No such file or directory".

Also, since i forgot to mention this earlier, i have tried rtl8139 also, as it is listed as a module on the Network Connection Wizard. But it, as well as the other modules i've tried (tulip, 8139too) has "failed" according to the Connection Wizard. And when i ran modprobe on rtl8139 it told me it could not find it.

Regarding the previous post, i do have the entire contents of "cat /proc/pci" but i cut out everything except that regarding the network card. I also have a log of everything i've done so far if it's needed.

Oh yeah, i don't know if it matters, but I'm running Mandrake 9.2 Download Edition.

Results of dmesg (it's long):

[root@localhost jacob]# dmesg
Linux version 2.4.22-10mdk ( (gcc version 3.3.1 (Mandrake Linux 9.2 3.3.1-2mdk)) #1 Thu Sep 18 12:30:58 CEST 2003
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 00000000000a0000 (usable)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000000fff0000 (usable)
BIOS-e820: 000000000fff0000 - 000000000fff3000 (ACPI NVS)
BIOS-e820: 000000000fff3000 - 0000000010000000 (ACPI data)
BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
255MB LOWMEM available.
ACPI: have wakeup address 0xc0001000
On node 0 totalpages: 65520
zone(0): 4096 pages.
zone(1): 61424 pages.
zone(2): 0 pages.
ACPI: RSDP (v000 VIA694 ) @ 0x000f6cb0
ACPI: RSDT (v001 VIA694 AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x0fff3000
ACPI: FADT (v001 VIA694 AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x0fff3040
ACPI: DSDT (v001 VIA694 AWRDACPI 0x00001000 MSFT 0x0100000d) @ 0x00000000
ACPI: Vendor "VIA694" System "AWRDACPI" Revision 0x0 has a known ACPI BIOS problem.
ACPI: Reason: Bogus table. This is a non-recoverable error
ACPI: BIOS listed in blacklist, disabling ACPI support
Building zonelist for node : 0
Kernel command line: BOOT_IMAGE=linux ro root=303 devfs=mount hdc=ide-scsi acpi=ht resume=/dev/hda2 splash=silent
ide_setup: hdc=ide-scsi
bootsplash: silent mode.
Local APIC disabled by BIOS -- reenabling.
Found and enabled local APIC!
Initializing CPU#0
Detected 1799.850 MHz processor.
Console: colour dummy device 80x25
Calibrating delay loop... 3591.37 BogoMIPS
Memory: 255332k/262080k available (1508k kernel code, 6364k reserved, -1961k data, 156k init, 0k highmem, 0k BadRAM)
Dentry cache hash table entries: 32768 (order: 6, 262144 bytes)
Inode cache hash table entries: 16384 (order: 5, 131072 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer cache hash table entries: 16384 (order: 4, 65536 bytes)
Page-cache hash table entries: 65536 (order: 6, 262144 bytes)
CPU: CLK_CTL MSR was 6003d22f. Reprogramming to 2003d22f
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 256K (64 bytes/line)
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: After generic, caps: 0383fbff c1c3fbff 00000000 00000000
CPU: Common caps: 0383fbff c1c3fbff 00000000 00000000
CPU: AMD Unknown CPU Type stepping 01
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
enabled ExtINT on CPU#0
ESR value before enabling vector: 00000000
ESR value after enabling vector: 00000000
Using local APIC timer interrupts.
calibrating APIC timer ...
..... CPU clock speed is 1799.9149 MHz.
..... host bus clock speed is 266.6540 MHz.
cpu: 0, clocks: 2666540, slice: 1333270
mtrr: v1.40 (20010327) Richard Gooch (
mtrr: detected mtrr type: Intel
ACPI: Subsystem revision 20030813
ACPI: Interpreter disabled.
PCI: PCI BIOS revision 2.10 entry at 0xfb520, last bus=1
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: ACPI tables contain no PCI IRQ routing entries
PCI: Probing PCI hardware (bus 00)
PCI: Using IRQ router default [1106/3099] at 00:00.0
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS version 1.2 Flags 0x07 (Driver version 1.16)
Starting kswapd
kinoded started
VFS: Disk quotas vdquot_6.5.1
devfs: v1.12c (20020818) Richard Gooch (
devfs: boot_options: 0x1
vesafb: framebuffer at 0xe0000000, mapped to 0xd0800000, size 1875k
vesafb: mode is 800x600x16, linelength=1600, pages=67
vesafb: protected mode interface info at c000:5552
vesafb: scrolling: redraw
vesafb: directcolor: size=0:5:6:5, shift=0:11:5:0
Looking for splash picture.... silenjpeg size 107888 bytes, found (800x600, 107840 bytes, v3).
Got silent jpeg.
Got silent jpeg.
Console: switching to colour frame buffer device 92x32
fb0: VESA VGA frame buffer device
Detected PS/2 Mouse Port.
pty: 1024 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI ISAPNP enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
RAMDISK driver initialized: 16 RAM disks of 32000K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: IDE controller at PCI slot 00:11.1
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
VP_IDE: VIA vt8233a (rev 00) IDE UDMA133 controller on pci00:11.1
ide0: BM-DMA at 0xd800-0xd807, BIOS settings: hdaMA, hdbMA
ide1: BM-DMA at 0xd808-0xd80f, BIOS settings: hdcMA, hddMA
hda: IC35L060AVVA07-0, ATA DISK drive
hdb: Maxtor 6Y120P0, ATA DISK drive
blk: queue c0180d20, I/O limit 4095Mb (mask 0xffffffff)
blk: queue c0180e5c, I/O limit 4095Mb (mask 0xffffffff)
hdc: TDK CDRW401240B, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: attached ide-disk driver.
hda: host protected area => 1
hda: 120103200 sectors (61493 MB) w/1863KiB Cache, CHS=7476/255/63, UDMA(33)
hdb: attached ide-disk driver.
hdb: host protected area => 1
hdb: 240121728 sectors (122942 MB) w/7936KiB Cache, CHS=14946/255/63, UDMA(33)
Partition check:
/dev/ide/host0/bus0/target0/lun0: p1 p2 p3
/dev/ide/host0/bus0/target1/lun0: p1
ide: late registration of driver.
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
Initializing Cryptographic API
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 2048 buckets, 16Kbytes
TCP: Hash tables configured (established 16384 bind 32768)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
Resume Machine: This is normal swap space
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 299k freed
VFS: Mounted root (ext2 filesystem).
Swsusp 1.0.3: kswsuspd starting
Mounted devfs on /dev
Journalled Block Device driver loaded
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
Mounted devfs on /dev
Freeing unused kernel memory: 156k freed
Got silent jpeg.
Real Time Clock Driver v1.10e
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.275 $ time 12:42:04 Sep 18 2003
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: USB UHCI at I/O 0xdc00, IRQ 12
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: USB UHCI at I/O 0xe000, IRQ 12
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
usbdevfs: remount parameter error
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,3), internal journal
Adding Swap: 1028152k swap-space (priority -1)
hub.c: new USB device 00:11.2-1, assigned address 2
usb-uhci.c: interrupt, status 2, frame# 562
usb.c: USB device not accepting new address=2 (error=-110)
hub.c: new USB device 00:11.2-1, assigned address 3
usb.c: USB device 3 (vend/prod 0xac8/0x301) is not claimed by any active driver.
hub.c: new USB device 00:11.2-2, assigned address 4
usb.c: USB device 4 (vend/prod 0x45e/0x39) is not claimed by any active driver.
SCSI subsystem driver Revision: 1.00
hdc: attached ide-scsi driver.
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
Vendor: TDK Model: CDRW401240B Rev: Z7SB
Type: CD-ROM ANSI SCSI revision: 02
usb.c: registered new driver hiddev
usb.c: registered new driver hid
hdd: attached ide-cdrom driver.
hdd: ATAPI 40X DVD-ROM drive, 512kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
input: USB HID v1.10 Mouse [Microsoft Microsoft 5-Button Mouse with IntelliEye(TM)] on usb1:4.0
hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <>
hid-core.c: USB HID support drivers
mice: PS/2 mouse device common for all mice
usb.c: registered new driver usbmouse
usbmouse.c: v1.6:USB HID Boot Protocol mouse driver
NTFS driver 2.1.4a [Flags: R/O MODULE].
NTFS volume version 3.1.
MSDOS FS: Using codepage 850
MSDOS FS: IO charset iso8859-1
inserting floppy driver for 2.4.22-10mdk
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
sr0: scsi3-mmc drive: 8x/48x writer cd/rw xa/form2 cdda tray
sr0: mmc-3 profile capable, current profile: 2h
sr0: mmc-3 profile: 2h
sr0: mmc-3 profile: 2h
sr0: mmc-3 profile: 2h
sr0: mmc-3 profile: 2h
Installing knfsd (copyright (C) 1996
cmpci: version $Revision: 6.16 $ time 12:41:28 Sep 18 2003
cmpci: found CM8738 adapter at io 0xd400 irq 12
cmpci: chip version = 037
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 203M
agpgart: Detected Via Apollo Pro KT266 chipset
agpgart: AGP aperture is 64M @ 0xe8000000
[drm] AGP 0.99 Aperture @ 0xe8000000 64MB
[drm] Initialized radeon 1.7.0 20020828 on minor 0
parport0: PC-style at 0x378 [PCSPP,TRISTATE]
parport0: Printer, Lexmark Lexmark Z22-Z32
lp0: using parport0 (polling).
Looking for splash picture.... found (800x600, 14470 bytes, v3).
Splash status on console 0 changed to on
Looking for splash picture.... found (800x600, 14470 bytes, v3).
Splash status on console 1 changed to on
Looking for splash picture.... found (800x600, 14470 bytes, v3).
Splash status on console 2 changed to on
Looking for splash picture.... found (800x600, 14470 bytes, v3).
Splash status on console 3 changed to on
Looking for splash picture.... found (800x600, 14470 bytes, v3).
Splash status on console 4 changed to on
Looking for splash picture.... found (800x600, 14470 bytes, v3).
Splash status on console 5 changed to on
spurious 8259A interrupt: IRQ7.

Old 02-18-2004, 01:48 AM   #3
LQ Newbie
Registered: Nov 2003
Location: Galveston, TX
Distribution: Slackware 9.1
Posts: 5

Original Poster
Rep: Reputation: 0
Oh well, i gave up and installed CollegeLinux, which worked great. I noticed while it was booting that it loaded the RTL8139 module for my eth0... I don't know waht Mandrake's problem was. I'm still going to recommend Mandrake for all my computer-illiterate friends to convert to. The only way i knew what was up with CollegeLinux was becasue I'd extensively read the Slackware Book.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Use of SpeedStream 5100b + Mandrake 10 The MCP Linux - Networking 0 08-23-2004 01:03 AM
Realtek 8139 (Speedstream 1020) compiles for different kernel?!?! hobbes567 Linux - Hardware 1 06-26-2004 08:01 AM
Mandrake 9.1 and Bettery Stat on a Evo 1020 cujo31 Linux - Laptop and Netbook 2 10-07-2003 11:16 PM
Mandrake 9.1 with Siemens SpeedStream 1024 wireless CptSiskoX Linux - Hardware 4 04-13-2003 11:27 PM
Siemens Speedstream 1024 on Mandrake 9.1 CptSiskoX Linux - Distributions 3 04-12-2003 09:22 PM > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 07:45 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration