LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   soundcard Problem (https://www.linuxquestions.org/questions/linux-hardware-18/soundcard-problem-334343/)

mahednranit 06-16-2005 06:02 PM

soundcard Problem
 
Hi,
I am using the RedHat 8 (Kernal V.2.4) in the following platform..

Motherboard : Intel 845GVSR
Audio : On Board (AC'97)
RAM : 128MB

I am having the linux as dual boot with Win98. In win98 I am getting the audio... but in Linux is not !..

Here giving my observation and error messages what I am getting.....

#1) while giving the command lspci it showing the following output

00:1P.5 Multimedia audio controller: Intel Corp. 82801DB AC'97 Audio [b] (rev 01)


#2) While loging into the GUI Mode the following error is poping
Unable to open /dev/dsp file

#3) While opening the Volume controller......
I was not able to Open your audio device. Please check that you have permission to Open /dev/mixer and make sure you have sound support compiled into your kernal.

#4) cat mixer
PCI: Setting latency timer of device 00:1f.5 to 64
i810_audio: Primary codec not ready
cat:mixer: No such device [b]

Is the intel 845GVSR motherboard is supportable to Redhat 8? If so, Please some let me know the solution to fix the same....

Thanks

kornerr 06-17-2005 01:11 PM

So do you have permissions to use a sound device? Check if root has.
Smth about configuring ALSA

mahednranit 06-17-2005 01:33 PM

I am working in root user only... also I had changed the permission to 777.....

still I am getting the error message " u dont have permission to open the file mixer" when ever I am trying to open to volume controller in Gnome / Kde.

I had removed the entry for audio from /etc/sysconfig/hwconf and tried to detect it thr kudzu.... it has beed detected as i810_audio and also the error msg has been poped that sound card initializing err and changing into null output device.....

in the output of pcimod command their is no enty for the sound card too...

Please tell me if u need any other configuration details to fix the problem.... I dont hv clear idea in linux....

Please help me...

kornerr 06-17-2005 09:36 PM

Have you run "alsaconf" to detect your sound card?
Does your kernel know of the sound card? You have a standard kernel or compiled by you?

mahednranit 06-18-2005 12:40 PM

I had fixed the problem.... Now I am getting the sound..... :cool:

In redhat 8 (kernal 2.4-18-14) is not having the driver for Intel 845GVSR m/b's soundcard AC'97.

I had get the driver from intel site and installed the same...now I am getting the sound......

[b]kornerr pls tell me how to run a mp3 in Redhat 8 GNOME. I can able to run the Track audio from CD... but none of the software supporting the mp3. Pls help to fix it.

If I try to run movie / Windows game casear & Zeus i am getting the following error message....


Nautilus has no installed viewr capable of dispaying the xyz file

Please help me.....


Thanks

kornerr 06-18-2005 01:04 PM

I play mp3 with xmms. If soundcard is properly configured, then you should be able to listen to mp3.

mahednranit 06-18-2005 01:19 PM

while I playing the mp3 songs from HDD (in xmms)it scrolling some ascii values in its play list.

Please tell me what are all the configuration i have to do in my xmms.

and also please tell me how to play a movie

Thanks

kornerr 06-19-2005 12:00 AM

http://www.linuxquestions.org/questi...36#post1653236
it's all xmms configuring I did, and it works not only for me, so it should work for you.
If not, post step by step what you did to configure sound.

mahednranit 06-20-2005 01:40 PM

kornerr, Could u plz explain me how and where I hv to do the following Plz

arts is said to be s**t, so turn it off;

sorry, I cant get u what ur trying to say here!

kornerr 06-20-2005 10:02 PM

Quote:

kornerr, Could u plz explain me how and where I hv to do the following Plz

arts is said to be s**t, so turn it off;

sorry, I cant get u what ur trying to say here!
arts is KDE's sound manager.
Later on I've noted that arts is not s**t.
If you use KDE you can try using sound either with or without arts. Choose the best variant for yourself. I use arts (and KDE).
BTW, arts is in KDE Control Center in Sound & Mutimedia.

mahednranit 06-21-2005 12:46 PM

Oh... I am using Gnome..... is it possible to configur it in Gnome....? any how.. I will try it kde too by today.

and today I tried as u told, but I cant find the /.asoundrc file....

I here with giving the group/errors & version details which I having


Version : xmms-1.2.7.13.p
---------------------------------------------------------------------------------------------------------------------------

While I tried to install alsa-driver-0.9.6-1.fr.i386.rpm

[root@Magi test]# rpm -ivh alsa-driver-0.9.6-1.fr.i386.rpm
warning: alsa-driver-0.9.6-1.fr.i386.rpm: V3 DSA signature: NOKEY, key ID e42d547b
Preparing... ########################################### [100%]
package alsa-driver-0.9.6-1.fr is already installed
[root@Magi test]#
--------------------------------------------------------------------------------------------------------------------------

But while querying it shows

[root@Magi test]# rpm -q alsa-driver-0.9.6-1.fr.i386.rpm
package alsa-driver-0.9.6-1.fr.i386.rpm is not installed
[root@Magi test]#
---------------------------------------------------------------------------------------------------------------------------

I dont hv the ALSA in xmmx preference tab->Output plugins......

I hving the following things in Output Plugins

aRts Driver 0.4 [libartsout.so]
Disk Writer Plugin 1.2.7. [libdisk_writer.so]
eSound Output Plugin 1.2.7 [libesdout.so]
OSS Driver 1.2.7 [libOSS.so]

---------------------------------------------------------------------------------------------------------------------------

Content of the Group File
==================
root:x:0:root
bin:x:1:root,bin,daemon
daemon:x:2:root,bin,daemon
sys:x:3:root,bin,adm
adm:x:4:root,adm,daemon
tty:x:5:
disk:x:6:root
lp:x:7:daemon,lp
mem:x:8:
kmem:x:9:
wheel:x:10:root
mail:x:12:mail,postfix
news:x:13:news
uucp:x:14:uucp
man:x:15:
games:x:20:
gopher:x:30:
dip:x:40:
ftp:x:50:
lock:x:54:
nobody:x:99:
users:x:100:
ntp:x:38:
utmp:x:22:
rpc:x:32:
floppy:x:19:
vcsa:x:69:
nscd:x:28:
sshd:x:74:
rpm:x:37:
mailnull:x:47:
smmsp:x:51:
slocate:x:21:
rpcuser:x:29:
nfsnobody:x:65534:
pcap:x:77:
xfs:x:43:
gdm:x:42:
postdrop:x:90:
postfix:x:89:
havardk:x:500:

Plz help me to fix it.. .

kornerr 06-21-2005 02:10 PM

Since I don't use GNOME, and don't like rpm-based distros I can only tell what I'd do if I were you.

1) try to uninstall alsa, then try to install again;
2) download the latest alsa from http://alsa-project.org ;
3) install the latest alsa
Code:

./configure
make
make install

in dirs alsa-driver, alsa-lib, alsa-oss, alsa-utils (may be without the last one), running commands as root;
or instead of 2 & 3 update rpm packages of alsa, if it's possible
4) have a better look at sound modules of kernel; to have AC'97 sound in 2.4.x you should have Input Core Support and all sound things compiled as modules;
5) run xmms from console in GUI and see the possible xmms errors.

Good Luck.

PS: 6) and may be try a newer distro, let's say FC4 wich comes with 2.6.x kernel. 2.6.x has ALSA built in, so it's easier to get sound working there.

PS2: you should create ~/.asoundrc by yourself. But this file makes effect only if you have ALSA.

mahednranit 06-21-2005 02:24 PM

Ya I am downloding the alsa driver and kernal too....

Could u pls tell me where I hv to create the .asoundrc file.....?

in 3rd step u had mentioned .configure.... is it the command or the file / directory?

kornerr 06-21-2005 09:40 PM

Code:

./configure
make
make install

is what you should type in each of the described alsa-* dirs.

mahednranit 06-22-2005 01:16 PM

At last I got the sound and I can play mp3........ Thanks for your kind suggestions.......:)

But for ur info, After installing the xmms-mpg123-1.2.7-21.i386.rpm I can able to play the mp3.......

and also I had installed the alsa-driver-0.9.6-1.fr ......

now what is the problem is..:(

1) Poor quality of audio; only on MP3, the system sound is perfect. the same MP3 playing fine in Windows.

2) as of your suggestion I had created the .asoundrc with code what u hv mentioned but no difference.....

3) After installing the alsa package also I hvnt get alsa output plugins in xmms preference window. Still it running in eSound Output Plugin 1.2.7 [libesdout.so]

4) Same MP3 file is cycling until I give/click the next command/button...

Pls guide me how fix it.....

Thanks


All times are GMT -5. The time now is 10:16 AM.