LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 03-02-2004, 02:39 PM   #1
nrunge
Member
 
Registered: Oct 2003
Distribution: Debian Woody (2.4.22)
Posts: 182

Rep: Reputation: 30
Soundcard Problem


I have an Asus A7V8X-X motherboard which has on it a ADI 1980 6-channel CODEC
S/PDIF out interface soundcard. I have both 2.6.0 and 2.6.3 kernel versions compiled on my machine and no matter what modules I enable I simply cannot get my soundcard to work. When KDE starts up it says that /dev/dsp is not functioning correctly. If I have to install a 3rd party driver that would be fine but I cannot find one anywhere for my soundcard. Any help would be greatly appreciated as I wouldnt even know where to start issuing command to toubleshoot a soundcard problem. I must add that I have both ALSA and OSS compiled into the kernel and different modules selected under both, I was also wondering if that is known to cause any conflicts.

Last edited by nrunge; 03-02-2004 at 02:41 PM.
 
Old 03-02-2004, 05:32 PM   #2
Rounan
Member
 
Registered: Jun 2003
Location: Ontario
Distribution: Ubuntu, Gentoo, Debian
Posts: 416

Rep: Reputation: 30
Did you compile them as insertable modules? Or directly into kernel?
I think if you have them both compiled directly, that is going to be one VERY confused kernel, and as modules, only one would load at once.

Drop OSS. Stick with ALSA.
Compile only soundcore support into your kernel, and then compile the latest version of ALSA seperately, from the directions for your card. Find it in the soundcard matrix at the ALSA webpage.

--Rounan
 
Old 03-02-2004, 11:34 PM   #3
nrunge
Member
 
Registered: Oct 2003
Distribution: Debian Woody (2.4.22)
Posts: 182

Original Poster
Rep: Reputation: 30
Thanks Ill give that a try.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Soundcard Driver for ALi M5451 Soundcard (Trident Module) xianzai Linux - Hardware 3 12-15-2006 01:00 PM
soundcard Problem mahednranit Linux - Hardware 16 06-23-2005 02:01 PM
Problem with Soundcard-Worked good with Redhat.Problem with Mandrake invinciblemk Linux - Newbie 1 02-27-2004 06:02 AM
SoundCard Problem TeenGangsta2003 Linux - Hardware 3 04-09-2003 09:39 AM
Soundcard problem! yenonn Linux - Hardware 1 04-04-2003 08:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 01:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration