LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 03-26-2010, 01:28 PM   #1
Nusky
LQ Newbie
 
Registered: Mar 2010
Posts: 5

Rep: Reputation: 0
Soundblaster XFi


Hi I'm using OpenSUSE 11.2 and am having problems with getting sound. The card is a Soundblaster XFi Xtreme Audio. YaST2 finds the card by name in the sound config. The card works perfectly fine on winblows XP. I've tried make under SU on their nix driver but got this error

Code:
make -C /lib/modules/2.6.31.5-0.1-desktop/build M=/home/andrew/XFiDrv
make[1]: Entering directory `/usr/src/linux-2.6.31.5-0.1-obj/x86_64/desktop'
make -C ../../../linux-2.6.31.5-0.1 O=/usr/src/linux-2.6.31.5-0.1-obj/x86_64/desktop/.
  CC [M]  /home/andrew/XFiDrv/xfi.o
/home/andrew/XFiDrv/xfi.c:14:26: error: sound/driver.h: No such file or directory
/home/andrew/XFiDrv/xfi.c: In function ‘ct_card_probe’:
/home/andrew/XFiDrv/xfi.c:55: error: implicit declaration of function ‘snd_card_new’
/home/andrew/XFiDrv/xfi.c:55: warning: assignment makes pointer from integer without a cast
make[4]: *** [/home/andrew/XFiDrv/xfi.o] Error 1
make[3]: *** [_module_/home/andrew/XFiDrv] Error 2
make[2]: *** [sub-make] Error 2
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.31.5-0.1-obj/x86_64/desktop'
make: *** [all] Error 2
 
Old 03-26-2010, 03:48 PM   #2
verdeboy2k
Member
 
Registered: Jan 2004
Location: /dev/random
Distribution: Gentoo amd64, CrunchBang amd64
Posts: 350

Rep: Reputation: 32
Do you have the kernel headers installed? Because it sounds like that is what you are missing. I don't know what the package is called under SUSE, but it is usually linux-headers-<version> or some such.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SB XFi Beta Driver installation failure BobNutfield Linux - Software 1 11-15-2008 04:58 AM
problem with xfi driver ditsikts Ubuntu 11 04-30-2008 12:40 PM
Business card Unstable install, Soundblaster Xfi not working Zaskar Debian 3 01-29-2008 09:12 AM
Xfi; how to downgrade gcc in debian? dexternl Linux - Hardware 5 11-29-2007 04:37 PM
Installing XFi drivers rrandrews Linux - Newbie 1 10-02-2007 08:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 05:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration