LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   sound went dead (https://www.linuxquestions.org/questions/linux-hardware-18/sound-went-dead-597104/)

southsibling 11-04-2007 03:46 PM

sound went dead
 
I have just, this very morning, somehow, managed to (selectively) disable part of my sound system on my Mandrake 10.1 OS. I do not know why. I did nothing. I touched nothing. I changed nothing. I spilled nothing. Here is what I do know:

I access my music cache with Kaffeine. I have done so for two years. It worked fine, until a coupla hours ago.

The log-in splash screen has stopped its' distinctive audio introduction.

If I put an audio CD in the CD player, it defaults to KsCD, and works perfectly. I hear sound.

Youtube no longer has sound.

I did nothing to cause this to occur:

I did not download anything audio related today.
Sound is fine on my Windows boot (on this same computer). Also, as I said, KsCD produces audio.
I did not pull out any wires from my computer.
I do not smoke.
I had a normal breakfast this morning (coffee, pancakes, etc.)
I did not push any buttons that said something like, "You are now about to disable an entire audio system that has worked perfectly for you for two years!"
I did not think any bad thoughts about my computer, that may have caused it to strike back at me.

Can someone please tell me what arcane, deeply hidden, here-to-for unknown, buried deep in the bowels, obscure file has all of a sudden decided it would, on its' own, with no incitement, change something, and render my sound system virtually dead?

P.S. I have been through all of the choices on the 'Configure Your Desktop/Sound' protocol on my GUI desktop.

poet_imp 11-04-2007 04:36 PM

I am not savvy with mandrake but have experienced similar problems on Fedora and Kubuntu. The problem has almost always been solved by opening the mixer and adjusting volumes or state. The mixer can ge gotten to, usually, by typing "alsamixer" or, for me, opening the volume control and getting to the GUI mixer.

In particular look at "External Amplifier" and mak sure it is turned on. Look at PCM and make sure it is also lit and tuned up.

Another hack I have found is that if I open mplayer and rais the volume there, It will fix things too.

southsibling 11-04-2007 07:17 PM

Move along folks...nothing more to see here!
 
Poet_Imp:

It's almost disconcerting sometimes, how you just sorta stumble on the right solution. I mean, there oughta be some logic to this. Well, maybe there is some.

I went back to the configurations: 'Multimedia/Sound/KMix'. Dunno why. Somehow, your suggestions led me there; think it might have been the obscure descriptions you offered, and 'KMix' seemed to fit in. Anyway, in the middle of the little GUI screen was a vertical control bar with its' control at the bottom and the indicator dimmed. Didn't have a name, just a symbol that was sort of a squiggle. Just for the heck of it, I pushed that control bar up a little, and bingo!, I had volume again.

Thanks for weighing in with your thoughts. As I type this, Enya is calming my mood and creating a nice atmosphere.

How'd that little control get shut off? I'll probably never know, although I'd love to. :scratch:


All times are GMT -5. The time now is 04:36 PM.