LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Sound was working, fails after NVidia install (https://www.linuxquestions.org/questions/linux-hardware-18/sound-was-working-fails-after-nvidia-install-162015/)

brianj774 03-24-2004 07:55 PM

Sound was working, fails after NVidia install
 
Hello.

I just installed Mandrake 10.0 Community.

Absoultely no problems, until I realized that I was only using the 2D nvidia driver, instead of the 3D one. I then dowloaded the newest driver, installed it, had it build my new kernel modules, and reconfigured XF86Config-4.

Upon reboot, the new drivers came in and worked fine, even the 3D stuff, but I got a message saying that /dev/dsp had failed to start.

I don't understand what happened, except that somehow the new nvidia modules must be interfering with my sound somehow

Kernel 2.6.3-4mdk
Relevant lspci info:
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)
01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 440] (rev a3)

Thanks

salparadise 03-25-2004 03:32 AM

apologies if this is a stupid question...
but
is this symptom occuring consistently?

my audio fails after nvidia install but is ok after second reboot
and my audio fails on first boot after coming out of windows but is fine on second reboot

brianj774 03-25-2004 02:14 PM

My sound has completely failed. I've even tried to utilize alternative sound drivers, and though they eliminate the error message, I still have no sound.

Other things have gone wrong with my nvidia driver install, X no longer has screens to boot into, though if I switch back to the 'nv' driver instead of the 'nvidia' one, X boots up, but still no sound. I haven't got a clue what kind of modelines it thinks it needs. Perhaps there's a better way?

I can get X to boot up with the 'nvidia' driver, but I have to use XF86Config to create a new one, and then the performance it really poor, and, of course, still no sound.

I'd like to just get the nvidia drivers working, in my old config file, and get my sound back...Is there any info I can give to anyone to help this? I don't know what else might be needed.

The mobo is a ASUS p4sdx, with a p4 celeron 2.3GHz, if that helps any.

:mad: brian :scratch:


All times are GMT -5. The time now is 10:41 PM.