-   Linux - Hardware (
-   -   sound: stuttering & pausing (

tek1024 09-26-2004 11:05 AM

sound: stuttering & pausing
[Fedora Core 2 i386 on an Abit KV8-Pro w/ Athlon64 3200+: sound chip -- RealTek/VIA AC'97, running ALSA]

1. When I run any KDE program, the sounds associated with it (now I've shut them all off, which is fine, but doesn't fix the underlying problem) are played in the following way. Let's take the KDE error message sound. It's a sound bite that's normally ~1.5s long. When the KDE sound server plays it, it stutters about thirty or fifty times in rapid succession, each time playing a clip of what is probably 100 or 200ms long, until it finally stops. Even playing large Vorbis or MP3 files acts the same way. This problem does not exist--in this sense--in XMMS, but it's the only media player I've seen that isn't affected. The odd thing is, both XMMS and the KDE sound server are apparently using ALSA.

2. Is there a way to increase the priority of the sound system (i.e., the ALSA drivers)? When I'm playing any sound file that's not a CD in XMMS, and I load a web page, scroll a page, type something quickly (like this post), or open a new window, it stutters and either replays some milliseconds (10-30 or so) or just skips that part of the file. This seems to be correlated with video--I can be compiling a new kernel, CPU maxxed out, and it won't happen, but let me scroll a webpage and oop!--there it goes.

Any ideas? Is this related to how many modules I have running? How can I cut back on these? (I didn't have the problem number (1) until recently, and I'm not sure what I did to cause it.) Thanks for your time.

If it's relevant, the output of lsmod:


Module                  Size  Used by
udf                    79429  0
8139too                22465  0
mii                    3777  1 8139too
snd_seq                56720  0
snd_pcm_oss            48420  0
snd_mixer_oss          17280  2 snd_pcm_oss
snd_via82xx            26784  5
snd_pcm                87816  3 snd_pcm_oss,snd_via82xx
snd_timer              28548  2 snd_seq,snd_pcm
snd_ac97_codec        59268  1 snd_via82xx
snd_page_alloc        10500  2 snd_via82xx,snd_pcm
gameport                4033  1 snd_via82xx
snd_mpu401_uart        9216  1 snd_via82xx
snd_rawmidi            24992  1 snd_mpu401_uart
snd_seq_device          8328  2 snd_seq,snd_rawmidi
snd                    48868  17 snd_seq,snd_pcm_oss,snd_mixer_oss,snd_via82xx,snd_pcm,snd_timer,snd_ac97_codec,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore              7713  2 snd
tdfx                  39477  2
w83627hf              22341  0
eeprom                  6217  0
i2c_sensor              2369  2 w83627hf,eeprom
i2c_isa                1985  0
i2c_voodoo3            4037  0
i2c_algo_bit            7497  1 i2c_voodoo3
i2c_core              17345  5 w83627hf,eeprom,i2c_sensor,i2c_isa,i2c_algo_bit
parport_pc            21249  1
lp                      9133  0
parport                35977  2 parport_pc,lp
autofs4                20677  0
floppy                54001  0
sg                    28513  0
dm_mod                47317  0
uhci_hcd              28505  0
ehci_hcd              27973  0
button                  4825  0
battery                7117  0
asus_acpi              9177  0
ac                      3533  0
ext3                  96937  2
jbd                    66521  1 ext3
sata_via                4805  0
libata                29637  1 sata_via
sd_mod                17473  0
scsi_mod              105360  3 sg,libata,sd_mod

vectordrake 09-26-2004 03:05 PM

Have you already tried increasing the priority of the sound system through the KDE Control Center? Your problem is likely an aRTs thing. You can either check the box that tells the system to give sound a higher priority or try selecting a larvger sound buffer to see if it helps. I had a similar "video-related" glitch, but it was a hard lock, caused by a voltage spike in the CPU wiring. I had to solve it by soldering a capacitor between two of the CPU slot contacts. The point is that scrolling a web page is actually CPU intensive, as your actually doing a continuous repaint of the screen space taken up by the web page.

tek1024 09-26-2004 03:32 PM

I did increase the sound priority in KControl. It's running "with the highest priority possible" (realtime/checked), with buffer "as large as possible." My options in the Control Panel are as follows (aRTS doesn't show up, I don't know if it should or not):
Threaded Open Sound System (never heard of it) ?

ALSA is selected.

Now, about soldering a capacitor ... well, heh, I tried manually overclocking my old Athlon 1700+ by looking at hardware diagrams and etching the chip and doing all sorts of other highly risky mods ... I got it back to where it worked, and that's about it. Crazy.

vectordrake 09-26-2004 03:58 PM

My board was unusable without the solder, so it was not really a risk, in that sense, I guess.

Does the sound repeat over a few times? I had that problem with OSS/ESD, which is why I never used the system sounds in Gnome, although I like the sounds.

As far as unloading modules, I don't know which you'd try for. There seems to be a logical dependancy from top to bottom, so to speak. _One thing I noticed with my SB Live! setup is that it doesn't use snd and soundcore. I wonder if you're having an alsa/oss conflict...

tek1024 09-26-2004 07:26 PM

Well, I guess it was a problem with conflicting (?) drivers or modules, but I just did a kernel recompile with the latest version (today, 2.6.9-rc2-bk12) and it runs flawlessly with ALSA and its constituents compiled as modules. So that narrows it down almost not at all, but at least I know the hardware's ok. Thanks for your suggestions and help!

vectordrake 09-26-2004 08:27 PM

Help? You're being generous! lol. Seriously, though, I bet if you had to compare the .config for each kernel, there'd be one small difference somewhere, and who know where that is? It could be something entirely different from sound. I missed something once that prevented me from using the bootsplash (which is why I was recompiling that time). I don't have to worry about that right now, as the -ck kernel doesn't support bootsplash. :(

All times are GMT -5. The time now is 09:08 PM.