LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 05-02-2005, 06:17 PM   #1
Mokkan
LQ Newbie
 
Registered: Jan 2005
Distribution: Slackware
Posts: 4

Rep: Reputation: 0
Sound Problem: Midi not working


Well, I've had this problem since I installed linux... for some reason, I can't play midi files. When I try to play them in KMid, I get an error that says "Could not open /dev/sequencer". When I looked, /dev/sequencer doesn't even exist... I've tried recompiling the kernel and recompiling alsa, and even switched my sound card out (was using intel integrated AC97, now using Soundblaster Live... emu10k1). So I'm out of ideas now :\... does anybody know how to fix this problem?

EDIT: Slackware 10.1, by the way.
EDIT2: And linux kernel is 2.6.11.7...

Last edited by Mokkan; 05-02-2005 at 06:22 PM.
 
Old 05-03-2005, 07:47 AM   #2
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,518

Rep: Reputation: 99
modprobe snd-seq-midi
is what u need.
 
Old 05-03-2005, 11:56 AM   #3
Mokkan
LQ Newbie
 
Registered: Jan 2005
Distribution: Slackware
Posts: 4

Original Poster
Rep: Reputation: 0
I ran that command, and the error stopped coming up... but the midi still doesn't work .
 
Old 05-04-2005, 08:31 AM   #4
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,518

Rep: Reputation: 99
If you want to play midi sounds with your soundcard (not with external midi synth), use timidity.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA MIDI: Sound fonts for NVIDIA/NForce Soundstorm on-board sound vharishankar Linux - Hardware 6 09-04-2007 01:37 PM
midi sound problem! akihandyman Mandriva 2 05-13-2005 05:29 PM
Sound working but not MIDI cragwolf Slackware 4 09-13-2004 04:04 PM
MIDI problem no sound l32 Linux - Hardware 2 07-21-2004 06:36 PM
Midi not working, possibly output device problem Druaga Linux - General 1 11-25-2003 03:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 11:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration