-   Linux - Hardware (
-   -   Sound Problem after switching to redhat 8 (

mmr_85 12-04-2002 09:26 PM

Sound Problem after switching to redhat 8
I switched from Mandrake 9 to Redhat 8, and in Mandrake 9, my soundcard used to work perfectly with the ALSA support in mandrake. When I run Redhat, it shows that I do have a FM801 but, it DOESN'T play a sound, I press the play test sound, nothing comes up. I load a Music CD and it plays, but I dont hear anything. I boot and get back to windows, and it does works, I dont know what might be happening, because it used to work in Mandrake with ALSA support, and Redhat has it too, I suppose and I think I read somewhere during the installation. So why my soundcard doesnt play in Redhat 8?

When the computer loads the environment, I get an error message saying that it cant load the /dev/dsp something similar, I dont remember very acurately, Im in windows right now. And when the computer is shutted down, it says something about a module sound-service, which cant be loaded, I cant read it, since it runs to fast. Sorry for not being too accurate in my description, but Ill check, and post it accurately.

Please help me, Im new into this, so dont try to give me hard to follow solutions, that I might not be able to do, since I'm new in this.

Thanks in advance.

neo77777 12-04-2002 10:29 PM

list the permissions on /dev/dsp*
ls -l /dev/dsp*
if it shows up like

crw------  root root yada yada /dev/dsp0
crw------  root root yada yada /dev/dspN

then change perms as root

chmod 666 /dev/dsp* /dev/audio* /dev/mixer*
P.S. Sorry, I should've expected it the above is done in Xterm/Konsole/Other terminal emulation software, to become root issue /bin/su and type root password when prompted with Password:, you won't see anything when you type it.

mmr_85 12-05-2002 07:59 AM

Im gonna try when I reinstall redhat, because I moved to mandrake, since Im gonna test a new modem I will buy today, when I return to redhat, Im gonna try it.

Here are the messages redhat displays
When It enters to Redhat environment, a message appears saying:


Sound Server Initialization message:
Error while initializating the sound driver:
device /dev/dsp cant be opened (No such device)
The sound server will continue, using the null output service.
When redhat exits to shutdown it syas something very quick, but Im unable to see accurately what it says, it is very quick:


mob prob cant locate module sound slot 0
Someting simililar, but Im not quite sure since it goes to fast.


mmr_85 12-05-2002 07:32 PM

when I run ls -l /dev/dsp*, I get other stuff diferent, it connects to 3 things, not 2, and they are not similar to this ones.

mmr_85 12-06-2002 05:53 PM

Im following this:

I dont have a clue what Im I doing wrong.

This is what I get after typing ls -l /dev/dsp*:

[root@localhost root]# ls -l /dev/dsp*
crw------- 1 root root 14, 3 ago 31 05:31 /dev/dsp
crw------- 1 root root 14, 19 ago 31 05:31 /dev/dsp1
crw------- 1 root root 55, 0 ago 31 05:31 /dev/dsp56k

I would really like to keep redhat, i like it, pleae help me

rwhitworth 12-07-2002 04:14 AM

I've got this same problem on a Sony Viao laptop with MagicMedia 256AV sound card.


Originally posted by neo77777
[B]list the permissions on /dev/dsp*
ls -l /dev/dsp*
if it shows up like

crw------  root root yada yada /dev/dsp0
crw------  root root yada yada /dev/dspN

Yes - that's what I get.


then change perms as root

chmod 666 /dev/dsp* /dev/audio* /dev/mixer*

Okay. And rechecking the permissions they have changed.

But even after this I can't open the volume control. I get:

"Error (gnome-volume-control) - I was not able to open your audio device. Please check that you have permission to open /dev/mixer and make sure you have sound support compiled into your kernel."

Also, the error message on shut-down is still there.

And next time I start up, the permissions have gone back to how they were!

What's going on here?

mmr_85 12-07-2002 10:21 AM

I dont have a clue, It makes me mad, because it worked on mandrake, but I prefer redhat, but ti dislikes my soundcard or something.

chrisharkness 12-07-2002 03:38 PM

we ought to make a little club for people with silent redhat 8s, cos i have the same problem!

mmr_85 12-08-2002 09:55 AM

Have you people tried with another linux distribution? Lke mandrake? Because I have both, but on Mandrake it does works.

mmr_85 12-08-2002 07:44 PM

I solved the problem!

First I installed the kernel pack and the development pack from the packages thing. Then I went to the page of the alsa project, and downloaded the files, and followed the instructions provided in there. If someone needs help, because of the same problem. Contact me at

Goodluck to all of you.

rwhitworth 12-09-2002 06:45 AM

I solved my problem too! Once I had worked out how to find and install "sndconfig" - which gets left out of the default Red Hat installation - it detected my card without any problem and fixed everything.

billbeq 12-09-2002 10:15 AM

Soundcard not working with Redhat Ver. 8.0
I tried using sndconfig and it was not installed with the default RD install packages. How do you install sndconfig?
Thanks, Bill

mmr_85 12-09-2002 10:52 AM

It is an rpm in one cd, I think it is #3, go to redhat/rpms and search for sndconfigblabla.rpm But I dont think its gonna make something, I isntalled it, detected my soundcard, but it told me that the soundcard was not detected, but the ALSA has been developing some drivers, so I went to the page of the alsa, and Isntalled it with the isntructions provided for my soundcard.

good luck

billbeq 12-09-2002 02:06 PM

Thanks! sndconfig did the trick and some packages
I solved the problem of having no sound by:

1. I added all the packages for kernels and everything else my computer showed as not yet being installed after I entered Gnome Menu -System settings - packages

2. I then relogged in as "root".

3. Then I opened my terminal from Gnome Menu -System Tools - Terminal
and entered "whereis sndconfig".

4. Once I saw the directory path to the file I copied and pasted it and ran it!
The first soundcard I had was a PCI - Vortex and sndconfig said it was not supported by Redhat even though it was recognized. So I plugged in another card which was a ISAPNP - AWE64 Sound Blaster card and restarted the computer which installed it for me and removed the old sound card settings on startup.

5. Then I went into sndconfig, as mentioned above, and it recognized and installed all the settings for the AWE64 card. It runs great now! :)

All the advice here in this thread put me on the right path. Thank you! Now if I can just get my CD-R to burn but that is another story :)

mmr_85 12-09-2002 06:17 PM

cool, now it works for you, well it is easy to replace the soundcard, but I installed all as the alsa saud, but I installed the kernel sources and the development packages, and follow all what the alsa page said about my soundcard.

All times are GMT -5. The time now is 01:09 AM.