-   Linux - Hardware (
-   -   Sound on the DELL Sound Blaster live (emu10k1X) (

ben_ch 05-29-2004 05:50 AM

Sound on the DELL Sound Blaster live (emu10k1X)
I've just installed gentoo linux (2.6.5 kernel) on my Dell. Everything is working but the sound. At first I used the emu10k1 driver from the kernel which wouldn't work at all. Then I found out that DELL modifies the SoundBlaster, so they don't work with Linux (they're getting a complaint as soon as their phone lines open :cool: )

I basically gave up until this morning, when I saw that alsa1.0.5 is out. I downloaded the ALSA driver and installed it. I unmuted my channels and

$ aplay file.wav
worked. What doesn't work though, is everything else (for example mpg123 file.mp3 returns 'can't open /dev/dsp)

I would be very greatful if someone could help me get this to work!

My stuff:


$ cat /etc/modules.d/alsa
# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore
##  ALSA portion
alias snd-card-0 snd-emu10k1x
## alias snd-card-1 snd-ens1371
##  OSS/Free portion
##alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1

alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

options snd cards_limit=1

I don't know if this is relevant, or if it's even good to have it in here,
but suggested it, so:[*] /proc file system support[*] /dev file system support (OBSOLETE) [*]  Automatically mount at boot   
[ ]  Debug devfs          [*] /dev/pts Extended Attributes 
[ ]  /dev/pts Security Labels

and the sound:
<M> Advanced Linux Sound Architecture
<M> Sequencer support
 < >  Sequencer dummy client 
 <M> OSS Mixer API
<M> OSS PCM (digital audio) API[*] OSS Sequencer API
<M> RTC Timer support [*] Verbose printk [*] Debug  [*]  Debug memory  [*]  Debug detection

$ lsmod
Module                  Size  Used by
snd_emu10k1x          11688  0
snd_pcm                97800  1 snd_emu10k1x
snd_timer              25220  1 snd_pcm
snd_ac97_codec        72708  1 snd_emu10k1x
snd                    55620  4 snd_emu10k1x,snd_pcm,snd_timer,snd_ac97_codec
soundcore              7648  1 snd
snd_page_alloc          9860  2 snd_emu10k1x,snd_pcm
e100                  29056  0

If you need any other information, please just ask!

ben_ch 05-29-2004 10:09 AM

OK, now after a restart it magically started to partially work ... and the quality is awful!
-> JuK is awful quality
-> xmms gives an error on oss-output-plugin, and no error (but also no sound) on the alsa-output-plugin
-> mpg123 gives an error /dev/dsp not found (but no error like that in kde startup)
-> kde sounds (like "are you sure"-alerts) also awful quality (lots of static and so)

what's wrong?

ben_ch 05-30-2004 04:55 AM

OK, I got it to work. I downloaded the new ALSA-driver, ALSA-oss and ALSA-lib (1.0.5) and installed them. Now it works fine!

Nubbin49 06-29-2004 09:43 PM

Need install help
Hey, I just downloaded the new stuff your talking about but I'm a complete nebie and don't know how to install this thing. I extracted the files and tried running some of the scripts as well as make and make install nothing worked. . . Be gentle, I said I was a nebie ;)


LavaDevil94 06-29-2004 09:49 PM

Nubbin: Exactly what are you trying to install? Can you give us some specific details?

ben_ch: Congrats, I don't think anyone else has gotten it to work with ALSA before (only proprietary drivers)! Because of that, you should post your findings on the official page for those drivers (emu10k1). They could use that info. The address is here:

Nubbin49 06-29-2004 10:23 PM

alsa-oss, I'm trying to do what ben_ch did. . . .I downloaded alsa-oss and extracted the tar but I can't get past that. . . I guess I gotta export KERNELPATH=bla bla && export so on then make and make install but I'm not sure, could someone help me out? alsa did not give any install instructions on the site or with the tarball.


LavaDevil94 06-29-2004 10:55 PM

You should compile the driver packages in this order (the ./configure, make, and make install):
Note that alsa-oss comes last, it's probably the problem. Try doing it in order from top to bottom.

All times are GMT -5. The time now is 04:28 PM.