-   Linux - Hardware (
-   -   Sound not working in GNOME but sound card test works (

saravkrish 07-01-2005 02:42 AM

Sound not working in GNOME but sound card test works

I'm using FC3 and sound was working fine for a loooong time. Since the last week or two, there is no sound and the gnome volume control doesn't work. If I run the "Soundcard detection tool", I can hear the test sound it plays. I don't know what I changed, but it no longer works anymore.

The only important things I can think of that I did in the past 2 weeks:
1. Installed software updates released by fedora, dag and freshrpms using Synaptic and up2date.
2. Was running 2 X-servers using gdm, changed it back to one.

I'm not saying those two could have caused the problem, but may be it could give you a hint.

Thanks in advance for the help.


bignewf 07-03-2005 01:19 AM

I had a similar problem in Fedora 3 after running the updates from yum. I updated the kernel and several programs no longer ran, including sound. Try reinstalling these files as root
from Disk 1 of the install CD:

run lsmod to make sure the soundcard drivers are loaded.
reboot to the original kernel
as root, run the following command: /usr/sbin/alsactl power [card#] [state] where card# is the soundcard number and state is on/off
in my machine I used /usr/sbin/alsactl power 0 on

my sound returned immediately after running this command
If still no sound, uninstall and re-install the sound apps, i.w mixer, CD and audio player.

;) ;)

NightGod 02-08-2006 06:49 AM

Hi! Same problem here.

After doing some updates, i still have sound, but gnome-volume-control can't detect any sound device. I can control volume in alsamixer, but ONLY in alsamixer.

After running the command: /usr/sbin/alsactl power 0 on, i'm now able to control volume in apps such as xmms, but gnome-volume-control is still not detecting any device, so no volume control. Annoying thing...

Thanks in advance.

rickh 02-08-2006 12:03 PM

Not sure if Fedora uses the same modutils structure or not, but I had a similar problem with Debian a while back. Turned out that mine was caused by a modutils.conf file created by one of the update packages I had installed. With Debian that file (modutils.conf) is no longer used. It uses the modprobe.d directory instead.

Of course I did have to configure the driver referred to in the (created) modutils.conf in modprobe.d

All times are GMT -5. The time now is 06:04 PM.