LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 11-29-2007, 06:04 AM   #1
utkarshrawat
Member
 
Registered: Jul 2007
Posts: 120

Rep: Reputation: 15
sound not coming


hye to all
I am not able to figure out my system sound .After booting my system ,system sound is coming but when iam increasing or decreasing the volume from volume control ,sound stops.
In real player same thing happens .sound is coming but if iam increasing or decreaasing the volume sound stops totally but player keep on playing the song.
when i tried to install alsadriver-lib.It came like
Code:
Making install in simple
make[3]: Entering directory `/home/My_experiment/alsa driver/alsa-lib-1.0.15/modules/mixer/simple'
if /bin/sh ../../../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../../../include -I../../../include   -g -O2 -W -Wall -g -O2 -MT sbase.lo -MD -MP -MF ".deps/sbase.Tpo" -c -o sbase.lo sbase.c; \
        then mv -f ".deps/sbase.Tpo" ".deps/sbase.Plo"; else rm -f ".deps/sbase.Tpo"; exit 1; fi
 gcc -DHAVE_CONFIG_H -I. -I. -I../../../include -I../../../include -g -O2 -W -Wall -g -O2 -MT sbase.lo -MD -MP -MF .deps/sbase.Tpo -c sbase.c  -fPIC -DPIC -o .libs/sbase.o
/bin/sh ../../../libtool --tag=CC --mode=link gcc -g -O2 -W -Wall -g -O2   -o smixer-sbase.la -rpath /usr/lib/alsa-lib/smixer -module -avoid-version sbase.lo ../../../src/libasound.la 
rm -fr  .libs/smixer-sbase.so
gcc -shared  .libs/sbase.o  -Wl,--rpath -Wl,/home/My_experiment/alsa -Wl,--rpath -Wl,driver/alsa-lib-1.0.15/src/.libs ../../../src/.libs/libasound.so  -Wl,-soname -Wl,smixer-sbase.so -o .libs/smixer-sbase.so
creating smixer-sbase.la
/bin/sed: can't read driver/alsa-lib-1.0.15/src/libasound.la: No such file or directory
libtool: link: `driver/alsa-lib-1.0.15/src/libasound.la' is not a valid libtool archive
make[3]: *** [smixer-sbase.la] Error 1
make[3]: Leaving directory `/home/My_experiment/alsa driver/alsa-lib-1.0.15/modules/mixer/simple'
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory `/home/My_experiment/alsa driver/alsa-lib-1.0.15/modules/mixer'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/home/My_experiment/alsa driver/alsa-lib-1.0.15/modules'
make: *** [install-recursive] Error 1
SECONDLY when i gave this command ->lspci
Code:
00:00.0 Host bridge: Intel Corporation 82946GZ/PL/GL Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82946GZ/PL/GL PCI Express Root Port (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82946GZ/GL Integrated Graphics Controller (rev 02)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) Serial ATA Storage Controller IDE (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
04:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5786 Gigabit Ethernet PCI Express (rev 02)
3: lsmod|grep snd

snd_hda_intel 21589 1
snd_hda_codec 144321 1 snd_hda_intel
snd_seq_dummy 7877 0
snd_seq_oss 32705 0
snd_seq_midi_event 11073 1 snd_seq_oss
snd_seq 49841 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 11853 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 42849 0
snd_mixer_oss 19137 1 snd_pcm_oss
snd_pcm 72005 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_timer 25029 2 snd_seq,snd_pcm
snd 52037 11 snd_hda_intel,snd_hda_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd _timer
soundcore 13217 1 snd
snd_page_alloc 13769 2 snd_hda_intel,snd_pcm

4:apropos alsa

aconnect (1) - ALSA sequencer connection manager
alsactl (1) - advanced controls for ALSA soundcard driver
alsa-lib-devel (rpm) - Static libraries and header files from the ALSA library.
alsa-lib (rpm) - The Advanced Linux Sound Architecture (ALSA) library.
alsamixer (1) - soundcard mixer for ALSA soundcard driver, with ncurses interface
alsa-utils (rpm) - Advanced Linux Sound Architecture (ALSA) utilities
amidi (1) - read from and write to ALSA RawMIDI ports
amixer (1) - command-line mixer for ALSA soundcard driver
aplay (1) - command-line sound recorder and player for ALSA soundcard driver
arecord [aplay] (1) - command-line sound recorder and player for ALSA soundcard driver
aseqdump (1) - show the events received at an ALSA sequencer port
aseqnet (1) - ALSA sequencer connectors over network
speaker-test (1) - command-line speaker test tone generator for ALSA
 
Old 11-30-2007, 04:28 PM   #2
Larry Webb
LQ Veteran
 
Registered: Jul 2006
Location: Crystal Beach, Texas
Distribution: Suse for mail +
Posts: 5,100
Blog Entries: 7

Rep: Reputation: 229Reputation: 229Reputation: 229
It appears ALSA may have a conflict. Which distro are you using and what package manager? Have you already installed your w32codecs or vidiolan player?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound coming from my sound blaster audigy 2 ZS platinum sound card msab Linux - Hardware 9 12-05-2010 05:10 AM
sound coming but sound contols not working ratnesh1 Linux - Hardware 3 05-05-2006 03:43 PM
help cracking/boiling soup sound coming from sound card mbman Linux - Hardware 2 01-20-2006 08:31 AM
sound not coming curious_srk Linux - Software 4 01-07-2005 10:23 AM
No sound coming from it Octan Linux - Hardware 1 12-17-2004 05:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 07:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration