-   Linux - Hardware (
-   -   sound modprobe errors: slackware 10.1 (

mttatkns 02-08-2005 03:36 AM

sound modprobe errors: slackware 10.1
I have integrated sound on the motherboard of my Dell Dimension 4500. It's i810 so it should be using that module, with the ac97 codec/driver Sound worked in Slackware 10, Red Hat 9, but after installing 10.1 (and repartitioning since I have a new hard drive), the sound does not work. When I run an app like XMMS and open a streaming media file or an MP3, etc, it shows it playing but I do not hear the sound. /sbin/lsmod shows:

ac97_codec 11924 0
snd-pcm-oss 36704 1
snd-mixer-oss 12152 0 [snd-pcm-oss]
appletalk 19972 12 (autoclean)
parport_pc 15044 0 (autoclean)
parport 22824 0 (autoclean) [parport_pc]
printer 7648 0
i810_rng 2528 0 (unused)
snd-intel8x0 18080 2
snd-ac97-codec 52472 0 [snd-intel8x0]
snd-pcm 54504 0 [snd-pcm-oss snd-intel8x0 snd-ac97-codec]
snd-timer 13412 0 [snd-pcm]
snd 31268 1 [snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-ac97-codec snd-pcm snd-timer]
soundcore 3396 4 [snd]
snd-page-alloc 4712 0 [snd-mixer-oss snd-intel8x0 snd-pcm snd-timer snd]
uhci 24284 0 (unused)
ehci-hcd 17516 0 (unused)
usbcore 58860 1 [printer uhci ehci-hcd]
8139too 13928 1
mii 2272 0 [8139too]
crc32 2880 0 [8139too]
pcmcia_core 39172 0
ntfs 51232 1 (autoclean)
ide-scsi 9392 0
agpgart 45092 0 (unused)

modprobe i810_audio returns:

/lib/modules/2.4.29/kernel/drivers/sound/i810_audio.o: init_module: No such device
/lib/modules/2.4.29/kernel/drivers/sound/i810_audio.o: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.29/kernel/drivers/sound/i810_audio.o: insmod /lib/modules/2.4.29/kernel/drivers/sound/i810_audio.o failed
/lib/modules/2.4.29/kernel/drivers/sound/i810_audio.o: insmod i810_audio failed

I'm wondering if this could possibly be referring to /dev/pcm, as I was previously able to get sound to work (in Slackware 10) by using /dev/pcm as the output device and chmoding it so all users could use sound. 10.1 doesn't come with /dev/pcm, and ./MAKEDEV says it doesn't know how to make the device.

If anyone could point me in the right direction, I would greatly appreciate it!

nucleo 02-08-2005 11:12 AM

try to use alsa driver.

run at prompt "alsaconf"

# alsaconf

urka58 02-08-2005 05:29 PM

From your lsmod output I can't see any module called i810_audio, so I think the error message you get when you try loading such module is normal.
The modules for your i810 integrated soundcard seem are correctly loaded.
May be you forgot running alsamixer first ???
Hope this helps

mttatkns 02-08-2005 09:58 PM

I already ran alsamixer, and then saved the settings using alsactl store. But I hadn't thought to try alsaconf.. when I run it, it says that no supported PnP or PCI card is found. However, I know that the sound is supported as it previously worked...

mttatkns 02-09-2005 12:36 AM

Another thing... among other lines, lspci returns
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB (ICH4) AC'97 Audio Controller (rev 01)

All times are GMT -5. The time now is 02:36 PM.