-   Linux - Hardware (
-   -   sound in debian sarge (intel i810 integrated) not working with alsa (

sea turtle 12-30-2004 08:33 PM

sound in debian sarge (intel i810 integrated) not working with alsa
Hey folks,

Recently installed Debian Sarge (testing version) and have been working on getting everything setup. Most everything is working except for sound, gah!

I have an Intel i810 Integrated Graphics chip (this is a notebook) and have upgraded to the 2.6.8 kernal from the 2.4 one that came with sarge. I didn't attempt to get sound working until after upgrading. I'm using Gnome as well.

What I've done so far is the following. Installed alsa-utils and used the alsaconf app to try and set things up. It detected my sound chip and said that it had set it up, but no dice. I made sure to go into alsamixer and unmute/raise the volume on everything. Rebooted several times as well.

Someone told me it might be OSS messing around and told me to add skip i810_audio to /etc/discover.conf but that also didn't work.

There are no error messages anywhere, and various programs that play sounds are acting like they are playing sounds. For example, I played an mp3 using the music player in gnome and it was displaying visualization that looked like it went along with the music that should have been playing.

I also read after searching here to add some stuff (snd_i8x0 something) to my blacklist file, and when I did that it seemed like the situation got even worse. I got error messages saying there was no /dev/dsp or something to that effect trying to play sounds. I redid alsaconf and the same problem as above with programs acting like they were playing sounds reappeared but when I rebooted, again the same /dev/dsp errors.

I'm at the ends of my wits trying to figure out how to get sound to work. Do I need to go back to OSS somehow? Sound never worked in the 2.4 kernal nor did it work before I did anything with ALSA. If I need to use OSS, how would I go about doing that?


sea turtle <3

sea turtle 12-30-2004 11:15 PM

Anyone have any ideas? :(

Should I maybe try a different distro? Reinstall this one from scratch (oh the days of windows) maybe?

I'm all for dropping Windows from my repetoire completely but I ain't about to live without my music.

dimgr 12-30-2004 11:26 PM

shoulb be easier if you would just go with debian Sid

try kanotix.
it blows knoppix away and works fine on my dell laptop with integrated sound

neonsignal 10-19-2006 09:48 PM

I encountered the same 'no volume' problem on a Toshiba Portege 3480ct with the i810 chip (worked fine with OSS, not with ALSA). It didn't matter whether the OSS compatible interface was enabled or not.

Running 'alsaconf' as superuser fixed the volume issue (I'm not sure why).

farslayer 10-20-2006 12:13 AM

I would suggest re-installing using Debian Etch netinstall iso..
2.6.17 kernel from the start, MUCH better hardware detection and support.
I would bet your sound problem is resolved.

Grab the latest build and give it a go..

All times are GMT -5. The time now is 05:16 PM.