-   Linux - Hardware (
-   -   Sound Hudson Azalia Toshiba L770 (

donnied 08-20-2011 09:42 AM

Sound Hudson Azalia Toshiba L770

I just got a Toshiba L770 and am trying to get sound in Debian working.
lspci identifies:
00:14.2 Audio device: Advanced Micro Devices [AMD] Hudson Azalia Controller (rev 01)

I've tried compiling and using the most recent alsa drivers with no success. (I am currently testing various configure options).

There are a few similar threads with similar hardware and I've tried a few - using rmmod and modprobe. Previously with the default alsa drivers I received the error message "driver in use" now I see that no sound cards are loaded.

modprobe snd_hda_intel tells me

FATAL: Error inserting snd_hda_intel (/lib/modules/2.6.32-5-amd64/kernel/sound/pci/hda/snd-hda-intel.ko): Unknown symbol in module, or unknown parameter (see dmesg)
When I look at the dmesg output I see:

[ 1047.782441] snd_hda_codec: disagrees about version of symbol snd_jack_report
[ 1047.782444] snd_hda_codec: Unknown symbol snd_jack_report
[ 1047.782844] snd_hda_codec: Unknown symbol __snd_printk
[ 1047.782924] snd_hda_codec: Unknown symbol compat_skip_spaces
[ 1047.783034] snd_hda_codec: disagrees about version of symbol snd_jack_new
[ 1047.783035] snd_hda_codec: Unknown symbol snd_jack_new

What might I try / do?

markush 08-21-2011 05:11 AM

Please post the output of

lsmod | grep snd

All times are GMT -5. The time now is 02:35 PM.