Latest LQ Deal: Latest LQ Deals
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 10-01-2003, 07:11 PM   #1
LQ Newbie
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 1

Rep: Reputation: 0
Sound Glitchy in MDK 9.1

Newbie Using Mandrake 9.1:

When I log into mandrake 9 I got this message in a popup:

"Sound Server Message:
Can't set real-time scheduling priority.
You need to run artswrapper as root or setuid root. This means that you will lickly not be able to produce acceptable sounds (ie without clicks and breaks) "

And the message is exactly right.. my sounds works fine when I am playing mp3s, but when I am in games (Zsnes and TuxRacer) the sound is slighty off and 'clicky'

When I log into root and attempt to run "artswrapper" I get this error:
>> running as realtime process now (priority 50)
Error while initializing the sound driver:
device /dev/dsp can't be opened (Device or resource busy)

Anyone have any clue what I need to do? What is artswrapper? I guessing I need sound drivers... but my sound it built into my motherboard which I have no idea what it is. Any advice would be great.
Old 10-01-2003, 08:03 PM   #2
Registered: Feb 2003
Location: San Antonio
Distribution: Suse 9.0 Professional
Posts: 843

Rep: Reputation: 30
Hmmm, that is weird. Starting it a second time might be why it states that /dev/dsp is busy, the artserver running as the regular user (weird) already has the device busy. I shut the aRTs sounderver off, and went back to OSS Driver with xmms. I have no problem with any app except k3b to play songs before burning (it only works with arts server). I didn't like the flaky operation of arts. Under Redhat, Preferences-->Sound-->Sound Server, there is an option that I unselected that 'start the arts sounderver on KDE start'. You might try that. That option is somewhere in configDrake, Preferences, somewhere.


P.S. If you needed the sound drivers, you wouldn't hear anything. The drivers are fine, the sound server is not behaving.
Old 10-01-2003, 09:04 PM   #3
LQ Addict
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
You need to run artswrapper as root or setuid root
do the latter. open a terminal window, become root and then do
chmod +s /usr/bin/artswrapper

Log out and log in again. You should stop getting that message.

Last edited by quatsch; 10-01-2003 at 09:05 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel 82815 [i815] acting glitchy Seiken Linux - Hardware 1 03-31-2005 08:20 PM
USB drive mounting glitchy Borg Swarm Linux - Hardware 0 05-29-2004 07:01 AM
Video Issue - Glitchy. v8n3t Linux - Hardware 3 04-05-2004 02:28 PM
ut2k4 and ut2k3 mouse glitchy exodist Linux - Software 0 03-26-2004 11:09 PM
glitchy/slow annimation in game zexter Linux - Software 2 11-01-2003 06:18 PM > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:05 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration