-   Linux - Hardware (
-   -   Sound dead after running VMWare (

amdinator 08-27-2006 10:14 PM

Sound dead after running VMWare
Hi, I have a very odd problem. I have a computer running Debian Etch with everything up-to-date and a 2.6.15-1-k7 kernel. I have a Chaintech AV-710 (VIA Envy based) sound card configured under Alsa. I'm using VMWare Server 1.0. Here's the order in which I did things:
  1. Added a sound device, /dev/dsp, to a Windows XP x64 VMWare image.
  2. Killed artsd to avoid "vmware failed to open sound device" error
  3. booted XP-64, installed VMWare audio driver, sound was choppy.
  4. Restarted sound server and listened to some music, worked fine.
  5. added the following to the corresponding .vmx VMWare config file in an attempt to fix choppiness:
    sound.maxLength = "256"
    sound.smallBlockSize = "256"
  6. killed artsd and closed amaroK which was just paused during previous vmware boot
  7. booted virtual machine, sound did not work in virtual machine.
  8. shut down xp-64, restarted sound server, sound does not work in Linux
  9. ran "alsactl restore"
  10. rebooted machine to no avail
  11. booted down, removed card, booted w/o card, shut off, re-inserted card.

My sound still does not work after trying the above. I see no error messages and things continue normally. AmaroK acts like it's playing but nothing comes out. No other sounds work. The red SPDIF light that is only on when the card is active is lit. Volume is normal, and I've tried different headphones as well as different jacks.

Any ideas? How did I manage to kill the sound that way? :scratch:

bigrigdriver 08-29-2006 11:58 AM

Run AlsaMixerGUI from the Multimedia -> Volume control menu. If the speaker symbols over the Master slide bar don't have parenthesis around them, the speakers are Muted. Click once on the speaker symbols to unmute.

amdinator 08-30-2006 08:01 PM

Nope, that's not it. Everything that needs to be unmuted is, and I even restored my mixer settings w/ alsactl restore. I guess I'm going to have to throw out all my sound stuff and put everything back, which shouldn't be too hard the second time around now that I have a working backed-up config file. If that doesn't work... expect more in this thread. :p

All times are GMT -5. The time now is 07:06 AM.