-   Linux - Hardware (
-   -   Sound Configuration (

kwigibo 07-13-2002 10:24 PM

Sound Configuration
Hi, Ive read some of the post already on sound cinfiguration and had no luck.

Im using redhat7.2, and Im also using the onboard sound card. This is what lspci prints out about my sound card.

00:07.5 Multimedia audio controller: VIA Technologies, Inc. AC97 Audio Controller (rev 21)

sndconfig, freezes after it tells me it is going to play sounds to test if the sound card has been configured properly. Ive tried "sndconfig --noautoconfig" to do it manually but that doesn't work either.

This is what is in my modules.conf file

alias parport_lowlevel parport_pc
alias sound-slot-0 via82cxxx_audio

post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
alias usb-controller usb-uhci

Im not too sure as what too do. Any help would be greatly appreciated.


pbharris 07-14-2002 09:02 PM

grab off the drivers from VIA they are over there with the docs! ->

go git 'em!!

aredshaw 07-16-2002 02:04 PM

Give this a try
Have you tried using sndconfig under a root login in a term session. I found that my card was not automatically detected in RedHat, but when I used sndconfig and followed the steps I could locate my card and make it work. I am running RedHat 7.3 and in sndconfig it includes a VIA 82CXXX PCI Audio. I don't know if that driver will work, but you can give it a try. It even has a couple of sound tests at the end.

kwigibo 07-17-2002 02:05 AM

sndconfig won't work, it freezes when it says it will now play a sound to test if it has been configured. Ive tried using sndconfig in several different situations. sndconfig just won't work

mrGee 07-17-2002 04:38 PM

i had this once; another card tho.
sndconfig itself was corrupted, the
awesfx was missing, so maybe
rpm -e sndconfig
rpm -e awesfx
and reinstalling it leads to something

bigjohn 07-19-2002 03:50 PM

Yo kwigibo,

I too am having snags with an AC 97 though if I look it up in windows device manager, it is identified as an "Advance" AC97, and somewhere between there and my mandrake 8.2 dual boot it gets a mention as an intel i810 series 82801 BA/BAM AC97.

I cannot make it link to any of the audio cd applications, I see the i810 module loading up at boot, in fact bugger all seems to work (I can mount data disc's), when I was digging this arvo, I pushed the start button on the front of the drive by mistake thinking that I was ejecting the disc and I nearly fell off my chair when music filled the air. But as I said, I still can't do anything with the app's i.e. noatun, xmms, kscd, etc etc.

This probably isn't much help, but as It's only taken me about 5 weeks to discover that the bloody button on the drive works, it makes me feel less of a total pillock that I did before and at least I can now get music while I meddle!!!!!!!!!!1

all the best


All times are GMT -5. The time now is 04:41 AM.