LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 05-28-2006, 04:26 PM   #1
orfiyus
Member
 
Registered: May 2006
Posts: 42

Rep: Reputation: 15
Sound Card doesn't work with FC5


Hi
I am new to linux and I am having a problem getting my soundcard to work. I am running Fedora Core 5. My soundcard is a Creative Labs SoundBlaster X-Fi ExtremeMusic. My problem is that the card is being detected but when I try to play the test sound there is no actual sound coming out of my speakers(they are on and plugged and everything). Can someone please help me out with suggestions on how to get the card to work properly?

Thanks.

Here is the contents of my scsoundcard.log

------- System Config Soundcard --------
Sun May 28 12:14:46 EDT 2006

------- lspci --------
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller
(rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev
a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev
a3)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller
(rev f3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller
(rev f3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
01:00.0 VGA compatible controller: ATI Technologies Inc R480 [Radeon
X850XT (PCIE)] (Primary)
01:00.1 Display controller: ATI Technologies Inc R480 [Radeon X850XT
(PCIE)] (Secondary)
05:06.0 Multimedia audio controller: Creative Labs Unknown device 0005
05:0b.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A
IEEE-1394a-2000 Controller (PHY/Link)

------- lsmod --------
Module Size Used by
radeon 100321 0
drm 68181 1 radeon
ppdev 12741 0
autofs4 22981 1
hidp 24001 2
rfcomm 42709 0
l2cap 31681 10 hidp,rfcomm
bluetooth 52901 3 hidp,rfcomm,l2cap
sunrpc 140925 1
ip_conntrack_netbios_ns 6977 0
ipt_REJECT 9536 1
xt_state 6209 2
ip_conntrack 54040 2 ip_conntrack_netbios_ns,xt_state
nfnetlink 10457 1 ip_conntrack
xt_tcpudp 7233 4
iptable_filter 7105 1
ip_tables 16389 1 iptable_filter
x_tables 16965 4 ipt_REJECT,xt_state,xt_tcpudp,ip_tables
video 18885 0
button 10577 0
battery 13253 0
ac 8901 0
ipv6 246433 14
lp 16265 0
parport_pc 29413 1
parport 38281 3 ppdev,lp,parport_pc
floppy 61829 0
nvram 12617 0
ohci1394 35845 0
ieee1394 292761 1 ohci1394
ehci_hcd 33229 0
ohci_hcd 23901 0
sg 36317 0
i2c_nforce2 10689 0
i2c_core 24897 1 i2c_nforce2
forcedeth 26693 0
dm_snapshot 20205 0
dm_zero 6209 0
dm_mirror 24081 0
dm_mod 54745 6 dm_snapshot,dm_zero,dm_mirror
ext3 121929 2
jbd 57173 1 ext3
sata_nv 13253 2
libata 58321 1 sata_nv
sd_mod 20545 3
scsi_mod 129641 3 sg,libata,sd_mod

------- /etc/modprobe.conf --------
alias eth0 forcedeth
alias scsi_hostadapter sata_nv

------- /etc/asound.conf --------
#Generated by system-config-soundcard, do not edit by hand
#SWCONF
#DEV 0
defaults.pcm.card 0
defaults.pcm.device 0
defaults.ctl.card 0

------- aplay -l --------
aplay: device_list:222: no soundcards found...

------- amixer --------


------- /proc/asound/version --------


------- rpm -q alsa-lib --------
alsa-lib-1.0.11-3.rc2.2

------- rpm -q alsa-utils --------
alsa-utils-1.0.11-3.rc2

------- /proc/asound/modules --------


------- /proc/asound/pcm --------


------- system-config-soundcard --------

Wrong card index 0...
/usr/share/system-config-soundcard/soundcard.py:217: GtkWarning:
gtk_label_set_label: assertion `str != NULL' failed
self.module_label2 = gtk.Label(_(self.module))
/usr/share/system-config-soundcard/soundcard.py:273:
DeprecationWarning: use gtk.ComboBox
self.primarySubDeviceOptionMenu = gtk.OptionMenu()
/usr/share/system-config-soundcard/soundcard.py:308:
GtkDeprecationWarning: gtk.timeout_add is deprecated, use gobject.timeout_add instead
self.timer = gtk.timeout_add (100, self.checkStatus, self)
/usr/share/system-config-soundcard/soundcard.py:548:
GtkDeprecationWarning: gtk.TRUE is deprecated, use True instead
gtk.main()
ALSA lib pcm_hw.c:1305_snd_pcm_hw_open) Invalid value for card
aplay: main:547: audio open error: No such device
NOTE:(This error repeats at least 200 hundred times)

Read config:
card 0
device 0
HW 0
----------- Kudzu -------------
Desc: Creative Labs Unknown device 0005
Driver: None
Device: None

----------- **** -------------

End of scsoundcard.log contents
 
Old 05-29-2006, 11:37 AM   #2
whk
Member
 
Registered: Jun 2005
Posts: 202

Rep: Reputation: 37
soundcard driver

So far there is no driver for this soundcard from ALSA (here).
Most Hardware is first designed for Windows. And maybe later a driver is written for Linux.
Also I don't see a driver from OSS (proprietary)here
 
Old 05-29-2006, 06:41 PM   #3
orfiyus
Member
 
Registered: May 2006
Posts: 42

Original Poster
Rep: Reputation: 15
Thanks for the response whk. I guess I ll just wait for them to release a driver for my soundcard.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with HDA-intel sound card FC5 tuxtoti Fedora 5 05-23-2006 01:25 AM
Sound card not working anymore on FC5 jialin Fedora 3 04-29-2006 07:08 PM
Wireless card doesn't work after rebooting FC5 lancherider Linux - Wireless Networking 3 04-18-2006 06:05 AM
FC5 cannot get WG511 card to work Jer1234 Linux - Wireless Networking 7 04-09-2006 03:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 04:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration