LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 02-17-2005, 01:23 AM   #1
Kobra_Stryke
LQ Newbie
 
Registered: May 2003
Location: Shillong
Distribution: fedora Core 3
Posts: 7

Rep: Reputation: 0
Sound Blaster Live! DE 5.1 and MIDI


I have an athlon xp 2200+ on a MSI K7N2gM-L mobo with 512 MB DDR 400 RAM. I use the onboard GeForce4 MX Gfx but i have disabled the Onboard Audio. The BIOS version is 1.6. I run Fedora Core 3. mp3's and other non midi files play fine. But the MIDI ports are really in a mess. Thats because i've downloaded the latest alsa 1.0.8 packages and compiled them. After that i added a few lines to my modprobe.conf file to enable MIDI support. I can play midi at the console by mc'ing and pressing enter on a midi file. In X, kmid can play my External MIDI keyboard properly. It can also see the SB Live! Synths (4 of them to be precise) and i can even set them to be the default output device for MIDI. Problem is i can't hear anything when i do that. I have the snd-pcm-oss and snd-seq-oss modules loaded and only then does the MIDI ports get recognised. If i don't then the command aconnect -o produces a sequencer detection failure.

I have also tried Mandrake 10.1 and the MIDI works fine in all MIDI capable applications. I have actually managed to record a few trax in rosegarden using my external keyboard.

In addition ... both in Mandrake and Fedora the mixer sliders are extremely confusing to set up. The slider names and their functions do not seem to tally at all.

Does somebody have the solution or a good link to a howto that will ease my woes.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound Blaster Live (CT4830) or Sound Blaster Live 24 bit un shiza Linux - Hardware 0 08-29-2005 04:57 PM
ALSA not working for Creative Sound Blaster Live 24 Bit sound card vishalsonu Linux - Hardware 7 08-20-2005 01:02 PM
Sound Blaster Live scottie Linux - Newbie 6 10-31-2003 04:58 AM
Sound blaster Live config with onboard sound card HChan Linux - Hardware 1 04-30-2003 01:47 AM
sound blaster Live carmojos Linux - General 3 11-22-2002 09:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 07:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration