-   Linux - Hardware (
-   -   Sound: Alsa driver compilation (

Blek 05-18-2003 11:48 AM

Sound: Alsa driver compilation
During compilation of alsa-driver-0.9.3a, i get the following error:

/sbin/depmod -a 2.4.20-8
depmod: *** Unresolved symbols in /lib/modules/2.4.20-8/kernel/sound/acore/snd.o

Then when i try modprobe snd-emu10k1

/lib/modules/2.4.20-8/kernel/sound/acore/snd.o: unresolved symbol schedule_work
/lib/modules/2.4.20-8/kernel/sound/acore/snd.o: insmod /lib/modules/2.4.20-8/kernel/sound/acore/snd.o failed
/lib/modules/2.4.20-8/kernel/sound/acore/snd.o: insmod snd-emu10k1 failed

does anyone know what i should do to solve this?

Blek 05-18-2003 12:16 PM

I have been reading through the INSTALL file that came with the alsa-driver-0.9.3a sourcecode. One of the first things it says is the following:

1) You must have full configured source for the Linux kernel which you want to use for the ALSA drivers. Note that ALSA drivers are part of the kernel, so there is necessary to resolve all symbol dependencies between the used kernel and ALSA driver code. Partly installed kernels (for example from distributor makers) can be unuseable for this action.

Perhaps this is the problem then... Althoug this might explain what is going on, I am not much of an expert on these things, so if anyone knows what to do ...

Blek 05-18-2003 03:28 PM

Upgraded to kernel version 2.4.20-13.9: still the same errors :(
I did find this however:
(so i am not the only one with this problem)
and this:
(their cvs-log seems to indicate that they are working on it (?))

Blek 05-18-2003 04:07 PM

So I tried it with alsa-driver-0.9.0rc6 and that worked

Thank you all for your help (or at least attention) :D

All times are GMT -5. The time now is 10:54 PM.