-   Linux - Hardware (
-   -   Sony VAIO SZ no sound (

CamelofCamelot 09-19-2006 01:05 AM

Sony VAIO SZ no sound
The sound on my VAIO SZ lappy doesn't work. I found that on Sony VAIO laptops, the sound doesn't work unless you install the patch found at

So I did this:
$ tar -jxvf ./alsa-driver-1.0.12.tar.bz2
$ cd ./alsa-driver-1.0.12

Now, it should work, because the forum in the link above talks about 1.0.11rc3, but I'll tell you right now that make gives me an error:

make[2]: *** [io.o] Error 1
make[2]: Leaving directory `/home/nick/alsa-driver-1.0.12/pci/emu10k1'
make[1]: *** [_modsubdir_emu10k1] Error 2
make[1]: Leaving directory `/home/nick/alsa-driver-1.0.12/pci'
make: *** [compile] Error 1

So I apply the patch.

$ patch -p0 < ~/vaio-stac7661-test3.diff
patching file alsa-kernel/pci/hda/patch_sigmatel.c
Hunk #1 succeeded at 1726 with fuzz 1 (offset 578 lines).
Hunk #2 FAILED at 1904.
1 out of 2 hunks FAILED -- saving rejects to file alsa-kernel/pci/hda/patch_sigmatel.c.rej

So yeah. What should I do?

GrueMaster 09-19-2006 12:41 PM

First, there are two patches in the forum that you link to; stac7661.patch which is against the kernel, and vaio-stac7661-test3.diff which is against alsa 1.0.11rc3. If you downloaded alsa 1.0.12 (driver, lib, utils), then you shouldn't need any of these patches. To resolve the build issue, use "./configure --with-cards=hda-intel", as this will disable building unneeded drivers (saves time and space). The build issue you had is in the Creative Labs Audigy driver, which I'd assume you don't need.

After building and installing the above 3 packages in order, you will probably need to add "options snd-hda-intel model=vaio" in /etc/modprobe.d, according to the last post of the thread.

CamelofCamelot 09-19-2006 05:00 PM

So I was able to make and make install alsa-drivers 1.0.12 this time, and then ran ./snd-devices as directed in the INSTALL file in the alsa-drivers directory, and then ran alsa-conf, also as directed, and then did modprobe snd-hda-intel, and then xmms'd a song, and still got no sound.

So I installed alsa-lib 1.0.12, and it seems to have installed ok, but then I tried to install alsa-utils, and it gives me this error:

checking for libasound headers version >= 1.0.12... not present.
configure: error: Sufficiently new version of libasound not found.

But, assuming that this is talking about alsa-libs, I just friggin' installed that.

CamelofCamelot 09-19-2006 05:08 PM

It works, just needed a reboot and another try at unmuting in alsamixer. Thanks!

GrueMaster 09-19-2006 08:13 PM

Glad to hear that it works now. If you run into any issues, let me know.

All times are GMT -5. The time now is 12:43 AM.