-   Linux - Hardware (
-   -   Sony Memory Stick Duo (

redroach 09-15-2004 12:52 PM

Sony Memory Stick Duo
hello everybody,

i searched here already but nothing could help me out. so here's my question:
i got a new Sony Ericsson P900 today. it comes with a 32MB Sony Memory Stick Duo and a corresponding adapter to fit into cardreader devices.

so, i put my memory stick duo in that adapter and plugged it into my card reader and tried to mount it.
the message was: /dev/sda1 is not a valid block-oriented device.
i tried different devices (sda2 and sdb1 etc...) and various filesystems (vfat, ntfs...) but nothing could get the memstick to work.
the same cardreader works just fine for e.g. Compact Flash in linux and the method described above worked out-of-the-box in W*ndow$...

so, at that point, i'm stuck as i am not very familiar with hardware issues...
can somebody help me to get the memory stick duo to work? (btw: my system is Fedora Core 1, Kernel 2.4)

redroach 10-14-2004 06:50 AM

so, i got suse 9.1 now... but the problem still exists :(

i got a hint from a friend, saying that i should re-compile the kernel where i should activate the "SCSI Probe Multiple LUNS" switch.
i saw this working with linux, but isnt there any other way?:confused: :rolleyes:

All times are GMT -5. The time now is 01:48 AM.