-   Linux - Hardware (
-   -   Something is wrong with my GPU, Radeon X700 (

LexMK 12-19-2012 01:59 PM

Something is wrong with my GPU, Radeon X700
I tried to install Debian on a computer I had. During the starting process, it gives me the following error:

do_IRQ: 0.147 No irq handler for vector (irq -1)

Repeated several rimes. The OS starts regularly after a while, but the computer keeps "beeping", it lags and locks up after a while. If I change the GPU with a different one, everything works fine and this error isn't there.

I used Debian Netinst. amd64 and then dist-upgraded to testing repos. I'm currently running the 3.6-trunk kernel from Debian Exp. repos, but with the same results of both the default one (2.6.x) and the testing repos one (3.2.x).

Computer specs:

CPU: Pentium D dual-core 3.0Ghz 64bit
Ram: 1Gb DDR2 + 4Gb swap
MB: ASrock 775Dual-VSTA

Shadow_7 12-19-2012 02:46 PM

# apt-get install firmware-linux-nonfree

I have no idea if that's what you need. But it's probably worth a try.

I'm running sid and had to install ati's version of a driver. In a non distro specific way because it fails to make a package for Sid. And it's the 12.6 version because my video card has officially been deprecated. Plus a few other first install woes (first time in a while anyway).

You could always try the vesa driver and see if that's good enough. But then again I never boot to a gui, and always use startx to get there from here. Specifically because of video driver "potential" issues. It's just easier for me, to have one extra step each boot, than to have many extra steps beyond addressing the issue, when there is a driver problem.

LexMK 12-20-2012 01:25 AM

Tried that but nothing happened. Any other possible solution?

DiskChris 12-21-2012 08:39 AM

If the computer is beeping on startup, that sounds like a BIOS beep, which is in it of itself, a sign of hardware problems. If it beeps before Linux even starts then you have more than a driver problem.

EDDY1 12-21-2012 10:49 AM

Can you install 64-bit OS on 32-bit computer?


This ASRock Motherboard can take up to 2.0 GB ram, with a fixed amount of 0 MB (removable) installed PC2100/2700/3200 DDR SDRAM DIMMs or PC2-4200/5300 DDR2 SDRAM DIMMs, Supports Dual Channel DDR..

LexMK 12-25-2012 04:42 AM

Beeping starts after the bios ended, and it can enter setup without problems, so the problem is somehow related to Linux.

Motherboard is 64bit compatible

and so is processor.

Still have no clue on what caused it.

H_TeXMeX_H 12-25-2012 05:23 AM

Can you describe the beeping ? Does it occur at regular intervals ? How many beeps ? How often ? etc.

LexMK 12-25-2012 03:05 PM

The same beep the computer does when you are in CLI, try to delete something but there's nothing to delete. That beep.

It does it every 10-15 seconds, and some rows of the error in my first post displays. Like, I'm writing something (Using a CLI, without starting X) and it does:

user@computer:~$ writing somdo_IRQ: 0.147 No irq handler for vector (irq -1)
do_IRQ: 0.147 No irq handler for vector (irq -1)
do_IRQ: 0.147 No irq handler for vector (irq -1)
do_IRQ: 0.147 No irq handler for vector (irq -1)
do_IRQ: 0.147 No irq handler for vector (irq -1)
do_IRQ: 0.147 No irq handler for vector (irq -1)

and beeps.

It keeps doing this until it completely locks and nothing you can do can unlock it, so you have to shut down pushing the power button. It's related to this particular model of GPU (Radeon X700). I tried other GPUs of the same model and the same error happened, so it's not broken. Other GPUs of different models works as they should.

H_TeXMeX_H 12-26-2012 04:07 AM

I think it is hardware failure and the beeps are from the mobo. It has an AMI BIOS so:

It is strange that it only happens with certain graphics cards.

cascade9 12-26-2012 05:06 AM

ASrock 775Dual-VSTA....known for odd problems with PCIe video cards. Not that suprising, it was a very weird motherboard (PCIe + AGP) with a VIA chipset. The problems with that chipset/board were bad enough that asrock actually has a 'Supported PCI Express VGA Card List for PCI Express Graphics Slot' list-

LexMK 12-26-2012 02:45 PM

Changing the motherboard solved the problem. At first I thought that updating the BIOS would solve the problem, but it seems it wasn't enough. VIA chipsets are as bad as I heard, but never experienced directly. Now I know.

All times are GMT -5. The time now is 01:49 AM.