-   Linux - Hardware (
-   -   some X apps hang system on startup w/ nouveau, geforce 7800 AGP (

Electrode 10-19-2010 12:25 AM

some X apps hang system on startup w/ nouveau, geforce 7800 AGP
For quite some time, I've been having stability issues with one of my machines, which I have narrowed down to the video card - or more specifically, its driver.

Brief specs:
Mobo: Tyan S2885
CPUs: 2x Opteron 290
GFX: GeForce 7800 GS AGP

When using the nvidia binary driver, I get dozens of machine check events in dmesg, and the rig will often spontaneously freeze or panic. Switching workspaces will sometimes crash the machine as well.

The nouveau driver is better in some ways, worse in others: no MCEs or random hangs, however some programs will cause the system to freeze upon creating their window; usually just before the window itself is drawn. I haven't yet figured out what exactly provokes this.

These work fine:
* fluxbox
* xterm
* xcalc
* graphicsmagick display
* glxgears (gallium3d works perfectly)
* mplayer (-vo xv, windowed and fullscreen)

These crash the machine:
* kcalc
* links -g (X is the only enabled GUI, it's not trying to grab the framebuffer or anything like that)
* virtualbox-ose
* seamonkey (x86 binary)
* baudline (amd64 binary)

The nv driver works and is stable, but is sorely lacking in terms of 2D acceleration.

Anyone run into anything similar? Any ideas?

RockDoctor 10-19-2010 11:38 AM

It may depend on the versions of the driver, kernel module, and Xorg. The nv driver has never worked for me, nouveau on Fedora now works well (Ubuntu now sort of works), and the nvidia driver has pretty much always worked for me. This with GeForce 9100 onboard graphics.

Electrode 10-19-2010 01:24 PM

Currently using kernel with nouveau modules built in, xorg-server 1.9.0 and nouveau X driver from 8-19 built from gentoo ebuilds.

RockDoctor 10-19-2010 05:29 PM

I'm pretty much running the same thing:


Guess I'm not being very helpful

All times are GMT -5. The time now is 10:18 AM.