-   Linux - Hardware (
-   -   Some devices don't work - sorry but do I really have to switch back to Win XP (

valter 12-27-2004 01:44 PM

Some devices don't work - sorry but do I really have to switch back to Win XP

Few weeks ago I left the Win XP behind and tried to come to the free world - linux (fedora core 3). It was very hard in the beginning - did feel like I had left all working stuff behind. After a wile I got all critical and needed stuff to work thanks to RPM packages and Synaptic packages manager and I started to love Linux.
But seems like some of my devices won't work under Linux and I don't have such skills to make them fork and the Great Google couldn't help me ether:

1: Canon M360 (printer/scanner) just doesn't work. I tried also turboprint - still printer didn't answer and from scanner I may only have a dreams (SANE doesn't support MP360). I think it is the last time I buy Canon products - they don't understand that windows isn't only OS.

2: I cant make Sony Digital 8 camcorder and Linux to interact each other throw Firewire - I tried Kino and it said: raw1394 kernel module not loaded or failure to read/write /dev/raw1394. I don't even have such directory but I did install libraw1394 0.10.1-3 and all others that Kino needs. I also noticed that the IEEE-1394 raw1394.ko driver situates in /lib/modules/2.6.9-1.681_FC3/kernel/drivers/ieee1394 folder but if I set this to Kino's preferences it's still says: raw1394 kernel module not loaded or failure to read/write /dev/raw1394. :confused:

Maybe someone wise knows solution to those problems or I have to go back to windows platform even if I don't like it :( - Linux is so promising

Please help if you can
Valter Kungla

Brain Drop 12-27-2004 10:33 PM

For the module, try typing lsmod and see if you see the firewire module listed. if not you can load it by typing modprobe followed by the module name.

I can't help you with the printer, you said you googled it so... but sometimes if you look at the drivers that other canon printers use and try them you might get lucky.

valter 12-28-2004 01:29 AM

it is there:

[we@localhost ~]$ /sbin/lsmod
Module Size Used by
video1394 18957 0
raw1394 36909 0


kpex 12-28-2004 01:46 AM

The /dev/raw1394 device is created by running "make dev" from the source tree of libraw1394. Since you have installed an rpm and don't have the source (and whoever created your rpm did not include a correct installation script) you can use these commands to create /dev/raw1394: (taken from the libraw1394 makefile)


/bin/mknod -m 600 /dev/raw1394 c 171 0
/bin/chown root.root /dev/raw1394
echo "/dev/raw1394 created"
echo "It is owned by root with permissions 600.  You may want to fix"
echo "the group/permission to something appropriate for you."
echo "Note however that anyone who can open raw1394 can access all"
echo "devices on all connected 1394 buses unrestricted, including"
echo "harddisks and other probably sensitive devices."

valter 12-28-2004 02:50 AM

:) Thats it - thanks kpex, you fixed it. I may say that Kino captures videos from camera widh more better quality than Windows Moviemaker does and doesn't only create MS wmv files. I believe that somehow, someday I get my printer/scanner work too (I start truing other Canon drivers). Thanks again.

Linux had made me feel like I was released from prison - I still cant believe that so much can be free and clean and so many things can be done.

OzOle 06-28-2005 10:27 PM

Canon MP360
Hi all,

Isn't it just amazing that a large corporation like Canon do NOT provide Linux drivers for their products? They obviously haven't woken up to the fact that more and more businesses as well as individuals are switching from MS to Linux. I'm running SuSE Linux 9.1 on my desktop PC. It works beautifully but sadly no printer driver available.

I have searched high and low to find a Linux driver for the Canon MP360 but not much success.
I did find a driver which will support some functions on the MP360 that was at:
HOWEVER, they want 29.95 Euro ~ US$37 for their driver!!!

They encourage you to download and install the driver free for private individuals but guess what:
they include their 1.5 inch high colour logo and slogan at the foot of the page right across the page. They also stiffle the functionality of the driver so that the result is not even as good as draft printing. So that is obviously NO SOLUTION.

If anyone finds a driver for the Canon MP360 that works they I would love to hear about it.

Greetings from Down-Under,


All times are GMT -5. The time now is 08:24 AM.