LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   SOLVED: No hdmi sound to TV on Asus M3A78-EM computer (http://www.linuxquestions.org/questions/showthread.php?t=4175451803)

Fox7777 02-26-2013 01:45 PM

SOLVED: No hdmi sound to TV on Asus M3A78-EM computer
 
While my onboard Radeon HD 3000-3300 series hdmi on my Asus M3A78-EM computer sends great video to the TV, I haven't yet got sound on the TV. As a lot of people move to Bodhi Linux, I am trying to find easy graphical solutions that work for them. A solution is needed.

More detail:
~$ lspci -v
01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS780 [Radeon HD 3200] (prog-if 00 [VGA controller])
Subsystem: ASUSTeK Computer Inc. Device 82f1
Flags: bus master, fast devsel, latency 0, IRQ 18
Memory at d0000000 (32-bit, prefetchable) [size=256M]
I/O ports at d000 [size=256]
Memory at fbdf0000 (32-bit, non-prefetchable) [size=64K]
Memory at fbc00000 (32-bit, non-prefetchable) [size=1M]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: radeon
Kernel modules: radeon

01:05.1 Audio device: Advanced Micro Devices [AMD] nee ATI RS780 HDMI Audio [Radeon HD 3000-3300 Series]
Subsystem: ASUSTeK Computer Inc. Device 82f1
Flags: bus master, fast devsel, latency 0, IRQ 19
Memory at fbde8000 (32-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
Kernel modules: snd-hda-intel

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC1200 Analog [ALC1200 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC1200 Digital [ALC1200 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0


I am connected by hdmi cable to a UN22D5003BF Samsung LED TV
Audio specs are:
Audio

Audio: Dolby Digital Plus / Dolby Pulse
SRS Tru Sound HD
5 Watts x 2
Down Firing + Full Range Speaker Type

Could it be the TV is not understanding what Bodhi Linux is sending for sound or that the hdmi version on Bodhi is not up to the one on the TV? I searched for Dolby in Synaptic and added the Dolby related aften software. Also I have tried various tweaks to Start - Applications - Preferences - Pulse Audio Preferences and other sound software but no success yet in getting sound on the TV.

I have tried everything I can think of with no success and I have found no posts showing success. Hopefully all the work Ubuntu is doing will soon get us sound on the TV.

TobiSGD 02-26-2013 03:17 PM

Which version of Bodhi is this?
Are you using the proprietary AMD driver or the open source radeon driver?

Fox7777 02-26-2013 03:34 PM

No hdmi sound to TV on Asus M3A78-EM computer
 
This is Bodhi Linux 2.2.0 and no doubt the default open source driver since I have not seen any info how to install AMD's proprietary driver. If do have fglrx, AMD Catalyst Control Center, jockey-gtk, xserver-xorg-video-radeon installed and have tried everything I can think of. It looks like the Samsung TV is not getting what it needs for hdmi sound. I have tried this on Kubuntu 12.10, Kubuntu 13.04 beta 2, Mint 14, Mepis 11 and Puppy 5.4.1 with no success too.

Fox7777 02-27-2013 12:49 PM

No hdmi sound to TV on Asus M3A78-EM computer
 
I finally found a solution. Apparently gnome-control-center needs to be installed. If you go to Start - Settings - All - Preferences - Sound - Sound - Output and click on hdmi, sound goes to the TV, if you click on your onboard sound, sound goes to your computer speakers. I have hdmi sound to the TV now.


All times are GMT -5. The time now is 07:00 PM.