-   Linux - Hardware (
-   -   snd-hda-intel sound from multiple sources at once (

wingcom 03-02-2006 09:19 AM

snd-hda-intel sound from multiple sources at once

i am trying to run unreal tournament 2004 (preferably with sound ^^) while listening to some adrenaline pumpin music on my Mandrake 2006. However, when xmms is running and i start ut, i dont have sound in the game... I have an ASUS P5GD2 Premium motherboard with this:


00:1b.0 Class 0403: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
        Subsystem: ASUSTeK Computer Inc.: Unknown device 813d
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at cdcf4000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
        Capabilities: [70] #10 [0091]

driver loaded. I'm running this driver on this:


[root@VOYAGER wingcom]# uname -r

edit: error in console (from where the ut2004 command is issued):

open /dev/[sound/]dsp: Device or resource busy
kernel. I also don't seem to have a recorder available (microphone) when i start KMIX. Iv've run AlsaMixer and saved that setting but no joy. It seems that this driver somehow cuts back the functionality of the card. Does anyone have any suggestions what i can try next? My older laptop (windowsXP) can run ut and winamp happily together so i dont think this newer one should act differently.


wingcom 03-02-2006 10:28 AM

ive gotten a bit further (starting from related posts on this forum pushing me in the right direction)

I am using ALSA on 2.6 kernel. I now installed a ALSA output plugin for xmms which seems equally fine to the other output plugin so ok. Now my guess is ut2004 still uses OSS. Soooo i upgraded my Mandriva2006 with alsa-oss0 and aoss. When i start ut2004 using the aoss wrapper i get SOUND! yeey!

but... the sound is terrible, there is alot of noizzz. Still searching for better solution. meanwhile if anyone can help -> please do so ;)

wingcom 03-12-2006 07:39 AM

i still need help with this :s

- I installed newest openal from the openal website.
- I linked the UT openal lib to that one
- i made a .openalrc file in my homedir with the following content

(define speaker-num 2)
(define devices '(alsa))
(define alsa-out-device "hw:0,0")
(define alsa-in-device "hw:0,0")

i tried to change the device to arts, then i get a:

Signal: SIGSEGV [segmentation fault]

Crash information will be saved to your logfile.

i tried to change the device to esd, then it runs without sound. same error, device is busy + game is rather slow

pfff, is there anyone who can listen to MP3's in xmms or whatever player and play UT WITH SOUND together? (using linux of course) So that i know it is even possible???

There is something wrong with my digital playback/sound system i think. See post with Kscd problem. When i make kscd play the cd's through the digital playback it wont read the cd, says i have no permissions on /dev/cdrom which is a big fat lie! When i decide to playback through the cable to the sound card (only one cddrive has this) it works. It also works when i start that kscd as root :s

i think these problems are somehow connected. Prolly something stupid that i dont see

I also tried ripping the mp3's to .ogg and playing them with the ut player. This works, however, the songs get speeded up in UT. When i play the .ogg in xmms the tempo is normal. When played in UT its too fast.

tredegar 03-14-2006 03:25 AM

Please see this thread about making a .asoundrc file in your home directory:

Dive's post in that thread worked for me.


wingcom 03-14-2006 04:21 AM

First, I know this post seems double posted but i tried all posts on it for over a week now and dont get it working.

So yes, i followed that post but it didn't work for me. I tried several versions of that file I dont know what's in it now (i am at work) but i'll verify its content with Dive's post and check if every setting in there is still correct (with the knowledge i posses atm :s ) Could be that i tried to change this settings before i fixed some other problems like patches or openal stuff etc thereby messing with it so much that is not correct anymore.

Prolly some stupid mistake i need to correct. And of course i dont really get the dmix stuff. I read its supposed to queue the incoming sound requests but how do i tweak it to my needs :s, i dont even know if its enabled and how to check that.

I had hoped that a high-definition audio device would be able to mix it on a hardware level but nooooo :)

tredegar 03-14-2006 07:01 AM

My suggestion: Install the .asoundrc file as dive says.
Run alsaconf as root.
Logout, login again. Try sound and game.
It should work for you.

wingcom 03-14-2006 02:43 PM


Originally Posted by tredegar
My suggestion: Install the .asoundrc file as dive says.
Run alsaconf as root.
Logout, login again. Try sound and game.
It should work for you.

Damn, since you were so convinced i was beginning to believe it would really work this time :s Bumper it didn't :s

I changed my .asoundrc file to Dive's content, ran alsaconf as root, logged in and out of kde. Doesnt do the trick:


[wingcom@VOYAGER ~]$ ut2004
open /dev/[sound/]dsp: Device or resource busy

say, this line in that file:


do you need to define this "!default" somewhere? or does alsaconf do this for you? I hate it when things like this dont work. I refuse to give up.

tredegar 03-15-2006 11:06 AM

Sorry, I have no idea how the .asoundrc file works, you could try the alsa site here:

But perhaps it is time for some checking. Having done all the above, can you now hear two sound streams at a time? Eg play music and play (a different) game, or play a system sound at the same time as music? If so then the problem is (mostly) fixed, and you should concentrate on just what it is about the unreal game that is causing problems.


wingcom 03-16-2006 02:50 AM

good thinking...

I think I have heard kde sounds while i was listening to a xmms playlist and I successfully tested AlsaPlayer playing a CD while i was listening to a xmms playlist before. I should retest all these things cus some things might have changed by messing with to many different factors.

Bad thing is i cannot even test it now, i was beta-testing the rt2x00 driver yesterday and while i was collecting the dump info from my messages file to post it on the board and tried to save it as a file my OS said: cannot write to home dir, device is read-only oO I rebooted and everything was fucked. all my disks where 1.1gb and had 33% usage :s It gets even worse cus neither Mandriva Rescue nor NEW install/upgrade wouldn't work.

Stupid coincidence i think but it booted me back to the beginning. I was even thinking of switching that new box to windows (go figure :) ) untill everything was supported by *nix but its probably bad hardware this time and not the pinguin's fault so...

Thanx for your help so far tredegar, if i can revive my sick box i will test it asap.

cheers m8

tredegar 03-16-2006 01:51 PM

Oops! Things like this are not that unusual when you are starting out (2 steps forwards, and then one step back) - I had to re-install about three times in my first month, but I gradually learned from my mistakes, so better luck next time.

For what it is worth, I had too many bad experiences with Mandriva 2006 and ditched it, but 2005LE (after the urpmi updates) is working well, as is suse 10.0 (but I am so used to mandrake's way of doing things, that I am just playing with suse).


All times are GMT -5. The time now is 08:49 AM.