-   Linux - Hardware (
-   -   Small problems with SuSE 10: usb devices on boot, numlock, and volume control (

ELconkestador 12-14-2005 08:16 PM

Small problems with SuSE 10: usb devices on boot, numlock, and volume control
Hey everyone, I just switched to SuSE 10 from Fedora Core 2 a little while ago, and have been very happy with it. However there are some things that bother me about it. I have searched the internet and not found solutions to any of these problems thus far.

The biggest complaint that i have is that about every other boot my usb devices (MOUSE!a kensington usb mouse , usb disk fat32 usb disk, bluetooth adapter [microsft :-p]) don't get started until I unplug and re-plug them in, and even then it sometimes fails to work. It has done this since the install. It's qutie annoying to have to reach to the back of the computer and do this everytime it happens. The big issue here is the mouse, the others i dont really mind to much, and I have tried symlinking /dev/mouse to /dev/input/mouse0 or mice and that didn't help.

Antoher issue I have is the numlock. It gets turned off when the login screen comes up, which is annoying because i use many alpha-numeric passwords, and then it gets turned off agian after I log on. I have tried many proposed solutions to this including numlockx, and editing /etc/sysconfig/keyboard. None of them have worked. I know that this is a simple option in Yast for KDE, but I use Gnome and have heard its a bit more complicated.

The last issue I have had, and not found a solution to is volume control. It appears to be working fine, as it recognizes and is bound to the correct device and option for control, and I do have sound, but the volume control doesnt actually do anything. I move it all the way up, or to mute and it does nothing to change the volume. the volume control on xmms does however work, so this is not a huge issue.

I am using openSuSE 10 with Gnome, x11, 2.6 kernel, and almost every other standard SuSE install thing there is.

thanks, all your help is very much appreciated!

jsandro7 01-02-2006 08:35 AM


I have be using suse ever since 9.0 version and I have seen similar problem that you are describing in this forum. I have a solution for one of the problems which in the USB mouse problems. Well basicly there are two possible solution, you can either get a very cheap usb to ps/2 adapter that will resolve the issue one and for all or you can type in this command one your log in, yast &mouse
That will reload all the usb device and the mouse will start working just fine. If you are comtible writing shell scripts it mind be a good idead to write a script that excuteds the yast &mouse command by it self at log in.

Let me know if this helps, I be glad to help out as much as I can

Happy New Years,


All times are GMT -5. The time now is 12:10 PM.