-   Linux - Hardware (
-   -   Slow hdparm, memtest86-- hardware related? (

coldrecd 01-30-2007 12:08 PM

Slow hdparm, memtest86-- hardware related?
I'm trying to determine if my very slow data transfer performance is hardware or driver related.

The system is a Dell Dimension 8100:
1GB ram, Nvidea GEforce 2 MX 32MB.

I installed Ubuntu 6.06 from a DVD, which took ~48hrs. Many driver issues were flagged. For example, the installer found a Fire Wire (which is not there) but not the on-board ethernet. The system runs unbelievably slow.

Live CD performance with Knoppix or Ubuntu is similarly slow.

Memtest86 takes >12 hrs to complete, and shows very low data transfer rates. However it shows no errors.

hdmarm -tT /dev/hda shows cached reads of 18 MB/sec, and buffered reads of 3.5 MB/sec .

Will Memtest86 show this kind of result because of bad drivers, or is it a lower level test? I've tried to rule out what I think are the most likely hardware problems (moved around the IDE positions, swapped both 80wire cables, reseated boards).

Can someone recommend a good diagnostic test to run?



bigrigdriver 01-31-2007 12:13 PM

I'm not sure about this, but it may be a config issue. Is DMA enabled?

From the hdparm manpage:
-d Disable/enable the "using_dma" flag for this drive. This option now
works with most combinations of drives and PCI interfaces which support
DMA and which are known to the kernel IDE driver. It is also a good
idea to use the appropriate -X option in combination with -d1 to ensure
that the drive itself is programmed for the correct DMA mode, although
most BIOSs should do this for you at boot time. Using DMA nearly
always gives the best performance, with fast I/O throughput and low CPU
usage. But there are at least a few configurations of chipsets and
drives for which DMA does not make much of a difference, or may even
slow things down (on really messed up hardware!). Your mileage may

coldrecd 01-31-2007 01:02 PM


Thanks for your reply. The HDD (WD1600JB) was set at udma5. I tried

hdparm -d1 -X udma6 /dev/hda

this command was refused

I tried

hdparm -X34 dev/hda
this set to multiword DMAmode2, and the system hung.

I have a limited ammount of spare hardware for swapping out, and I tried another HDD. I'm installing Fedora on that now (10+ hrs), although the memtest86 results with the second HDD suggest it is not the problem.

Are you suggesting that another DMA mode might work better? I'll try that, but I suspect the problem may lie elsewhere since both cached and buffered reads are extremely slow.

Thanks again for your reply. Tinkering with this box has been fun so far, and I really appreciate your help.


marozsas 01-31-2007 01:43 PM

Looks like there is something wrong in the BIOS parameters.
Memtest is not affected by DMA settings.....

Try to reset your BIOS settings to default values and run memtest again.

coldrecd 02-06-2007 11:39 AM

Solved--thanks marozsas
Resetting the BIOS settings solved this completely.

hdparm -tT went from 18MB/sec cached to 1009MB/sec

It was not obvious in the Dell BIOS how to reset the CMOS settings. I initally re-flashed the BIOS with the same rev (A09), but this did not help.

To reset the CMOS, first enter setup and turn on Caps Lock, Num Lock, and Scroll Lock. At this point
Alt-E clears the cmos,
Alt-F loads default settings,
Alt-B reboots the system,

and from there the redetection and resetting goes smoothly.

Thanks for your help,


All times are GMT -5. The time now is 05:47 PM.