Latest LQ Deal: Latest LQ Deals
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 03-24-2007, 10:22 AM   #1
Registered: Oct 2005
Distribution: SuSe
Posts: 95

Rep: Reputation: 17
Slow DVD-RAM writes on SuSE 64-bit with Lite-on multi drive

I have an odd problem with my dvd-ram drive. It seems to recognize any disk I put in it, writes to most formats just fine, but when I read or write dvd-ram disks is very slow. It appears to write 32k,stall out for a couple of seconds, and write the next 32K, stall out, (repeat until file copied). I've tried writeing with Krusader and from the command line, logged in as a normal user.

I'm running SuSE 10.2 64 bit.
Computer is:
Daktech Discovery 6
Intel D946GZ motherboard
Pent 3.4 dual core
4gb ram
/dev/sda = 80 gb sata
/dev/sdb = 250gb sata
/dev/hda = LITE-ON DVD LH52C1P - DVD - CDRW
/dev/hdb = LITE-ON DVDRW LH-20A1H - DVDRAM (multi)

(Side note: The SuSE install saw every device on this computer perfectly except the onboard video. I had to manually change it to Intel i810 video in the xorg.conf file. The video now works perfectly.)

Disks automount correctly in both drives. Neither of the drives show in the /etc/fstab or /etc/mtab files, as hald is handling mounting. Blank media is seen ok. K3b has worked with all blank burnable media I've used so far. I've been able to read/write disks that have been used on this computer on other computers just fine.

DVD-RAM disks are recognized as UDF filesystem correctly. udf is in the /etc/filesystems file. Yast shows both optical drives to have DMA on.

The drive (/dev/hdb) seems to work correctly, just extremely slow with DVD-RAM. With CDRW media, it goes at normal speed. I use this for data, not movies. I've not installed the libdvdcss, as I don't watch movies on the computer anyway. I don't see any errors in the /var/log/messages file, so it isn't timing out,or erroring that I can tell, just takes a month of Sundays to write anything. I haven't tried writeing a 100mb file to see if it ever errors, as a 300kb file takes about 5 minutes.

Thanks in advance for any help or suggestions.
Old 03-24-2007, 11:36 AM   #2
LQ Guru
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 555Reputation: 555Reputation: 555Reputation: 555Reputation: 555Reputation: 555
Does seem a little bit odd, as most modes seem to work properly.. You could check if your BIOS offers the option of 16 or 32 bit IO on the IDE bus. If it does, is it set to 32?
Also, what's the command 'hdparm -I /dev/hdx' return for that drive (where hdx is the drive) ? Would you post the output?
Old 03-24-2007, 12:00 PM   #3
Registered: Oct 2005
Distribution: SuSe
Posts: 95

Original Poster
Rep: Reputation: 17
Output of the hdparm command:


Model=LITE-ON DVDRW LH-20A1H, FwRev=LL06, SerialNo=
Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
BuffType=unknown, BuffSize=0kB, MaxMultSect=0
(maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
IORDY=yes, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio3 pio4
DMA modes: sdma0 sdma1 sdma2 sdma? mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 *udma4
Drive conforms to: Unspecified: ATA/ATAPI-4 ATA/ATAPI-5 ATA/ATAPI-6 ATA/ATAPI-7

* signifies the current active mode

Will restart computer to get to bios, but don't remember seeing those options in the bios.

Also, with a dvdram mounted, the /etc/mtab file:

/dev/sda3 / ext3 rw,acl,user_xattr 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
debugfs /sys/kernel/debug debugfs rw 0 0
udev /dev tmpfs rw 0 0
devpts /dev/pts devpts rw,mode=0620,gid=5 0 0
/dev/sda1 /boot ext3 rw,acl,user_xattr 0 0
/dev/sdb1 /data ext3 rw 0 0
/dev/sdb2 /home ext3 rw 0 0
/dev/hdb /media/MEI_UDF udf rw,nosuid,nodev,sync,uid=1000 0 0

the /dev/hdb line is generated by hald automounting the disk.

Thanks for the quick response!!
Old 03-24-2007, 12:17 PM   #4
Registered: Oct 2005
Distribution: SuSe
Posts: 95

Original Poster
Rep: Reputation: 17
Ok, checked the bios. No settings other than boot order there relating to the optical drives.
Old 03-24-2007, 12:28 PM   #5
Registered: Oct 2005
Distribution: SuSe
Posts: 95

Original Poster
Rep: Reputation: 17
Ok, just found the problem. Not sure how to fix, but here goes:
Edit: Was incorrect.

I went to Konsole, and umounted the /dev/hdb (as root). Next I mounted it as /dev/dvdram, instead of dev/hdb. Did a cp from there, and it was very fast. Next went back to Krusader (as normal user) and it is as fast as possible. It appears that hald needs to use /dev/dvdram for DVD-RAM disks, and /dev/hdb for "normal" r and rw media.

Edit: It shows the files I copied and I can work with them, until I umount the disk, eject it, and remount it. The files still show to be there, show the correct file size, but seem to be empty. So guess the fix isn't a fix at all.

Edit2: To anyone else trying this, don't do what I did up there. I think I've corrupted this disk. I'm now getting errors in the /var/log/messages file:

Mar 24 12:41:40 cbhome hald: mounted /dev/hdb on behalf of uid 1000
Mar 24 12:41:46 cbhome kernel: udf: udf_read_inode(ino 558) failed !bh
Mar 24 12:41:46 cbhome kernel: udf: udf_read_inode(ino 437) failed !bh
Mar 24 12:42:26 cbhome kernel: VFS: busy inodes on changed media.
Mar 24 12:43:00 cbhome kernel: VFS: busy inodes on changed media.

Not sure if it was caused by the mount as /dev/dvdram, or what, but was not getting these errors before.

Last edited by chuckbuhler; 03-24-2007 at 12:47 PM.
Old 03-24-2007, 02:44 PM   #6
LQ Guru
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
After doing research about DVD-RAM, it can use other filesystems that are reliable in Linux. Linux provides several filesystems that you can use. They include, EXT2, EXT3, ReiserFS, JFS, XFS, cramfs, EncFS, and many others. If you want the disc to be read and write in Windows and write reliable in Linux, use FAT32. Like NTFS, UDF write support is experimental. Just make sure block size is 2048 bytes.
Old 03-24-2007, 03:57 PM   #7
Registered: Oct 2005
Distribution: SuSe
Posts: 95

Original Poster
Rep: Reputation: 17
Formating the disk to Fat32 seems to have worked. I'll have to take this disk to the office and try it on a Windows computer to be sure, but this is looking like a solution.

Now, the problem is, I have about 20 disks that are all formated UDF, and have data on them. If the Windows workstation can read these ok, then I guess I'll have a lot of data to transfer.

I'm still getting one error, but not sure how severe it is:

Mar 24 15:51:31 cbhome kernel: VFS: busy inodes on changed media.

The files all look ok, even after a umount and remount.

Thanks for all of your help.
Old 03-24-2007, 04:48 PM   #8
Registered: Oct 2005
Distribution: SuSe
Posts: 95

Original Poster
Rep: Reputation: 17
Just got back from the office. The windows computer read the disk fine. I copied about a GB of data to it, brought it back home, and was able to copy the new data here.

Thanks again.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
External DVD Reads and Writes REALLY Slow usaf_man Linux - Hardware 1 03-19-2007 11:15 AM
Ridiculously slow fat32 usb drive writes relpats_eht Linux - Software 5 06-30-2006 08:24 PM
x-cd-roast won't read my DVD/CD RAM drive Ryanjon7 Linux - Newbie 2 04-30-2006 01:37 AM
How can I change cdrom1 to dvd. REDhat9, lite-on LTD-163D dvd drive theonlydrew Linux - Hardware 3 01-26-2006 05:54 PM
slow dvd-ram write since kernel 2.6.8 droebbel Linux - General 1 02-12-2005 07:46 AM > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 03:57 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration