-   Linux - Hardware (
-   -   Slackware no sound - kernel problem? (

nwhite 01-02-2004 05:21 PM

Slackware no sound - kernel problem?
A problem I've had for a while, is that I get no sound. I'm pretty sure all of the modules necessary are loaded, sound.o emu10k1 ac97codec etc.
However, I get NO sound. Nothing. I suppose the soundcard is never initialised (don't know if that's the right word), as unlike Windows it never makes a little click sound when the OS is turned on, and also never emits a little sound. Not even that am I granted.
The volume control on gnome shows the correct settings etc and finds the card fine, as does kmix and everything else I try. XMMS and CDPlayer (the 2 media players I have which I know work) both happily play music, but still nothing comes from the speakers.
I'm pretty sure it's not the driver(s) at error, as when I tried with my on-board sound (810i) the exact same thing happened (using the appropriate alsa drivers). It also occurred with 8.1, and when 9.0 (which I'm now using) was released I wiped the partition and freshly installed it, but to no avail.
I can get it to work when using the original 2.4.20 bare.i included (which some applications such as nvidia's installer seem to think is 2.4.0), where for some reason it works perfectly. This is unacceptable however as using this other modules such as the graphics and modem drivers will not work as they need a kernel source to build themselves. The kernel I use at the moment is 2.4.21, built in various different configurations, all attempts to get the soundcard to work, all of which failed (including using the config file from bare.i). I've also tried using 2.4.20, even building this using the bare.i config file, which gives the same result.

I'm using the latest emu10k1 driver (which supports the Audigy 2)

PC Specs:
Intel 8120i Motherboard
Creative Audigy 2 Soundcard
Videologic ZXR-500 5.1 Speakers

Output from lsmod when in 2.4.21 kernel (when sound doesn't work)
Module Size Used by Tainted: P
ppp_deflate 3512 0 (autoclean)
zlib_deflate 18520 0 (autoclean) [ppp_deflate]
bsd_comp 4440 0 (autoclean)
ppp_async 7712 1 (autoclean)
ppp_generic 16092 3 (autoclean) [ppp_deflate bsd_comp ppp_async]
slhc 5200 0 (autoclean) [ppp_generic]
hsfbasic2 95948 2 (autoclean)
hsfserial 23188 2 (autoclean)
hsfengine 868908 0 (autoclean) [hsfserial]
hsfosspec 21756 1 (autoclean) [hsfbasic2 hsfserial hsfengine]
printer 7424 0 (unused)
keybdev 2112 0 (unused)
mousedev 4404 1
hid 19492 0 (unused)
usbmouse 2296 0 (unused)
input 3328 0 [keybdev mousedev hid usbmouse]
i810_rng 2720 0 (unused)
i810-tco 3248 0 (unused)
uhci 25968 0 (unused)
usbcore 62624 1 [printer hid usbmouse uhci]
tuner 10976 1 (autoclean)
tvaudio 13436 1 (autoclean)
msp3400 17932 1 (autoclean)
bttv 77632 0 (unused)
i2c-algo-bit 7624 1 [bttv]
i2c-core 13060 0 [tuner tvaudio msp3400 bttv i2c-algo-bit]
videodev 6112 3 [bttv]
btaudio 11020 0
emu10k1 67752 1
ac97_codec 10440 0 [emu10k1]
sound 58292 0 (unused)
emu10k1-gp 1480 0 (unused)
gameport 1484 0 [emu10k1-gp]
ohci1394 25608 0 (unused)
ieee1394 44676 0 [ohci1394]
pcmcia_core 43104 0
ide-scsi 10352 0
ne2k-pci 5888 1
8390 6800 0 [ne2k-pci]

Output from lsmod when in 2.4.20 bare.i kernel (when sound does work)
Module Size Used by Not tainted
printer 7040 0 (unused)
keybdev 1952 0 (unused)
mousedev 4212 1
hid 18596 0 (unused)
usbmouse 2008 0 (unused)
input 3200 0 [keybdev mousedev hid usbmouse]
i810_rng 2624 0 (unused)
i810-tco 3088 0 (unused)
uhci 24560 0 (unused)
usbcore 58144 1 [printer hid usbmouse uhci]
tuner 9696 1 (autoclean)
tvaudio 12188 1 (autoclean)
msp3400 15180 1 (autoclean)
bttv 67936 0 (unused)
i2c-algo-bit 6984 1 [bttv]
i2c-core 12708 0 [tuner tvaudio msp3400 bttv i2c-algo-bit]
videodev 5632 3 [bttv]
btaudio 10508 1
emu10k1 61288 3
ac97_codec 9512 0 [emu10k1]
soundcore 3332 7 [bttv btaudio emu10k1]
emu10k1-gp 1352 0 (unused)
gameport 1452 0 [emu10k1-gp]
ohci1394 16264 0 (unused)
ieee1394 30828 0 [ohci1394]
pcmcia_core 38112 0
ide-scsi 8048 0
ne2k-pci 5504 1
8390 6064 0 [ne2k-pci]

Output from lspci and dmesg are both the same in either kernel, so I presume are not part of the problem.

Using lsmod (which I don't know the details of what it's telling me) it would appear that when the kernel uses sound rather than soundcore there is a problem. However, I could be wrong, and don't know how to solve this. This problem has plagued my linux experience up to now and any help would be most welcome.

Please bear in mind I'm new-ish to linux (as without sound I'm drawn back to Windows - I know, I know), so I appologize for any errors in this.

Many Thanks,

320mb 01-02-2004 05:32 PM

have you edited the emu10k1 config file?? are your speakers digital??
the config file is usually installed to......../usr/local/etc

nwhite 01-02-2004 08:06 PM

No, I hadn't looked at the emu10k1 config file, but it turned out to already be set up ok.
And my speakers are analogue.

Thanks for the quick response.

tarballedtux 01-02-2004 10:22 PM

Double check the permissions on /dev/dsp and /dev/dsp0, I think its safe to set them to read-write-execute for all users.

chmod 777 /dev/dsp
chmod 777 /dev/dsp0


THEHERO 01-03-2004 02:41 AM

have you tried updating everything with swaret to current. I had a lot of problems with my sounblaster live card until I set up swaret to update everything including the kernel and alsa to current. Then I just ran alsaconf and everything seemed to work great.

THEHERO 01-03-2004 02:43 AM

just a thought

All times are GMT -5. The time now is 09:46 PM.